Filling credentials broken with 7.6.BETA-1

Hello,

in order to connect to my work pc I have to use a Citrix gateway. My credentials contain username, password and PIN + Token. Before Beta-1 1Password filled username, password and PIN. The cursor remained within the PIN field and I only had to enter the generated token.
The beta version fills username and inserts the PIN into the password field. The password isn't inserted and the PIN + Token field remains empty.
Here is a screenshot of the behavior of Beta-1:

This is the configuration within 1Password that worked before:

passwd1 is the 2nd form field and contains the password
passwd is the 3rd form field and contains the PIN

I've already tried to save form data again without any success.

I can't publish the URL here but could do it in private. Although I'm not allowed to share login data or create a test account for you.

Cheers,
Kai


1Password Version: 7.6.BETA-1
Extension Version: 4.7.5.90
OS Version: macOS 10.14.6
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @viswiz!

    Do you get the same behavior even after creating a new login item using the procedure shown in this support article?

  • Hi @ag_ana,

    yes, I've tried to create a new login. This makes things even worse as it just stores username and password ignoring the PIN field. Furthermore the newly stored forms data contains generic form field names that change with every site refresh instead of the fixed id of the form field.

    Here is an example - relevant fields/ids marked red:

    I remember that this happened with some versions many months or even years back until it was fixed. The new filling brain breaks it again.

    Kai

  • ag_anaag_ana

    Team Member

    @viswiz:

    Thank you for the confirmation! Can you please send us this URL in private at [email protected], so we can take a closer look for you?

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • @ag_ana I've sent an email about an hour ago but still haven't received a ticket number. I even checked my spam folder. Is this normal? I've expected to receive an automated response from some kind of ticketing system. Maybe I have to be more patient ;)

  • rudyrudy

    Team Member

    @viswiz,

    If you sent it from the same email address that you're using on the forums then I don't see it in the ticketing system either. can you try sending it to support+macbeta[email protected] ?

  • Ok. I've double checked the email address and yes, it's the same one I'm using here. Notifications about new posts work without a noticeable delay. But I haven't received a response from you email address. Just send another mail to the address rudy mentioned.

  • ag_anaag_ana

    Team Member

    @viswiz:

    Thank you! I confirm that I have managed to locate your message in our system :+1: Someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: WYI-47517-695

  • @ag_ana thank you for your support!

  • ag_anaag_ana

    Team Member

    You are welcome :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file