form that does not autocomplete

edited June 8 in 1Password X

Hi :)

My compagny is using a plateform from InnovPro for time tracking.
There is a login page that is using our AD credentials.

First problem is that I can't display the 1PX logo in the form.
Second problem is, if I use the extension directly, only the password field in filled.

Here is the HTML code for the login field :

<input type="search" size="20" name="A6" value="" onblur="clWDUtil.pfGetTraitement('A6',10,void 0)(event); " onfocus="clWDUtil.pfGetTraitement('A6',12,void 0)(event); " id="A6" class="l-15 A6 padding webdevclass-riche" placeholder="Votre identifiant" tabindex="18" autocomplete="off">

The "type" seems wrong to me. If I change it from "search" to "text", the 1PX icon appear, hourra ! But it's still not filling, only the password field is OK.

Do you see a solution to my problem ? Clearly I can't force the editor to change is code, sadly.
Tests have been done in Firefox (76.0.1) and Edge (83.0.478.45)


1Password Version: Not Provided
Extension Version: 1.19.1
OS Version: Windows 10 1909
Sync Type: Not Provided

Comments

  • ag_brandonag_brandon

    Team Member

    Hello!

    I'm sorry that 1Password isn't working correctly on this site. This is an interesting form and you're correct that 1Password is getting tripped up on the "type". Is this a publicly accessible URL that we can take a look at or a private internal site? If it is public, can you post the URL here so we can take a look at it?

  • Hey @ag_brandon !

    Thanks for the quick answer. Unfortunately, this is a private URL, locally accessible.
    Is there anything else I can provide ? Full HTML code of the form maybe ?

  • ag_brandonag_brandon

    Team Member

    Hello @Grishkaone

    Unfortunately with the URL being local and the type of the field being search there's not much we can do on our end. Allowing filling in a search type field could potentially break filling on many websites.

    Sorry about this! If you would like you can reach out to InnovPro and let them know that their product is making signing in difficult for you and can be fixed by changing the fields type, adding autocomplete-type, and using proper id and name fields.

  • I'll try this, thanks !

  • ag_anaag_ana

    Team Member

    On behalf of ag_brandon, you are welcome! :)

  • Hi !

    I reported to our IT team, who'll discuss it with the developer.
    At the same time I found a public URL : it's from another company but the form is identical (I checked the code). If you want to take a look, it's https://gj.iptime.fr/IPWEB/PAGE_SAAS/

    Have a nice day !

  • kaitlynkaitlyn

    Team Member

    Thanks, @Grishkaone! Here's what I'm seeing when I visit the URL you linked:

    Does this look right to you?

    https://gj.iptime.fr/IPWEB/PAGE_SAAS/

  • Hey !

    Look like I miss a part of the URL.

    Is this better ?

  • ag_michaelcag_michaelc

    Team Member

    That one also errors out, unfortunately. Can you tell us the steps for how you got to that URL? Some URLs are not intended to be visited directly, only accessed from somewhere else.

  • Ooook !
    Try with https://gj.iptime.fr/IPWEB : indeed it generate a unique ID in the URL every time. I just try a few times, seems OK.

  • ag_anaag_ana

    Team Member

    @Grishkaone:

    Thank you! I confirm that the URL works now :)

    I have just tested the website and I think I was able to reproduce the issue, with some differences: in your first post you wrote that you are able to fill the password field, but in my test nothing got filled. I wonder if this is maybe because the website is actually not the same, even the form is. Do you see the same behavior also on this second website, or are you able to fill something there too?

  • Hi @ag_ana :)

    I just tryed, doesn't work either.

    For the password, we use a centralized directory. So I have an item in my vault that does already contain my IDs. I think I managed to do this :
    1. Add manually the URL to the item in my vault
    2. Go to the URL, manually fill both inputs
    3. Ask the extension tu update my item with this.
    4. I'm able now to fill the password input.

    If I look in my item in the 1password main app, I see that 1P registered the input in the "web form detail" part.
    A new item named "A7" is created (that is the ID of the password input in the html code), with password field associated.

    Strangely, an A8 item is also created (still in the web form detail part) but for my own company login form, it stay empty while being filled when I updated the 1P item.

    The more I look at the html code, the more it seems bad and not at all aligned with the best practices.

  • ag_anaag_ana

    Team Member
    edited June 13

    @Grishkaone:

    Thank you for the confirmation! I will open an internal issue to report these findings, so the developers can take a look at this :+1: Thank you for all your help so far!

    ref: dev/core/core#1721

  • ag_jarekag_jarek

    Team Member

    @Grishkaone thanks for reporting this to us :smile: I was able to fix the issue that was causing 1Password to not recognize the login form on the https://gj.iptime.fr/ site. The fix will be in a future release!

  • @ag_jarek Thank you for the good news ! Sorry that you have to adapt to bad html forms, but that's why 1Password is the best :+1:

  • ag_michaelcag_michaelc

    Team Member

    @Grishkaone on behalf of Jarek, you're very welcome. He has been fixing issues incredibly quickly lately — it's pretty awesome. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file