The latest beta version not support Google Chrome Canary

Google Chrome Canary: Version 85.0.4167.0 (Official Build) canary (64-bit)

I believe it was working when I have two Google Chrome, both regular Chrome and Chrome Canary installed. I removed the regular Chrome and updated Canary to the latest, 1Password stop working.

I tried to upgrade 1Password to the latest beta build, still doesn't work.

It's exact same as described here: https://support.1password.com/code-signature/
I don't know if it's because Chrome Canary is too new (probably just upgraded today) or it's because I removed the regular Chrome that may helped to verify in the beginning.


1Password Version: 1Password 7 Version 7.6.BETA-2 (70600002)
Extension Version: 4.7.5.90
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • rudyrudy

    Team Member

    @SharkIng,

    When you say you "removed the regular Chrome", did that include removing ~/Library/Application Support/Google/Chrome ?

  • Yes, removed Google Chrome directory. There is a folder called "Chrome Canary" in the above "..../Google/" directory.

    So that's the cause? which mean i need to reinstall the regular Chrome back to get it works?

  • rudyrudy

    Team Member

    @SharkIng,

    nope, just mkdir -p ~/Library/Application Support/Google/Chrome/NativeMessagingHosts

  • Great, thanks you rudy, it works with this fold created.

  • BenBen AWS Team

    Team Member

    Great! :) Thanks for the update. On behalf of Rudy, you're most welcome. If we can be of further assistance, please don't hesitate to contact us.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file