Trying to log in "An unexpected error occurred"

steve28steve28 Junior Member
edited June 9 in 1Password X (beta)

Trying to use the 1passowrd X beta (1.20.1) When I enter my password I get this:

this happens in chrome, and Brave. The desktop app (Mac 7.6 beta 2) works, as does the non-X extension. I have tried rebooting, uninstall re-install the extension. Every once in a while it will say "please complete two factor authentication" but as far as I can tell, there's no way to do that.

Logs for the extension show this:


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • YaronYaron

    Team Member

    Hey @steve28 ,

    Can you please try logging into your account via https://my.1password.com and see if it unlocks 1Password for you?
    Some other suggestions I can think of:

    • Disable desktop app integration in 1Password X's settings (right click 1Password X extension icon on the top right of the browser -> Settings).
    • Clear the browser's cache.

    If none of these help, send us an email with the extension's log to [email protected]
    https://support.1password.com/cs/extension-console-log/

  • steve28steve28 Junior Member

    @Yaron one of the problems is that I can’t get past the login screen to set any preferences. Also, the whole time I was logging in/out of the online account

    What I have done in the mean time:

    • wiped everything from the desktop app and re-connected to my 1password.com account
    • Uninstalled/reinstalled the extensions
    • Turned off TFA on my account

    That last one allowed me to make some progress. Once I disabled TFA on my account, I was able to to get past the login - it accepted my password! However, at that point, it would briefly show me my vault, then the extension would close and would from then on just show something like “The account has not been added yet” with a big blue button to “manage accounts” - clearly it WAS added and I could access it with the desktop app.

    So I once again reset 1p desktop app, but this time I didn’t re-connect it to my online account. I logged in to the online account ... at which pint 1p -X extension offered to connect my account! I was then able to get to get to the prefs and turn off integration with the desktop app. So now, it works, but I don’t have integration with the desktop app. I will try turning that back on today

    Somehow my system got into a really bad state

  • YaronYaron

    Team Member

    Hey @steve28

    You don't need to unlock 1Password X to get to its settings. As I mentioned earlier, you can right click the 1Password X icon on the top right corner of your browser and select "Settings, even if 1Password X is locked. That will allow you to turn desktop app integration on/off regardless of the lock state.

    Secondly, you shouldn't remove/uninstall/delete your 1Password 7 desktop app. This is all about 1Password X here, and that is what you should focus. Please get your desktop app up and running with your account, then try to enable desktop app integration in 1Password X.
    If you are experiencing issues, please send me:

    Send them to [email protected] with a brief description that includes the URL of this forum discussion so we can connect the dots faster :)

  • steve28steve28 Junior Member

    Yep - thanks for the setting tip. I has noticed in the extension logs (from my post) that it was having issues communicating with the desktop app... so I thought wiping my account from there might get it going again. For some reason, it was turning off TFA that finally let it connect again. I’ll spend some time today getting everything back up (and the 1pX extension connected to the desktop app) and report back

  • YaronYaron

    Team Member

    Thank you, my teammates will take over as soon as you email us all the required files :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file