Permission Denied when updating

This issue is similar to ones I have seen here, but with a twist. I get ("got", actually, read on) the "Permission Denied" message when trying to upgrade 1Password from within the app on my Windows 10 Laptop. That had happened earlier, so I dug out the KB article and did the same steps. I turned off all antivirus software, allowed 1Password app to my firewall, made sure AppData is not hidden, tried to move the 1Password\app folder to the desktop. However, I could not move the folder. Error message says "The action can't be completed because the folder or a file in it is open in another program". I exited 1Password and tried again. Somewhere along the way I renamed that folder with no joy, so I renamed it back. Now the app won't start. So I can't try to upgrade that way.

I downloaded the latest version for windows (1PasswordSetup-7.4.767.exe) and get the original "permission denied" error message.

Suggestions? Thank you!


1Password Version: 7.4.??
Extension Version: 4.7.5.90
OS Version: Windows 10.0.17134
Sync Type: Not Provided

Comments

  • GregGreg

    Team Member

    Hi @donerwin,

    Thank you for reaching out!

    First of all, could you please specify what AV/firewall software you use on your computer?

    Secondly, if you are able to sign in to your account on 1Password.com in the browser and see all of your data there, please try to do the following:

    1) Download the installer for the latest version of 1Password 7 from here (save it, but do not launch it yet).

    2) Finish pending updates in browsers, AV/anti-malware software, or Windows.

    3) Reboot your PC.

    4) Open Start menu, type %LOCALAPPDATA%\ there and press Enter.

    5) Find 1Password folder there and move it (cut and paste) to your desktop.

    6) Launch 1Password 7.4 installer that you downloaded in step 2.

    Are you able to install and open 1Password this way? Thanks! :+1:

    Cheers,
    Greg

  • Thanks for replying!

    AV/Firewall is Windows Defender.

    I will follow the steps you outlined as soon as I can and report back here.

  • Good news! Your procedure worked. I had to do one extra step. When trying to move the 1Password folder, I got the "Folder In Use" error message again. So I opened Task Manager, and ended the Background Process called "1Password for Windows Desktop". Then I was able to move the folder. I ran the installed .exe and it worked as expected.


  • Did the error message upload?

  • Error message provided for reference. I think I am all set now.

  • bundtkatebundtkate

    Team Member

    Just for our own edification, @donerwin, did you feel like the installation (to the extent it was able to proceed at all) took a long time to process? It's clear that 1Password itself was restarted, which can happen if the install or update takes longer than I think ~20 sec because the browser extension will attempt to reconnect and ask the desktop app to launch when it can't. Otherwise, though, the installer/updater should quit the application thus allowing that update to proceed. I'm curious if that might explain your experience or if there's something more going on that might merit a closer look.

  • I can't be certain, but I think it is something else. The initial problem was rooted in the "Permission Denied" error message. Once I performed the steps above (including ending the Background Process called "1Password for Windows Desktop"), the installation seemed to go very quickly. It did take several minutes for my data load, but once it did, everything is working as it did before trying the update. Thanks for following up. I am happy to provide any more data if it is helpful. I need to update 1Passowrd on my second laptop, so I can let you know how that goes.

  • GregGreg

    Team Member

    Hi @donewin,

    It is good news that you are all set now. Do you have the exact same issue on your second laptop? Please confirm. Thanks! :+1:

    ++
    Greg

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file