1PasswordX Will Not Open in Firefox

adambeckadambeck
edited June 22 in 1Password X

I'm using Firefox Developer Version 78.0b9 (64-bit) and the extension, when clicked, doesn't open. I've tried checking the console for some sort of error but I'm getting nothing there either. I'm not too familiar with debugging extensions so maybe I'm missing something.

I have tried uninstalling/reinstalling the 1PasswordX add-on as well as the Firefox browser itself. The extension is "Allowed" to "Run in Private Windows". I think this is significant because if this option is set to "Don't Allow" I do not see the extension at all -- even though the default is not a private window.

Another thing of note is that the extension does work in the same Firefox version on Windows 10 Pro version 1909. So something related to being ran in Ubuntu?

Any suggestions would be greatly appreciated!


1Password Version: Not Provided
Extension Version: 1.19.2
OS Version: Ubuntu 20.04 LTS
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @adambeck! Welcome to the forum!

    Are you seeing this issue both in private and non-private windows in Firefox?

  • Yes I am seeing this in both private and non-private windows. To clarify my earlier statement, the default for Firefox is a non-private window. However, without "Allowing" "Run in Private Windows" I am unable to see the extension at all.

    "Don't Allow" "Run in Private Windows" + non-private window = no extension displayed. (unexpected)
    "Allow" "Run in Private Windows" + non-private window = extension displayed but will not open. (should open)
    "Don't Allow" "Run in Private Windows" + private window = no extension displayed (expected)
    "Allow" "Run in Private Windows" + private window = extension displayed but will not open (should open)

  • ag_anaag_ana

    Team Member

    @adambeck:

    Thank you for the clarification! Do you mind sending us the logs you looked at, so we can take a look at them too? You can email them to us at [email protected] The specific instructions for Firefox are here.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • adambeckadambeck
    edited June 22

    The instructions you sent were the instructions I used to look at the logs. However, there isn't anything being logged. I click the extension and I can see the animation of the click but the extension does not open (i.e. the window to enter my master password is not displayed). In the developer console I have Errors, Warnings, Logs, Info, and Debug selected and nothing shows up.

    Edit: ~after restarting the browser I am seeing two messages now. I will email those to the supplied address.~ I cleared the logs and attempted to get the errors again and cannot reproduce. Back to square 1 -- no logs when attempting to open the extension.

    Thank you for your help!

  • ag_anaag_ana

    Team Member

    You are welcome @adambeck! Thank you for the update and please keep us posted and we'll get to the bottom of this ;)

  • @ag_ana sorry I was unable to recreate the console statements so I believe they came from a different extension.

    I noticed on browsers where it is working I receive something like

    Initializing 1Password X... background.js:2:1691836
    Finished initializing stable 1Password X 1.19.2 in firefox (20114) background.js:2:1692454
    crypto tests: 37ms - timer ended
    

    However, I don't even get this in the Firefox Developer Edition.

  • ag_anaag_ana

    Team Member

    @adambeck:

    Do you perhaps have other extensions installed in this Firefox browser? I wonder if there might be something else in this browser that is interfering with 1Password X, especially if things are working in Firefox on your other system.

  • adambeckadambeck
    edited June 22

    I do have other extensions installed. I just went through and disabled them all and restarted the browser -- still nothing. I did just notice that there is a banner with the message when entering the plugin debugger.

    Your browser configuration is not compatible with Service Workers. Learn more
    

    The "Learn More" links to https://developer.mozilla.org/en-US/docs/Tools/about:debugging#Service_workers_not_compatible and I checked my about:config and dom.serviceWorkers.enable is set to true.

  • So I ran Solution 1 from here: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

    And it seems to be working. Not sure exactly what happened as I hadn't adjusted any settings. Thank you for help!

  • ag_anaag_ana

    Team Member

    You are welcome @adambeck, and thank you for the update! I am glad to hear this :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file