Does not autofill all fields on IRS direct pay site

When using Direct Pay on the IRS website (for estimated payments and regular returns: https://directpay.irs.gov/directpay/payment?execution=e1s2) - 1password does not auto fill all the fields. Confirm last name is not filled, SSN and Date of Birth are all blank after autofill.


1Password Version: Not Provided
Extension Version: 1.20.0
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:Does not autofill all fields on IRS direct pay site

Comments

  • When using Direct Pay on the IRS website (for estimated payments and regular returns: https://directpay.irs.gov/directpay/payment?execution=e1s2) - 1password does not auto fill all the fields. Confirm last name is not filled, SSN, confirm SSN, and Date of Birth are all blank after autofill. Once you make it past that page - the routing and account number for your bank info also does not get autofilled.

  • ag_anaag_ana

    Team Member

    Hi @tylercal!

    I wanted to test the website but it looks like it's not working at the moment:

    In the meantime, can you confirm how you are trying to fill the information on those pages? Is it with a Login item or with an Identity item?

  • Try https://www.irs.gov/payments/direct-pay - that should be working, just select 1040 payment for tax return.

    I'm using the Identity autofill - although how can you get SSN's to autofill? There doesn't seem to be an autofill option on the SSN item.

  • ag_anaag_ana

    Team Member
    edited July 12

    @tylercal:

    Thank you, the new link worked!

    I'm using the Identity autofill - although how can you get SSN's to autofill? There doesn't seem to be an autofill option on the SSN item.

    An Identity item might not always be able to fill every field, especially if it's a custom one like the SSN. I will let the developers know and see if there is anything we can do on this website :+1:

    ref: dev/core/core#2004

  • Thanks - I think confirm last name and DOB should still be autofilled as they aren't custom.

  • ag_yaronag_yaron

    Team Member

    Thanks for the additional info @tylercal .

    "Confirm last name" is a very rare occurrence, I don't think we ever brought it up as a possible scenario but thanks for pointing that out. Perhaps our developers will be able to improve 1Password accordingly.

    Thanks again for reporting this website!

  • I think part of the issue is that 1Password completely disables Chrome’s builtin autofill which remembers values for any field that doesn’t set autocomplete off. Chrome isn’t perfect at autofill either, but it would be nice to have both working as together they cover more scenarios. And coming from LastPass where I had both autofill systems on I found filling forms automatically faster and more effective than 1Password alone.

  • ag_michaelcag_michaelc

    Team Member

    Hey @tylercal, if you want to still use the built-in password manager, head to the Settings page for 1Password X (right-click the toolbar icon, choose Settings), and turn off "Make 1Password the default password manager".

  • Odd - I thought I had tried that before and it had the effect of disabling 1pw auto-fill. But testing it again, it does appear to do what I want.

  • ag_yaronag_yaron

    Team Member

    We're glad to hear it does work as you want it now :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file