--silent doesn't finish install from cmd/powershell

The install of the non/beta versions of the software won't finish install unless the program is killed via stop-process or right-click menu. This makes it very hard to install via terminal/powershell installation scripts. Thanks for any help.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @Redbaron2!

    Just so I understand your suggestion: are you asking if the 1Password installer can quit itself automatically, so you don't have to do this manually?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @redbeard20,

    Thanks for reporting this.

    I just ran 1PasswordSetup-7.6.779-BETA.exe --silent and it installed silently for me in both Powershell and CMD.

    Can you tell me what you see instead?

  • @ag_ana
    Yes, that is it exactly. If I am looking for a valid exit code from the installer. It never gives one, until the program is terminated.
    @MikeT
    What I'm seeing is that no exit code of "0" is sent. (This is a normal Successful Install exit code) The program just starts running, and therefore the install program never finishes until the program is stopped.

  • MikeTMikeT Agile Samurai

    Team Member

    @Redbaron2,


    It shows 0/true for me.

    If you can give us the precise steps to reproduce this, we can look into it but so far, both CMD and Powershell is showing 0 for us after installing the app.

    Just to be clear, when you run the command directly, did it return you to the prompt?

  • @MikeT
    This is the Chocolatey Log file:
    2020-07-21 15:10:00,506 3060 [DEBUG] - RunningStart-ChocolateyProcessAsAdmin-validExitCodes '0' -workingDirectory 'C:\Users\rbtec\AppData\Local\Temp\chocolatey\1password\7.6.779-BETA' -statements ' --silent' -exeToRun 'C:\Users\rbtec\AppData\Local\Temp\chocolatey\1password\7.6.779-BETA\1PasswordSetup-7.6.779-BETA.exe' 2020-07-21 15:10:00,513 3060 [DEBUG] - Unable to use current location for Working Directory. Using Cache Location instead. 2020-07-21 15:10:00,531 3060 [DEBUG] - Test-ProcessAdminRights: returning True 2020-07-21 15:10:00,541 3060 [DEBUG] - Elevating permissions and running ["C:\Users\rbtec\AppData\Local\Temp\chocolatey\1password\7.6.779-BETA\1PasswordSetup-7.6.779-BETA.exe" --silent]. This may take a while, depending on the statements.
    This is when I Stopped the 1password located in the taskbar area. Please note the time 15:10:00 and the time 15:23:59 when the process for the chocolatey log resumes. Clearly there is a disconnect between calling the setup this way.
    2020-07-21 15:23:59,144 3060 [ERROR] - [2020-07-21 15:10:00.774567 -07:00] INFO [opw_starter] opw-starter\src\main.rs:174: Starting fresh installation to 1Password 7.6.779 2020-07-21 15:23:59,147 3060 [ERROR] - [2020-07-21 15:10:00.774567 -07:00] INFO [opw_starter] opw-starter\src\main.rs:476: Setup logs path set to : C:\Users\rbtec\AppData\Local\1Password\logs\setup 2020-07-21 15:23:59,159 3060 [ERROR] - [2020-07-21 15:10:00.947274 -07:00] INFO [opw_starter] opw-starter\src\main.rs:238: Copying files to C:\Users\rbtec\AppData\Local\1Password\update 2020-07-21 15:23:59,161 3060 [ERROR] - [2020-07-21 15:10:00.948274 -07:00] INFO [opw_starter::transaction] opw-starter\src\transaction.rs:72: copying files to: C:\Users\rbtec\AppData\Local\1Password\update\7 2020-07-21 15:23:59,162 3060 [ERROR] - [2020-07-21 15:10:01.207495 -07:00] INFO [opw_starter] opw-starter\src\main.rs:242: Renaming C:\Users\rbtec\AppData\Local\1Password\app to C:\Users\rbtec\AppData\Local\1Password\previous 2020-07-21 15:23:59,165 3060 [ERROR] - [2020-07-21 15:10:01.207495 -07:00] INFO [opw_starter::transaction] opw-starter\src\transaction.rs:116: renaming C:\Users\rbtec\AppData\Local\1Password\app to C:\Users\rbtec\AppData\Local\1Password\previous 2020-07-21 15:23:59,166 3060 [ERROR] - [2020-07-21 15:10:01.373282 -07:00] INFO [opw_starter::transaction] opw-starter\src\transaction.rs:159: renaming C:\Users\rbtec\AppData\Local\1Password\app to C:\Users\rbtec\AppData\Local\1Password\previous 2020-07-21 15:23:59,168 3060 [ERROR] - [2020-07-21 15:10:01.374282 -07:00] INFO [opw_starter] opw-starter\src\main.rs:250: Renaming C:\Users\rbtec\AppData\Local\1Password\update to C:\Users\rbtec\AppData\Local\1Password\app 2020-07-21 15:23:59,170 3060 [ERROR] - [2020-07-21 15:10:01.374282 -07:00] INFO [opw_starter::transaction] opw-starter\src\transaction.rs:159: renaming C:\Users\rbtec\AppData\Local\1Password\update to C:\Users\rbtec\AppData\Local\1Password\app 2020-07-21 15:23:59,172 3060 [ERROR] - [2020-07-21 15:10:01.379279 -07:00] INFO [opw_starter] opw-starter\src\main.rs:267: File copying completed successfully! 2020-07-21 15:23:59,176 3060 [ERROR] - [2020-07-21 15:10:01.379279 -07:00] INFO [opw_starter] opw-starter\src\main.rs:327: starting C:\Users\rbtec\AppData\Local\1Password\app\7\1Password.exe setup 2020-07-21 15:23:59,178 3060 [ERROR] - [2020-07-21 15:10:01.825021 -07:00] INFO [opw_starter] opw-starter\src\main.rs:148: Installation completed successfully! 2020-07-21 15:23:59,184 3060 [DEBUG] - Command ["C:\Users\rbtec\AppData\Local\Temp\chocolatey\1password\7.6.779-BETA\1PasswordSetup-7.6.779-BETA.exe" --silent] exited with '0'. 2020-07-21 15:23:59,192 3060 [DEBUG] - Finishing 'Start-ChocolateyProcessAsAdmin' 2020-07-21 15:23:59,195 3060 [INFO ] - 1password has been installed. 2020-07-21 15:23:59,198 3060 [DEBUG] - ---------------------------------------------------------------------- 2020-07-21 15:23:59,203 3060 [DEBUG] - Built-in PowerShell host called with ['[System.Threading.Thread]::CurrentThread.CurrentCulture = '';[System.Threading.Thread]::CurrentThread.CurrentUICulture = ''; & import-module -name 'C:\ProgramData\chocolatey\helpers\chocolateyInstaller.psm1'; & 'C:\ProgramData\chocolatey\helpers\chocolateyScriptRunner.ps1' -packageScript 'C:\ProgramData\chocolatey\lib\1password\tools\chocolateyInstall.ps1' -installArguments '' -packageParameters '''] exited with '0'.

    I can see that it returns a 0 to the script, but what is the lag in reporting back to the calling script?

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 21

    @Redbaron2, is that your script or did you use Chocolatey's package for 1Password (we don't host any 1Password files outside of our site)? First, test without using any third party scripts, we don't provide any support for third party tools, we can only help with what 1Password itself is doing.

    I notice in the first line, it said this:

    -statements ' --silent'

    Is that supposed to have the space at the beginning? I'm not sure if it is properly encoded.

    The reason I'm bringing this up is that the following installation log you see is what happens without the --silent successfully used. So, the delay is because it is writing logs and starting the app with UI visible this way, so it will never exit with 0 until you exit the app. This is all expected without --silent.

    First, make sure that you are able to successfully install it silently on your own without any third party tools.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file