State Farm/Hewitt web site form issues

I'ver been through the dance before with this website but the latest update to 1Password seems to have broken it again. 1Password captures the userid on the form (which is encrypted when entered) into the Password field in 1Password and the password on the form into a custom web field. When I try to use the login in Safari (on the Mac) or Chrome (on Windows), the web site UserID field is left blank and the actual userid (captured as the password by 1Password) is put into the website Password field. I end up having to enter the userid manually and copy/paste the actual password from 1Password.

Custom web field with the actual password

_ParticipantLogon20_WAR_ahcommonauthportlet_password

Website url

https://leplb0300.portal.hewitt.com/web/statefarm/login?linkId=LOG_ON_LINK&technicalNameForLink=LOG_ON_LINK&userFriendlyNameForLink=Log On&domain=Ben-CM&baseClientIndicator=Base#/routing


1Password Version: 7.6 (70600005)
Extension Version: 7.6
OS Version: macOS 10.14.6
Sync Type: 1Password

Comments

  • ag_anaag_ana

    Team Member

    Hi @tannebil!

    I'ver been through the dance before with this website but the latest update to 1Password seems to have broken it again.

    Just so we have all the information, how did you manage to fix this before? Did you manually edit this login item perhaps?

  • Sorry, I thought I responded but must have left the response hanging in one of my (way too many) browser tabs.

    Unfortunately, I don't remember what I did although the one that was working ended up with has three custom web fields and the password field (which actually has the password in it. No username field was captured.

    The two other custom fields are _ParticipantLogon20_WAR_ahcommonauthportlet_userid (value is the correct userid with a "head") and _ParticipantLogon20_WAR_ahcommonauthportlet_useScreenReaderCheckbox (which is blank). Both the ..._userid and ..._password files are marked as type password.

    When I use the login on the web site (both Safari and Chrome/Win 10), the Password field gets filled in correctly but the UserID field is left blank. If I type in the UserID manually, it works fine.

    If I manually capture a new login, it doesn't capture a UserID field, it properly captures the Password field, and captures two custom for fields: _ParticipantLogon20_WAR_ahcommonauthportlet_password saved for field (type=password with a "key"), and _ParticipantLogon20_WAR_ahcommonauthportlet_useScreenReaderCheckbox (type=Checkbox, value is unchecked).

    If I use the new login item, it doesn't fill in the userid field but does fill in the Password field.

    If I manually add the _ParticipantLogon20_WAR_ahcommonauthportlet_userid field, the userid field is still left blank.

    If I change the _ParticipantLogon20_WAR_ahcommonauthportlet_userid to have the "head" tag, nothing changes.

    If I changed the _ParticipantLogon20_WAR_ahcommonauthportlet_userid to have the "key" tag, it fills in the userid field properly but now the password field is left blank.

    I tried to look at the web page but the contents are way beyond my skill level.

    I need a login item that has two passwords. I actually tested it by using the login that did the password followed by the login that did the userid and it worked fine. Or maybe a way to chain two logins?

  • ag_anaag_ana

    Team Member
    edited July 20

    @tannebil:

    Thank you for the additional information! I managed to reproduce this issue on that website, so I will open an internal issue for our developers to look at. Let's see if there is something we can do here despite the strange login form :+1:

    ref: dev/core/core#2107

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file