Directly filling login isn't possible anymore

Using the beta of 1password X and the desktop app, when I use my global keyboard shortcut for "filling login or show 1password", as configured in the settings for the desktop app, it no longer directly fills the login field, even when there is only one account. Instead, it shows the 1Password popup and asks me to choose an account.

Expected Behavior: When I use the non-beta desktop app with the other (not 1password x) extension, the autofill will fill the field without showing the popup. This is what I expect to happen when there's only one plausible account.


1Password Version: 1Password 7 Version 7.6.1.BETA-0 (70601000)
Extension Version: 1.21.1 (1Password X Beta on Chrome)
OS Version: MacOS 10.15.5
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @jeffkmeng .
    The behavior you are describing is only possible if using the companion extension, not 1Password X (and not 1Password X beta).

    1Password X (and beta) should show up directly inside the username/password field with a popup of the relevant login(s), clicking on the suggested login(s) or moving with your keyboard and hitting Enter on the suggested login(s) will autofill it immediately, without needing to press a keyboard shortcut or opening 1Password.

    Is that not what you're experiencing? Does 1Password X not show up inside the fields of the website you try to log into?

  • Hi @ag_yaron,

    Yes, I do see the 1Password X button inside the field. However, when I use the autofill keyboard shortcut, it also (partially) works. It shows the popup that allows me to select an account to fill (with a filter to only show accounts for the current URL).

    I'm hoping that the desktop integration on 1Password X will keep support for the keyboard shortcut because I prefer that over the button in the input field (however I'm using the beta because I like the functionality for generating new passwords and because I think it looks a lot better.

  • ag_yaronag_yaron

    Team Member

    Hi @jeffkmeng ,

    When you press the keyboard shortcut, it calls the 1Password 7 desktop app. It cannot autofill immediately in the browser without prompting you to select a proper login - that ability only exists in the companion extension, as mentioned earlier.

    1Password X has its own shortcuts, such as CMD+SHIFT+X if you're on Chrome, or CMD+. (command + period) in Firefox. However, this shortcut won't autofill - it will show 1Password X's popup.

    Personally, when I load a login page, 1Password X shows up immediately in the field, and I use the keyboard to navigate (up down arrow keys) and hit Enter when I get the login I need.

    And yes, I also prefer 1Password X's interface and passwords suggestions over the old companion extension, but if you're adamant about using the CMD+\ keyboard shortcut to autofill, you'll want to disable 1Password X and install the companion extension instead. This is not something we plan on implementing in 1Password X in the near future as far as I know, but I'll mention it to the developers and see what they think.

    Thanks for bringing this up!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file