Feedback on the UI / UX of the Safari Inline Menu

13»

Comments

  • Gilles9Gilles9 Senior Member

    @rudy
    "There will be a checkbox in preferences that controls that setting and a couple others, probably in the next beta."

    that is even better
    Thank you

  • BenBen AWS Team

    Team Member

    :+1::)

    Ben

  • So my question is, what time frame do you expect the next beta? I'm fine if it takes awhile, because if this is a definite, I would rather wait than use the command line to get the result then have to change it again once the change is implemented. The reason being is that when a new update pops up it doesn't ask me to implement the update. It just does it, and that could interfere with subsequently removing the original command line after the fact(?)

  • BenBen AWS Team

    Team Member

    @DrSFG

    I don't have an estimate on the next beta update, though I wouldn't expect it to be terribly far away.

    Ben

  • Thanks. In that case I'll wait.

  • I am not a fan of this at all. It feels intrusive, it takes over my input behavior by autofilling, stealing focus, removing screen space and doesn't allow me to feel like "I'm in control" of my browser any longer. Having used this for roughly a week, my feedback is: If this is the path of the extension, I can no longer be a user. Sorry.

  • I kind of hate the new update to the extension overlapping the safari autofill suggestions. I would prefer safari over 1Password for non password type fields. And I have some passwords just in Apple key chain and it's frustrating to dismiss 1Password/keychain. Please add a preference to disable/just show for passwords.

    But I love the update to extension though like suggestion.


    1Password Version: 1Password 7 Version 7.7.BETA-1 (70700001)
    Extension Version: Not Provided
    OS Version: 10.15.6
    Sync Type: iCloud

  • BenBen AWS Team

    Team Member
    edited July 28

    @DrSFG

    :+1:

    @jbergstroem

    Thanks for letting us know your thoughts. It is possible to hide the inline menu until you click on the 1Password icon in a field. More details on that can be found here.

    @kamthamc

    While we don't support using Safari's password manager alongside 1Password, and there are known conflicts, the advice I offered just above may be of some help to you. Generally our recommendation is to turn off the built-in password manager in your browser, but you may want to try hiding 1Password's inline menu until activated to see if that works better for you.

    Ben

  • Thank you Ben for the quick response. My Problem is the little password icon covers the key icon in the text field (right side). And the 1Password popup shows up without even clicking the 1Password icon on the right. I will try to override the settings as provided in the comment.

  • ag_anaag_ana

    Team Member

    @kamthamc:

    As Ben said, we do not support leaving both 1Password and Safari autofill enabled at the same time. If you would like to do this regardless, you will have to disable the setting manually for now.

  • r8ders2kr8ders2k Junior Member
    edited July 28

    @Ben Thanks for the Terminal command, love it! But why does the Unlock 1Password show up? As you have to click that before you get to the actual unlock field. Why not just go straight to the unlock field? Oh and yes, please add that Terminal command to 1Password's Preferences.

  • BenBen AWS Team

    Team Member

    Oh and yes, please add that Terminal command to 1Password's Preferences.

    We're working on it. :)

    But why does the Unlock 1Password show up? As you have to click that before you get to the actual unlock field. Why not just go straight to the unlock field?

    I believe at least part of the answer here is that for folks with Touch ID / Apple Watch unlock enabled ... that would be a less than ideal experience. I'll check with the team and see if we can get more details though.

    Ben

  • BenBen AWS Team

    Team Member

    @r8ders2k

    I spoke with the team and have a better understanding of why we can't put the Master Password field where you see the "Unlock 1Password" button. The problem is that button is part of the website you're viewing (it is injected into the website by 1Password). If we were to have the Master Password field there, then any scripts running as part of the page could snoop on your entry. Also, because of this, any web page could make a popup that looks just like our popup. If you're used to entering your Master Password in such a popup... that leaves you open to phishing.

    Ben

  • r8ders2kr8ders2k Junior Member

    @Ben Copy that, thanks!

  • BenBen AWS Team

    Team Member

    You're very welcome. :)

    Ben

  • rwarwa Junior Member

    The preference to disable this in 7.7b2 is great. Thanks.

  • ag_tommyag_tommy

    Team Member

    We're glad to hear you found it useful. :chuffed:

  • r8ders2kr8ders2k Junior Member

    @Ben Quick questions, do I have to re-use the Terminal command [ defaults write com.agilebits.onepassword7 SAEAutoShowInlineMenu -bool NO ] each time a new beta is released or is it remembered/carried over to the next update?

    Also, if I choose to hide the in-line icon

    How do I bring it back...?

  • ag_anaag_ana

    Team Member

    @r8ders2k:

    The setting should remain valid even after an update.

    To show the inline menu again on a page where you previously hid it, it's enough to quit 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and then relaunch 1Password.

  • The new inline feature feature is amazing, is it possible to have that for Firefox and Chrome also?

    I do not use 1Password X (which already has this feature), as I use both Safari and Firefox at the same time. So I am using the normal 1Password add-on to have same unlock and shortcuts across browsers

  • BenBen AWS Team

    Team Member
    edited August 5

    Hey @ckarthik17

    That may be possible in the future, though I couldn't make any promises yet. :) Thanks for the kind words!

    Ben

  • I think the time has come to disable the plugin in Safari for 1Password until this popup goes away. It has gotten to the point beyond annoying. Regardless if a user leverages Safari Keychain or not, this darn thing shows up for any field [password related or not] getting in the way all the time. 1Password really should stop bringing this pop up automatically and go back to how it used to be not having this come up constantly in every field and let the user determined when to use by bringing it up using right mouse click. Very very very extremely annoying.

  • rudyrudy

    Team Member

    @Julio Bouza,

    To continue to be able to use mini and fill in safari you'll want to leave the extension enabled, but turn off the inline menu option on the 1Password Preferences' browser tab.

  • rudyrudy

    Team Member

    @ckarthik17,

    The inline menu will not be coming to the existing "desktop application required" extensions.

  • @ckarthik17 AHHH Thanks G-D ROFL. Didn't notice that. I was looking for an option on the Extension side in Safari vs the preference on the app. I am less annoyed now lol. TY. This darn thing has been driving me nuts SIGH.

  • ag_tommyag_tommy

    Team Member

    @Julio Bouza

    Its great to hear you found the tip helpful.

  • I must admit, I actually quite like the inline menu, but, I have noticed there are a number of websites where it doesn't work, and the Command and Backslash combination is more reliable in that regard...

  • ag_anaag_ana

    Team Member

    Thank you for the feedback @gussic! If you found websites where the inline menu does not behave as expected, please feel free to open separate discussions here in the forum and share the URLs there. We are happy to test websites and see if there is anything we can do :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file