Go & Fill opens incorrect site in new tab in 7.7.BETA-1

spearlmutterspearlmutter Junior Member
edited July 24 in Mac Beta

I'm used to using Go & Fill in Safari w/1Password (Cmd-Opt-\). Starting with 7.7.BETA-0, when I do this, a new tab opens in Safari with the same page as the tab that was currently in the foreground.

For example, if I currently have www.google.com as the foreground tab, do Cmd-Opt-\, select a login, hit Return, Safari opens a second tab with www.google.com.


1Password Version: 7.7.BETA-1
Extension Version: 7.7.BETA-1
OS Version: MacOS 10.15.5
Sync Type: WLAN

Comments

  • Hi there.

    I’ve noticed that with the recent 7.7 betas, when I hit Command-\ to “Go” to another site and login, unless my current tab is new (empty), 1Password just duplicates whatever tab I currently have open, rather than creating a new tab and loading the requested site.

    I can duplicate this issue in Safari 13.1.1 (13609.2.9.1.3), Chrome 84.0.4147.89, and Vivaldi 3.1.1929.45

    On my other laptop (also running High Sierra, the same browser versions, and the same release of the 1Password Extension), 1Password is working correctly. The only difference is that I am still running the 7.6.Beta-4 application on that computer.

    Happen to provide more details or testing as require.

    Thanks.


    1Password Version: 7.7.Beta-1
    Extension Version: 4.7.5.90
    OS Version: macOS 10.13.6
    Sync Type: 1Password

  • ag_anaag_ana

    Team Member
    edited July 25

    @spearlmutter, @Grant Hutchinson:

    I have merged your discussion into one since you are reporting the same behavior. I have managed to reproduce this issue in the latest beta too, so I will open an internal issue so our developers can look at this :+1:

    Thank you both for the report!

    ref: dev/apple/issues#4915

  • @ag_ana, thanks for confirming the issue. I look forward to testing the imminent fix.

    Cheers!

  • ag_anaag_ana

    Team Member

    You are welcome @Grant Hutchinson!

  • spearlmutterspearlmutter Junior Member

    Thanks @ag_ana !

  • Bill.Bill. Junior Member

    Glad to get here and see that this issue has already made it to the developers. A temporary workaround is to click on the website field instead of the Go button. That link seems to be working OK.

  • ag_anaag_ana

    Team Member

    You are welcome too @spearlmutter, glad to help :)

  • ag_anaag_ana

    Team Member

    Thank you for sharing the workaround with the community @Bill. :+1: That indeed seems to be working.

  • ag_anaag_ana

    Team Member

    @spearlmutter, @Grant Hutchinson, @Bill.:

    I wanted to send you a quick update to let you know that this has been fixed in the latest 1Password for Mac beta, version 7.7.BETA-2 (70700002):

    Fixed an issue that would cause 1Password mini to open the existing page URL when hitting the Go button instead of the URL from the item. {#4915}

    The update should already be available for you to download ;)

  • Bill.Bill. Junior Member

    Confirmed. Thank you ag_ana.

  • ag_anaag_ana

    Team Member

    You are very welcome @Bill. :)

  • Can also confirm … works like a charm!

  • ag_anaag_ana

    Team Member

    That's great to hear @Grant Hutchinson :)

  • spearlmutterspearlmutter Junior Member

    Me too! Thanks to the team for the quick turn-around!

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation as well @spearlmutter :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file