Configuring Safari to get rid of annoying notification

edited July 29 in Mac Beta

macOS 10.14.6
Safari Version 13.1.2 (14609.3.5.1.5)
1Password 7 Version 7.7.BETA-1 (70700001) 1Password Beta

I'm using the latest beta of 1P along with an up-to-date version of Safari, and everything is working well. I especially like the dialogues that appear, avoiding the need to press Cmd . However, I've noticed that with some, not all, websites, Safari is popping up an extra unwanted dialogue...

I'm assuming that I need to use Safari -> Preferences -> Websites to configure this behaviour, but it isn't clear which of these options I should change...

I established email contact with Brent, but haven't heard back from him, so I thought I would throw this one out to everyone 😉

Cheers,
Carl


ref: REZ-96176-957

Comments

  • Annoyingly the problem has stopped on one of the offending websites, but not at the same time as any change I have made to Safari preferences. I don't know if this change in behaviour is because of the change in Safari or a change in 1Password - the lack of synchronisation makes it difficult to establish patterns of cause and effect, which is never handy when trying to solve software problems, I've found 🙃 It would be so much easier if someone could definitely say "this is the option you need to change"...

  • rudyrudy

    Team Member

    @carlcaulkett,

    Since you're already having a conversation with Brenty about this, lets keep the conversation there for now.

  • brentybrenty

    Team Member
    edited July 31

    In case it helps anyone else, you'll get these prompts any time you're filling a Credit Card or Identity, as well as any time you're filling an item into a site where the form you're filling into does not match the website URL(s) you've saved in the Login item you're attempting to fill (e.g. if the form is at google.com, the Login must also have a google.com URL in order for this security notice to not be triggered when filling). Cheers! :)

This discussion has been closed.