Why ~70% continuous CPU usage?

jdwxjdwx
edited September 12 in Mac

Why is 1Password 7 using ~70% of a CPU core continuously? (152 CPU core-hours' worth total!)


1Password Version: 7.6
Extension Version: Not Provided
OS Version: macOS 10.15.6
Sync Type: 1Password Cloud

Comments

  • ag_anaag_ana

    Team Member

    Hi @jdwx!

    I am not seeing this here:

    But from your screenshot, it looks like you haven't rebooted or relaunched 1Password in a very long time. Can you please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and then relaunching it? Do you see the same behavior then?

  • jdwxjdwx
    edited September 14

    152 hours is 70% of about nine days (152/0.7/24 = ~9.04). I'm not sure nine days is "a very long time" but I guess opinions on that can vary.

    Restarting, meanwhile, doesn't fix software bugs but it does destroy any ability to investigate the issue.

    Is there a specific definition of "a long time" that is considered good enough that problems that occur after that point need not be reported?

  • BenBen AWS Team

    Team Member

    @jdwx

    Not at all. My apologies. I think Ana was just trying to help you get back to a good state. Certainly, particularly if the issue persists or reoccurs, we'd want to troubleshoot further. I'd like to get a sample from 1Password on your computer. While this is occurring please do the following:

    1. Open Activity Monitor from the Utilities folder of your Applications folder, or use Spotlight to find it.
    2. Search for "1Password 7".
    3. Select it and choose "Sample Process" from the Gear icon in the toolbar.
    4. When it is finished, save the sample to a file.

    Additionally I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Please note that these reports are "snapshots in time," so if the problem is not occurring when they're generated they are unlikely to provide information of any value in tracking this down. Attach the diagnostics along with the sample to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/115802/why-70-continuous-cpu-usage#latest
    • Your forum username: jdwx

    That way I can "connect the dots" when I see the diagnostics in our inbox. You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here. Thanks very much!

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file