Always asks for Password, even with AutoLock OFF

JDWJDW Junior Member
I've come to find that 1PSW4 always asks me for my password when I switch to another app and then switch back. It does that despite the fact that I have Auto Lock turned off. (I also have the Quick Unlock Code turned off too.) This is very troubling to me because I decided in the last few days to increase the security of my master password from 9 digits long to 19 digits long.

Previously when I was using 1PSW3 on my iPad3, 1PSW3 would ask me every now and then for my password, even with Auto Lock set to Off. But the big difference between 1PSW3 and 1PSW4 is that 1PSW4 asks me for it every single time I switch to an app and then switch back to 1PSW. 1PSW3 never started doing that until I launched another 7 or 8 apps, which I assume caused iOS to put 1PSW3 into standby. but again, that's not the case with 1PSW4.

I know for a fact that this problematic 1PSW4 behavior is NOT a RAM related problem. You see, even if I only have Mail, Safari, and 1PSW4 open, 1PSW4 will still ask me for my password when I switch to Mail or Safari (even for a split second) and the switch back to 1PSW. Furthermore, I have an app called "System Status" which reports very accurately to me how much memory is being used and how much memory is free. That app informs me that 28% of my RAM is free, which translates into 279 MB free.

I even tried killing the 1PSW4 app and relaunching it, but that didn't solve anything. So after much testing, it appears that this is a bug in 1PSW4 that prevents the "Auto Lock = Off" setting from being recognized. Your kind assistance in addressing this bug would be greatly appreciated.

Thanks.

Comments

  • roustemroustem AgileBits Founder

    Team Member
    I wonder if you have the "Lock On Exit" option enabled?
  • JDWJDW Junior Member
    Hi Roustem,

    Oh that naughty little asterisk is there all right (indicating "Lock on Exit" is active), but I can't get it to go away. And yes, I went through every single option in that menu one-by-one (1 min. ~ 30 min., and NEVER), but that persistent asterisk remains. I don't see anything in your documentation that really helps me to resolve this problem either:

    http://learn.agilebits.com/1Password4/iOS/Settings/ios-auto-locks.html

    If this is truly not a "bug," and if I'm missing something obvious, please guide me!

    But regardless, I have a suggestion to make. Please, please make "Lock on Exit" a separate setting! It's far too confusing and frustrating the way you have it set up now. You may argue that it is more "logical" the way you have it now. But the fact is it would be "easier" if you made it a separate setting.

    I look forward to your reply.

    Thank you.
  • JDWJDW Junior Member
    After much hair pulling, I finally figured it out. When you tap on the gear icons in the lower left, and then on Security, and then on Auto Lock, you are presented with a menu of options (1 min., 2 min., ... NEVER). What had me totally confused before was that I could not see that the content could scroll up/down! It was only by accident that I did this just now and I found "Lock on Exit" to be hidden at the bottom. Since there is no vertical scroll bar, you really don't know what scrolls and what doesn't. Perhaps if that little popout were taller, there would be no need to scroll at all. But for now my problem is solved.

    One odd thing I've noticed though, now that I've got Auto Lock turned off, is that when I flip to another app and then return to 1PSW, for about a half a second the PSW entry screen appears, and then what you were working on before appears. Since no PSW entry is required, why even flash the PSW entry screen at all, even briefly? It's not a big deal, I suppose, but I just wanted to report it to you anyway.

    Thanks. And sorry for having troubled you.
  • khadkhad Social Choreographer

    Team Member
    I'm glad you were able to find the switch for "Lock on Exit". It is showing on an iPhone 5 without any scrolling, but it does require a little scroll on older iPhones and iPods touch.

    The lock screen is displayed because 1Password has no way of knowing what your lock settings are until is actually loads. The lock screen you are seeing is a static image. Once 1Password actually loads, either the lock screen becomes active if you need to input your Quick Unlock Code or Master Password; or the content you were last viewing is displayed. Without it, the content you were last viewing would be displayed instead for that brief moment.
  • dtearedteare Agile Founder

    Team Member
    JDW wrote:

    Thanks. And sorry for having troubled you.


    No apology needed! It's invaluable to hear your feedback on things that are confusing as it helps us improve :)

    Thanks again for taking the time to share your experiences with 1Password!
This discussion has been closed.