Extension won't load in Safari

I am running iPassword v4 on my iPhone & iPad and v 3.9 on my Mac (from the App Store). It works fine on the IOS devices but not on my Mac. I am running Mountain Lion and Safari 6 and it may be that I will have to wait for v4 to come out. Otherwise now, the safari extension fails to load and the GO&Fill feature will go to the website but does not fill anything!!

Any suggestions as to how to fix it or is it that the software does not fully work on Mountain Lion?


  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, akarora! Thanks for taking the time to contact us. I'm sorry that you are having some trouble. 1Password has been fully compatible with Mountain Lion since before it was ever released, so I'm sure we can get things working well for you.

    Can you tell me what you mean when you say that the extension "fails to load'? If the extension is not installed then Go & Fill will not work. Is the 1Password extension installed in Safari? Do you see the key in the toolbar? What happens when you click the key button in Safari's toolbar?

  • edited December 2012
    Thanks for your reply. I click on your link to download the Safari extension software. It opens and asks me to install. When I click 'install' it gives the message "An error occurred while installing the extension “1Password”.
    Without the extension, I do not get the key in the toolbar.
    If i enter through the main program and click on a website, such as Amazon, it goes to the page but does not log in. Presumably the same problem. I tried to uninstall/reinstall the program using your uninstaller from the website but it failed also. Glitch somewhere.

    Any advice?
  • khadkhad Social Choreographer

    Team Member
    Would you happen to be behind a proxy server when you experience the error trying to install the extension? My guess is that it is not possible to install any extension as this usually indicates a problem with Safari itself rather than the 1Password extension specifically.

    Please try to install the YouTube5 extension and let me know what happens.
  • The YouTube extension failed. I have Kaspersky antivirus and virtual keyboard extensions installed, as given by my bank for security. Have tried another extension from the Apple website but same thing. Any suggestions where the problem may lie and how I can fix it?
  • Have updated latest version of Firefox and it did load the extension. Now to get Safari working.......
  • I also tried to install it on my MacBook Air - worked first time.
    Have deleted Safari and reinstalled on desktop - still not working. Tried Safari reset also.
    Where is the problem???
  • khadkhad Social Choreographer

    Team Member
    While the issue is not with 1Password since you cannot install any other extensions, hopefully I can help you fix Safari so you can install the 1Password and other extensions.

    In Finder, select Go > Go to Folder… from the menu bar. Copy and paste the following path into the input box and then press Return:


    Drag the Extensions folder and the Databases folder to the Desktop.

    Restart Safari and try installing the 1Password extension again.

    If that doesn't help, try downloading the Safari extension in Firefox and then double-click it in Finder.

    Still trouble? There might be something wrong with key system files on your Mac. Here are a couple of solutions you can try:

    Rebuild LaunchServices:

    Make sure the Cache folder is not locked:

    Please let me know how it goes.
This discussion has been closed.