Import into 1Password from 1PW3 broken in build 4.1b18

Is this bug reproducible?

Yes

Which devices did this bug appear on and is it reproducible on any devices?

iPhone 5, iOS 6.0.1, 1PW3.7.2, 1PW4.1b18

A quick summary of the bug:

The new build 1PW4.1b18 broke the import from 1PW3 version into 1PW4. Earlier builds 4.1b15 and 4.1b17 have no issue with import from 1PW3 although the process is not consistent (I'll post in a separate topic later). From the recent change log, this may be due to the CFBundleURLSchemes or CFBundleURLName updates made in 4.1b18 regarding the onepassword related URL schemes. A consistent behavior is when 1PW3 opens, it should display the familiar dialog where it detects a 1PW4 version is installed and prompts user to import. 4.1b18 no longer produce this behavior.


Detailed Step-by-step instruction on how to reproduce it:
  1. Backup 1PW3 data using 1ptbackup or other methods.
  2. Uninstall/Delete both 1PW3 and 1PW4 apps on iPhone
  3. Install 1PW3.7.2
  4. Open 1PW3, setup Master password and add one or more entries OR simply restore from any 1ptbackup files or from other methods.
  5. Close 1PW3 and force quit this app from background
  6. Install 1PW4.1b17
  7. Open 1PW4, you may see a dialog to upgrade (to 4.1b18 or any higher version) - simply ignore any upgrade for now.
  8. Select 'I've used 1Password before' and Import from old version.
  9. Enter new Master Password for 1PW4 and re-enter the Master Password, skip the Hint view.
  10. You should see a view with 'Get started!' button. Select Get started! button. This should setup a new DB in 1PW4.
  11. 1PW3 app is opened automatically - you will be prompted to enter the quick unlock code or master password for 1PW3 - DO NOT unlock yet
  12. Click on iPhone HOME button
  13. Force quit both 1PW3 and 1PW4
  14. Open 1PW3, enter any Quick unlock code or master password for 1PW3.
  15. Dialog is displayed prompting for Import into 1Password app. Select the button 'Import into new 1Password'.
  16. You will be prompted with 3 options - Open in 1Password, Mail, Copy
  17. Select 'Open in 1Password'
  18. 1PW4 app opens at the enter Master Password view - ignore any upgrade option if prompted.
  19. Enter the Master Password of 1PW4.
  20. You should now see a view the Import view. Select the Begin Import button.
  21. All entries from 1PW3 will be imported into 1PW4 (except for trashed items).
  22. Preview the new entries in 1PW4 to verify.

Repeat the same steps as above but install 1PW4.1b18 instead of 1PW4.1b17 - no dialog is displayed after step 14 and you are stuck without any option to import into 1PW4.


Workaround
  1. Stick with 4.1b17 (yawn)
  2. Install 4.1b17, import old entries from 1PW3, then upgrade app to 4.1b18.

Hope this helps.

Comments

  • Still broken in build 4.1.1b4. Release notes stated this build will be submitted to App Store as 4.1.1. Please fix this before submission!
    Thanks.
  • MikeTMikeT Agile Samurai

    Team Member

    Hi @wailam,

    I just tested this with the latest 4.2b2 and it seem to be working fine. Can you confirm that it's still broken for you? Also, can you install the official build of 1Password at the App Store and see if it makes any differences?

    Here's what it looks like to me when I killed all apps and open 1Password 3 first,

    Open in 1Password

    I did both and it imported fine in both the beta and official versions.

    Please let me know.

  • Hi Mike
    Still occurring on 4.2b4. This is on IPhone 5 6.0.1. I see that you're testing on an iPad from your screenshot.

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2013

    Hi @wailam,

    Sorry, I meant to post the iPhone screenshot, I tested both to make sure it's not just iPhone.

    Here's a video of me doing it, please let me know what I'm doing wrong, I did the first step 14 and this video starts with me killing both apps:

  • Hi Mike

    Pls try without having the 1Password app (official) installed. Only install the beta. I suspect since 4.1b17 (last known working beta to support this feature), some location mrtadata was changed causing all future betas to break. I just tried this without any official 1password. 4.1b17 still works and 4.2b4 that breaks.

    Hope this helps.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi,

    Looks like the import process won't start if it can't recognize the regular URL scheme but it does recognize both the regular and beta URL schemes if the official build was installed first.

    I've filed it as a bug. Unfortunately, this may require an update to 3.7.x series to fix this, which is lower on the priority list. As soon as we finish with the rest of issues in 4.x, we'll take a look in the 3.7.x series to release an update to fix this.

    Thanks for your patience on this matter.

  • wailamwailam
    edited May 2013

    It's been awhile since I've last beta test this app. Fast forward to today and testing the latest beta 4.2.2b1. Unfortunately the import from old version (3.x) is still not working even though i have the official 1Password 4.2.1 installed FIRST, before 4.2.2b1.

    Note: Dropbox sync was configured in 1P3 and I had turn this off, rebooted phone before attempting to run either 1P4 versions.

    Neither 1Password4.2.1 and 1Password4.2.2.b1 work. Am I the only one using this feature?

This discussion has been closed.