New user, multiple issues

I have just installed 1Password for the first time and so far it looks like a real lemon. Here are some of the problems I am experiencing:

  1. I mostly use Firefox. Every time I go to a web site and try to use 1Password it forces me to enter my unlock password. This is despite configuring 1Password to never lock. If I open the 1Password application itself then it remains unlocked but, as I said, every time I actually use it in a browser then it makes me unlock it again. This is so infuriating as to make the product useless.
  2. When I go to a web site with a login stored in 1Password and click on the 1P icon at the bottom of the window, no logins are listed as being appropriate for the particular site even though at least one is. The login I am after appears in "Login with current window" but clicking on it fills in the fields and then just closes the window without actually logging me in.
  3. The red '!' icon appears in the left margin and clicking on it reveals that there is a "Problem with 1Password Helper" but gives no hint as how to resolve it other than supplying a link to the details shown at the bottom of this post.
  4. In Chrome, the "1P" icon never appears but when I select "1Password" after right-clicking in the User Id field it fills in the fields and then closes the window without actually logging me in at all.
  5. In IE, I cannot see any integration with 1P at all even though the Browsers section in Preferences indicates that it should be there.

So to summarise, I get absolutely no value out of this product so far. It is totally annoying and frustrating. I would be happy if it just worked in Firefox and I don't really care that it is totally broken in IE or Chrome.

Can anyone help? Am I doing something fundamentally wrong?

Here is the report displayed in the window opened by clicking on the red "!" icon:

1Password Troubleshooting Report

When experiencing problems this page can help you diagnose the cause. Common configuration issues detected on your system will be highlighted below, along with troubleshooting tips to resolve them.

If the support team requests this report, you send it to them by saving this page (select File > Save As) and then attaching the saved file to your email response.
System Information
System time 2013-2-13 : 21:44:25
Browser version Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

1Password Extension Information
Extension version 3.9.9 (release notes)
Database created at 2013-2-8 : 21:8:22
Instance UUID dcd654f0...C438
Uptime (mins) 18
1Password Helper Information
Connection status Connected
Last Sync Error
1Password Helper version 1.0.9 (315)
Heart beat interval (sec) 20
Heart beat acknowledged No
Number of heart beats 0
Round trip elapse time (ms)
Data update in progress No
Last data update completed at 2013-2-13 : 21:44:17
Data update elapse time (ms) 46
1Password Extension Settings
Autosave enabled YES
Autosubmit enabled YES
Universal Unlock enabled YES
Conceal Passwords YES
Avoid Autosave on Domains ""

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Lucan1d,

    If you're seeing a red badge on the 1Password icon in your browsers, then it means that it is not able to connect to the 1Password helper, which is responsible for the universal (browser) unlock support and syncing of your data. So, while it is not connected, it may not unlock consistently and may not have your data, which would explain all of your issues.

    Before we move on to fix this, please note that the Windows app does not support true universal unlock where if you unlock the main app, it will not unlock the browser extension. They both are two separate things but if you unlock the browser extension in Firefox, 1Password Helper will unlock the rest of the modern browsers such as Chrome and Safari along with Firefox. If you close the browser, it'll remain unlocked for all of those browsers until the auto-lock kicks in.

    Internet Explorer doesn't support the modern browser extensions, so it does not benefit from those features that I just mentioned. However, it should work nearly the same way, it'll auto-lock based on your settings and remain unlocked until then.

    First, let's work on your Internet Explorer as it does not use 1Password Helper. If you do not see the 1Password key in the toolbar in Internet Explorer, it may be hidden. Please read this on how to make it appear. After that, see if it'll work better now.

    For Firefox, open the main 1Password app, go to the Help Menu > Check for New Version to update 1Password, once it is updated, go to Help Menu > Restart 1Password Helper.

    Once you do both, reset the data in Firefox with this instruction and restart Firefox after this, see if you can unlock it now.

    Hopefully, this should work now. If it does, check Chrome, it should work properly as well.

  • Hi Mike,

    Thanks very much for your reply. Unfortuantely, none of what you suggested has helped.

    At the moment I am just trying to get 1P to work with Firefox but am not getting anywhere.

    I did as you suggested (i.e. updated to a newer version of 1P, restarted it and reset the data in Firefox) but the exact same problems remain. I still get the red "!" icon, I still have to unlock 1P on every website, 1P still says there are no relevant logins for each site and 1P still does not actually log me into the site when I use one of the logins (listed under other section headings).

    Basically, this product is still completely useless and the source of enormous frustration!

    I am hoping it's "user error" but the presence of the red icon suggests otherwise. What else can I try to get this to work? There is nothing really special or unique about this machine, it's just a vanilla Windows 7 64-bit machine.

    P.S. I saw on some of the 1P Help documentation that there should be an option in Preferences->Browsers to keep extensions open but I do not see any such option. My guess is that this doco referred to an older version and that this option has since been removed.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Lucan1D,

    Yes, the documentations are outdated, we're working on getting it refreshed. I apologize for the inconvenience.

    To help us track down the issue more quickly, could you please email us your Diagnostics Report? To generate the report, open 1Password and go to the Help Menu > Diagnostics Report > Export to File. Then email your report to [email protected]

    Please include a link to this thread, so we can connect the dots in the email.

    Thanks!

  • Thanks Mike, I have emailed the diagnostic report as requested. Good luck!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Lucan1d,

    Got the email and you should get a response there. There's some weird situation going on but hopefully, we'll get somewhere soon.

This discussion has been closed.