Trouble with iframes in Firefox with extension 3.9.10 [resolved in 3.9.11]

rothomasrothomas
edited March 2013 in 1Password 3 – 6 for Mac

Tonight I have not been able to login on many sites that I have been using for years. I s there an issue or has something changed?

Comments

  • khadkhad Social Choreographer

    Team Member

    There was an extension update, but this is the first report of any trouble I've seen so far. I'm not certain that I understand what the trouble is, though. Could you please describe in as much detail as possible the steps you are taking, and what you are [not] seeing happen? With some additional information from you we can then provide you with specific assistance.

    Thanks!

  • edited March 2013

    Same problem. FF 19.0.2, OSX 10.7.5 ... click on 1pw icon, select login ... then ... login data does NOT get populated on the web form.

  • like the other user, works fine on latest Chrome.

  • nachalniknachalnik Junior Member
    edited March 2013

    Maybe I can add more info. Just today (after the 3.9.10 FireFox extension update), noticed that on at lease one site, Capital One (credit card log-in), 1PW would not fill in log-in info (neither with the button, nor keyboard command. For me, the problem only exists in Firefox (19.0.2). Am running Leopard 10.6.8, 1PW 3.8.30. Other sites I normally visit seem to be okay ..... but can't say what other may be having problems. Tried to log-in on the Cap One site with Safari/Web-Kit with the 3.9.10 extension ..... no problem. Same with Chromium (1PW extension 3.9.10.3) ... no problem. Just Firefox having the problem.

    Update: You can add Express Scripts web site to the list, just tried it based on a comment in the extension forum .... no go, will not fill in with FF/ext 3.9.10. (which, not that I think about it .... this thread probably belongs there, as I am sure it is extension related)

    Also, I was just going to try to revert to the 3.9.9 extension and turn auto-update off, but, for the life of me, can't remember where the previous versions of the extensions were listed. All I have is the link to the change log.

  • contradictionofgermscontradictionofgerms Junior Member

    Hello,

    I'm trying to use this (awful) website Express-Scripts and, at first, it wouldn't automatically save my login info. Having dealt with that before, I filled in the info and added the site to 1Password. Now, however, when I go back to the home page, 1Password says "No logins saved for this site"

    I know something funny is going on with the site since the whole page loads before the login section, but I'm not sure beyond that what's happening and why it's confusing 1Password.

    thanks!
    dennis

  • Same problem. Firefox 19.0.2 not working properly with 1Password. Safari ok.

  • hjformanhjforman Junior Member

    Same problem. Firefox 19.0.2 not working properly with 1Password. Safari ok. I'm not going to change browsers.

  • khadkhad Social Choreographer

    Team Member
    edited March 2013

    Thanks for the additional information!

    It appears to be an issue with frames/iframes. I've passed this along to the developers so we can get this resolved as soon as possible.

    RM4383

  • khadkhad Social Choreographer

    Team Member

    I split your posts from the other thread which was about installing the extension in Firefox. Could you all please provide a URL where you are having trouble? There is a known issue with iframes. I want to make sure you are not reporting a different issue. It's possible we're already aware of the problem and working to resolve it, but it is impossible to say unless we know the URLs where you are having trouble.

    Thanks!

  • I can't speak for the other users, but I'm having the issue here: http://sddp.ent.sirsi.net/client/default#

  • davebarnesdavebarnes Member

    I have the same problem.
    Firefox 19.0.2
    1P Extension 3.9.10 (re-installed this morning)
    Can use 1P extension to log into http://www.verticalresponse.com/login
    Cannot use it with https://76.74.126.20:8443/login.php3
    Cannot at https://www.dcu.org/
    Can at https://www.americanexpress.com/

  • Some more detail on mine... here's a conversation I had w/ support.

    From: me
    To: [email protected]

    Since the recent update to the Firefox extension (to 3.9.10), 1Password will no longer successfully fill the login form found at http://sddp.ent.sirsi.net/client/default (to see the form, click Login in the upper right)

    The Chrome extension appears to still work fine, I'm only having an issue w/ Firefox.

    I'm using:
    Firefox 19.0.2
    1Password extension 3.9.10
    OS X 10.8.3

    If there is any more information I can provide to assist in resolving this issue, please let me know.

    Thanks,

    From: [email protected]
    To: me

    Thanks for taking the time to contact us about the trouble you're experiencing.

    I was able to confirm it doesn't work. I've made our developers aware. I believe this may be related to an issue we're already aware of, but they'll know for sure.

    I do apologize for the inconvenience though.

    Cheers!

    Kyle Swank
    AgileBits Support

  • khadkhad Social Choreographer

    Team Member
    edited March 2013

    Thanks for the additional information, @ENDelt260. You're actually talking to AgileBits support here (me), so there is no need to duplicate efforts both here and via email. We are the same team in both places. ;)

    http://sddp.ent.sirsi.net/client/default contains an iframe. There is a problem with iframes in Firefox. We have reported it to Mozilla. Either they broke it in the version of their SDK we upgraded to, or we're doing something wrong. We are waiting to hear back from Mozilla for some more details.

    @davebarnes, the two sites https://76.74.126.20:8443/login.php3 and https://www.dcu.org/ are also using iframes, so it is the same issue.

    I couldn't reproduce any trouble with http://www.verticalresponse.com/login though. It is working well in all my testing. I'm sorry that you're having some trouble. Please try saving a new Login manually like this:

    1. Enter your credentials at http://www.verticalresponse.com/login but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and select the "+" button in the upper right hand corner.
    3. Change the title and make any notes (if desired).
    4. Click the Save button in the upper right hand corner.

    Using the above technique I was able to save and fill a sample login at:

    http://www.verticalresponse.com/login

    Manually saving a new Login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Saving a new Login item allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :)

    If you are still having trouble, please try disabling autosubmit for that Login and let me know if that resolves the issue. Since I don't have an account there, I was not able to verify autosubmit for the form.

    I hope that helps. Please let me know. If you're still having trouble, please start a new thread so we can keep the discussion in this thread on topic (iframe issues).

    Thanks!

  • ou're actually talking to AgileBits support here (me), so there is no need to duplicate efforts both here and via email. We are the same team in both places.

    Yeah, I figured. I was mostly hoping to save y'all duplication of effort in case a different person was reading this forum than the e-mail.

    Thanks for the add'l info re: iframes.

  • khadkhad Social Choreographer

    Team Member

    It is my pleasure to help. Please let me know if there is anything else I can help with in the meantime. :)

  • khadkhad Social Choreographer

    Team Member

    This should be resolved in version 3.9.11 of the Firefox extension. Please let me know if you are still having trouble with sites with iframes in Firefox with version 3.9.11 of the extension.

  • nachalniknachalnik Junior Member

    Thanks khad ..... just checked against all the sites with iframes what were not working with the 3.9.10 extension ..... and they are working now (for me). However, when I checked FF for the extension version ..... it was being listed as 3.9.12! Perhaps another came out very quickly after 3.9.11.

  • khadkhad Social Choreographer

    Team Member

    Thanks khad ..... just checked against all the sites with iframes what were not working with the 3.9.10 extension ..... and they are working now (for me).

    Great news! Thanks for letting me know that everything is working well. :)

    However, when I checked FF for the extension version ..... it was being listed as 3.9.12! Perhaps another came out very quickly after 3.9.11.

    We are on a roll. It's been a busy weekend. :)

    It was resolved in 3.9.11 and should keep working in future versions too. Let us know if you ever find out otherwise.

    Cheers!

  • davebarnesdavebarnes Member

    36 hours for a fix. You guys are great!

  • khadkhad Social Choreographer

    Team Member

    Thanks, Dave! It's a pleasure. :)

This discussion has been closed.