Trouble with mega.co.nz [resolved in 4.2]

LockerLocker
edited May 2013 in iOS

1PW iOS 4.1.2

iPad iOS 6.1.3

The 1PW web browser does not seems to work correctly on <mega.co.nz>

It may be an issue with a script. There is a menu screen on the left that is accessed by licking on an icon on the top left. This causes the min screen to slide to the right, revealing the menu window.

The problem is that the main window is not updated correctly when selecting different menu items.

If I rotate the iPad from landscape to portrate mode (or from portrait to landscape), it can cause the main window to update itself in some cases. [It still does not display the right content for the 'cloud drive' menu.]

(Note to the critics: This is not an endorsment of any particular website. Just a report of a problem in 1PW).

Comments

  • khadkhad Social Choreographer

    Team Member

    Do you mean that there is a problem filling a Login item on the login page? It almost sounds like you are just describing a problem with the mobile layout of their website. I'm not sure what trouble 1Password is causing/having. Could you help me understand 1Password's specific role in this a bit better?

  • LockerLocker
    edited April 2013

    No. It's not a problem with the login. Once I am already logged in, the browser of 1PW does not behave correctly. I cannot navigate to the right places.

    If instead of using 1PW browser I go to the Safari browser (and after logging in), it does behaves 'correctly'.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi Locker,

    I'm not able to see anything wrong. Here's a video I recorded while using that site in the 1Browser on the iPad.

    I did notice that I have to tap twice on some menus to get it to load the page but other than that, I don't see anything broken. Can you be more specific or take screenshots on the broken parts?

    Please let me know.

    Thanks!

  • LockerLocker
    edited May 2013

    Strange. Mine does not work that way. I checked also on iPhone -- same problem. What version are you using? Mine is 4.1.2.
    What is the right icon at the top of your 1PW? I see only the left three. Not the one with two keys back to back.

    How did you take a screen-video?

  • khadkhad Social Choreographer

    Team Member
    edited May 2013

    How did you take a screen-video?

    I think Mike was using the iOS simulator and recording the video on his Mac. You could also just use the camera built-in to your MacBook or another iOS device to record the screen.

    I think Mike was probably using the beta version of 1Password. I can't reproduce any trouble in the stable version either, but perhaps the next update will resolve this for you. I don't think it will be very long before the next update. Let's see if you are still having trouble in the next update. If so, we can go from there. That will give is a good baseline. :)

  • I'll hold my breath then. :)

  • khadkhad Social Choreographer

    Team Member

    Thanks for your patience. I'm hoping the next update resolves it.

  • 1PW iOS 4.2

    Yes. 4.2 works fine. Problem fixed. It was worth waiting... :)
    (And now I know what that new icon at the top right -- password generator)

    There are minor things that are not fixed, but I think it is not related to MEGA site specifically. I'll write about that in a different port.

    The important thing is, again, that the problem that I've described in the original post is now fixed. Yea!

  • khadkhad Social Choreographer

    Team Member

    Great news! Thanks for letting me know that everything is working well. :)

    Please keep us abreast of anything else you come across.

This discussion has been closed.