1P button missing in Firefox after upgrading extension to 3.9.15

lpnlpn Junior Member

As the title says, after upgrading the extension to 3.9.15, the 1P button is missing in Firefox 21.0 on OS X 10.8.3. 1P is in the list of addons, but the key icon It is not in the navigation bar (where it was), and the 1P icon it is not in the addon-bar (where it also was), it is not hidden in the Customize menu of the toolbars. Installing the 3.9.12 (ESR) extension fixed the problem, but that is an outdated version which works, but is not for FF 21.

As an 1P user from 2007, I should say that this is really frustrating and I am already looking for stable alternatives and most likely I won't be upgrading to 1P version 4.

«1

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @lpn,

    Unfortunately, this is a problem with Firefox, not 1Password. We're frustrated by this as much as you are. Mozilla is already working on replacing the way toolbar icons works for Firefox 25, hopefully, that'll fix the problems. 1Password isn't the only one affected by this.

    Could you follow the instructions here and see if it'll help: http://kb.mozillazine.org/Corrupt_localstore.rdf

    This came from here: http://support.mozilla.org/en-US/questions/960414

    Please let me know how it turns out.

  • I also have this problem - it's pretty annoying.

  • hakanhakan
    edited May 2013

    I am also seeing this on the current Firefox 23 Aurora builds. This happened with the beta and going back to 3.9.14 fixed the problem.
    Are the old versions achieved somewhere? I would like to roll back to the previous version.

    edit: Found the old 3.9.14 xpi in my mobile TM backup. :)

  • Anyone from 1 password got any tips ?

    I have found the last few versions of 1Password very flakey on my iMac to be honest - autofilling not working etc and now this latest problem where I can't get it to work in Firefox at all is making me think I should look at an alternative too

  • I can't find any Localstore.rdf files on my machine ?

  • I am running Firefox 21.0 / 1Password 3.9.15 and OS 10.6.8

    Found Localstore.rdf in Firefox/Profiles and deleted them but still no 1Password add on in the browser

  • lpnlpn Junior Member
    edited May 2013

    Hi @MikeT,

    I think that it is not a localstore.rdf problem.

    This is why: let's assume for a second that the problem is with a corrupted localstore.rdf file. Installing 3.9.12 ESR (when having that "corrupted" localstore.rdf file) causes no issues at all. Installing 3.9.14 (that I found in time machine backup as hakan did) when having that "corrupted" localstore.rdf file causes no issues. 3.9.15 is the only one causes issues. And that is consistent, I can install these one after another in any order, doesn't change a thing -- 3.9.12 EST and 3.9.14 are ok, 3.9.15 -- not.

    I went further and did something else -- I restored my profile including a localstore.rdf from a backup from 6 months ago and then upgraded all my 7 addons (including 1P and some popular ones -- ABP and NoScript) one by one. Only the 1P icon went missing. Now, if the localstore.rdf from 6 months ago was somehow corrupted and missing icons are related to broken localstore.rdf it is highly unlikely that the only 1P icon would go missing after upgrades (remember, I updated 6 other addons). If that localstore.rdf was good, it means that the explanation in the mozilla support forum has nothing to do with the issue and the missing icon of another addon discussed there could be different problem (or perhaps related, i.e. using same libraries that have issues... who knows).

    And finally, I deleted localstore.rdf as mrtumnus did and had a new localstore.rdf created by FF, but that didn't fix the issue. Therefore most likely the problem has nothing to do with localstore.rdf.

    It could be another issue with FF and my wild guess is that the issue is related to this in the 1P addon changelog:
    Changed Updated Firefox’s Add-on SDK to 1.14

    However I don't know anything about that SDK to say if this is a problem with the SDK or anything else in FF, or 1P incompatibility with any of these.

    My suggestion -- please post a link to 3.9.14 for people who do not have a backup. Regardless of localstore.rdf being good or bad or if it has anything to do with the issue, that version has an icon that appears in FF.

  • "My suggestion -- please post a link to 3.9.14 for people who do not have a backup. "

    I completely agree.

    AgileBits, please do so immediately to solve an annoying problem.

    Norbert E. Fuchs
    [email protected]

  • hi, @hakan
    Would you please share your old 3.9.14 xpi with us? I have the same problem.
    Thanks.

  • I would also like to have the 3.9.14 xpi if it is available. I have this same problem with 3.9.15 running Win8 in Firefox 21

  • I went to ~/application support/firefox/profiles/extensions/ found the xpi file

    I copied the xpi file from my back up from April and restarted Firefox and . . .

    all working again !!!

    Thanks for the tip !

  • hakanhakan
    edited June 2013

    @WillRoy: Here is the old version: https://www. dropbox .com/s/zjkzrxwyumfrb5r/onepassword%40agilebits.com.xpi

  • Thanks, hakan! All better.

  • Thanks Hakan. That solved my problem!

  • Hakan, thanks from me and my wife.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    I'm glad to hear 3.9.14 fixed it for you. That's very weird because we didn't change much in 3.9.15 for Firefox, it was just a single unrelated bug fix for FIrefox only.

    Do any of you guys restart Firefox with a blank page or with previous tabs?

    @lpn, we don't believe it is either, but it is the first thing Mozilla asked for this type of issue, they're the one with the most experience about this problem. In fact, we've received the same reports of the Firefox icon disappearing for the last couple of updates, we've seen it in 1Password extension 3.9.10-14 and Firefox 18-21 updates. We're trying to help Mozilla figure this out but so far, no patterns yet.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hey, guys, @MikeT asked me to stop by. We haven't changed any Firefox code significantly so I'm rather confused about what could be going on here.

    There are three places 1Password shows up in Firefox: the toolbar, the addon bar (at the bottom of your screen), and the context/right click menu. Can you report back as to where 1Password is missing? (You can turn on the Addon Bar in View > Toolbars if you don't have it displaying.) The reason I ask is to try to determine if it's just one portion of 1Password that's not properly wired up or if the whole thing is going MIA.

    The other thing to look for is logs from our end.min.js file in Firefox's web console. We try to minimize our noisiness here, but from time to time there will be a log that slips out. It can be instructive to know that our web content scripts are being loaded, but an absence of logs shouldn't be taken as an absence of 1Password.

    I'm sorry for the trouble you're having, and I'll definitely appreciate your help in trying to track down the issue.

  • lpnlpn Junior Member
    edited May 2013

    @jxpx777

    The 1P is missing in all three places.

    In the web console there are things like:

    [timestamp] TypeError: can't access dead object @ resource://gre/modules/XPIProvider.jsm -> jar:file:///Users/username/Library/Application%20Support/Firefox/Profiles/something.default/extensions/[email protected]!/bootstrap.js -> resource://onepassword-at-agilebits-dot-com/addon-sdk/lib/toolkit/loader.js -> resource://onepassword-at-agilebits-dot-com/addon-sdk/lib/sdk/loader/sandbox.js -> resource://onepassword-at-agilebits-dot-com/onepassword/data/src/end.min.js:51

    [timestamp] TypeError: can't access dead object @ resource://gre/modules/XPIProvider.jsm -> jar:file:///Users/username/Library/Application%20Support/Firefox/Profiles/something.default/extensions/[email protected]!/bootstrap.js -> resource://onepassword-at-agilebits-dot-com/addon-sdk/lib/toolkit/loader.js -> resource://onepassword-at-agilebits-dot-com/addon-sdk/lib/sdk/loader/sandbox.js -> resource://onepassword-at-agilebits-dot-com/onepassword/data/src/end.min.js:49

    The above appear in the addon version 3.9.15, but not in 3.9.14. Hope that this helps.

    This is on OS X 10.8.3, FF 21.0, 1P 3.8.21 (all latest versions)

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2013

    Hi guys,

    I've been doing a lot of testing. I think I know where the cause is but I need your help to test it.

    If you guys have Firefox configured to Never Remember History (as a test to confirm the issue), please change it to Remember History, and restart Firefox. Does that bring back the 1Password icon with 1Password extension 3.9.15?

  • lpnlpn Junior Member
    edited May 2013

    @MikeT I can confirm that switching to Remember History brings back the icons. Note that I had Use custom settings with Always use private browsing mode and the icons didn't show up, so it is not just Never remember history that is causing it (although what I had was quite similar to it).

  • MikeTMikeT Agile Samurai

    Team Member

    Awesome!

    Thank you, we'll investigate why it is doing that and find a way to fix it or file a bug report with Mozilla.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    We figured out the problem with Mozilla, we've pushed the 3.9.16 update that will fix the issue with the Never Remember History option.

  • lpnlpn Junior Member
    edited June 2013

    Yes, 3.9.16 fixes it. Thanks a lot for fixing this promptly.

  • hakanhakan
    edited June 2013

    On Windows with the 3.9.16 update the button is not missing anymore but now nothing happens if I click on the 1Password button.
    My browsing history in the privacy settings is still enabled.

    edit: The same problem on my Mac. The 1Password button does not open the menu anymore and going back to 3.9.14 is still helping to avoid the issue. As mentioned before I am using Aurora 23a2 on both systems. This could be an upcoming issue with the future Firefox releases.

  • khadkhad Social Choreographer

    Team Member

    This could be an upcoming issue with the future Firefox releases.

    It probably is. Please let us know if you have trouble with the current stable version of the 1Password extension in the current stable version of Firefox. Regarding prerelease browser builds, please see:

    Support for Prerelease Browser Versions

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @hakan,

    I tested Aurora 23, it definitely doesn't work in that version at the moment. You'll have to stick with the stable version for now while we research what they've changed.

  • According to the latest blog post this issue on Aurora should have been fixed. So I installed the new 3.9.17 build on Windows and Mac and it seems to be true. :)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Haken,

    That's correct, we've updated to work around the bug in Aurora 23 for now. Hopefully, no more changes in Aurora for now.

  • I am brand new to 1p. Downloaded the 30 day trial, but 1p button is missing in Firefox 21.0. Extension has been downloaded (3.9.17) but 1p doesn't appear in the list of extensions, nor does the button. Would appreciate any help.

  • khadkhad Social Choreographer

    Team Member

    I'm sorry that you are having some trouble, @fedley917. We will get this resolved for you.

    To help us track down the issue more quickly, could you please send us a Diagnostics Report?

    Download the 1Password Troubleshooting utility and follow the instructions to generate the report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox. It would also be helpful if you mentioned in your email that you want to make sure Kyle sees your support ticket. He's the go to guy for this issue right now.

    Once we see the report we should be able to better assist you. Thanks in advance!

This discussion has been closed.