[4.2.2b1] Browser => Edit => Browser

bleepnikbleepnik
edited June 2013 in iOS Beta

Is this bug reproducible? Yep.

On which device(s)? I discovered it on an iPhone 5 running 6.1.4. I didn't try to reproduce it elsewhere.

Quick summary: There's a (really) minor glitch when going to a login's edit screen from the browser and then going back to the browser. I noticed this on a site for which I have just the one login and didn't test on another site where I've got multiple accounts.

Step-by-step:

  1. Visit a login page in 1Password's browser.
  2. Tap the key to display login options and saved logins.
  3. Tap the right arrow on the displayed login item.
  4. Tap Edit, change your username, then tap Done at the top.
  5. Tap Log in using at the top instead of the Done button at the bottom of the screen.

You'll see that 1Password still displays the old username. If you tap Done and then the key again, it'll have updated. However, after editing the username if you tap the Done button at the bottom of the screen instead of the Log in using button at the top of the screen, 1Password updates the display.

I feel like there's a bit too much complexity on that Edit screen and hopefully in future updates @danvpeterson Dan (Edit: How is that not Dan's name here? That's Dan's name everywhere.) can polish it up a little. For example, while editing, there's a Done button at the top and at the bottom. That looks a little, I dunno, kind of awkward to me. But that's off-topic, so I'll leave it at that.

Oh wait, while I'm off-topic, one more little thing: you know how in Edit mode 1Password makes the field blue? That particular shade of blue makes it really hard to see what I'm editing. The contrast is just a tad too low. Maybe you could lighten up the text when the field is blue? That'd really help. Thanks for the consideration.

And I almost forgot. In case the steps aren't clear, here's a one-ish-minute screencast.

This discussion has been closed.