1Password would not continue past the initial welcome screen

I ran into this issue recently, and wanted to post my solution, which was different from the support article.

The Problem
I could not start 1Password. It would show an error message on start up, and ask me to follow instructions to resolve the issue here:
http://support.agilebits.com/kb/1password-39-for-mac-from-mac-app-store/1password-fails-to-continue-past-the-initial-welcome-screen-purchased-from-mac-app-store

Steps to Reproduce the Problem
I had 1Password installed and working fine, and then decided to update the user shortname on my Mac. I used the instructions at apple: http://support.apple.com/kb/HT1428?viewlocale=en_US&locale=en_US. After updating my username, 1Password failed to start with an error message saying to follow the instructions at the support article posted above.

The support instructions failed to work.
First I tried the Troubleshoot Utility, which didn't seem to do anything (it also wouldn't save a diagnostic file).

The console commands also failed:
chmod -N /var/db/launchd.db/com.apple.launchd.peruser.'id -u'/overrides.plist
chmod: Failed to clear ACL on file /var/db/launchd.db/com.apple.launchd.peruser.502/overrides.plist: No such file or directory

The 'extra steps if needed' section also failed:
ls [email protected] /var/db/launchd.db/com.apple.launchd.peruser.*/overrides.plist
ls: /var/db/launchd.db/com.apple.launchd.peruser.*/overrides.plist: No such file or directory

The Fix
I had to create a folder with my user id (502), add an overrides.plist file, and make it owned by my username[1]

sudo mkdir /var/db/launchd.db/com.apple.launchd.peruser.'id -u'
sudo touch /var/db/launchd.db/com.apple.launchd.peruser.'id -u'/overrides.plist
sudo chown -R 'id -u' /var/db/launchd.db/com.apple.launchd.peruser.'id -u'

[1]in all the code posted above, you need to replace the single quote mark (') with a backtick (`) for terminal to understand it correctly.

Comments

  • khadkhad Social Choreographer

    Team Member

    Sorry to hear you had some trouble, Aaron, but I am glad things are working well now. Thanks for posting the solution that worked for you!

This discussion has been closed.