1Password Extension for Firefox

cfloodcflood
edited June 2013 in 1Password 3 – 6 for Mac

The extension file for Firefox is an xpi file. My Mac will not open this type of file. What should I do?

Comments

  • khadkhad Social Choreographer

    Team Member

    Please make sure you are opening the link to install the Firefox extension in Firefox. It sounds like you may be opening the link and downloading the file in another browser like Safari or Chrome. Neither of those browsers will handle an XPI file, so they attempt to pass it to the OS to open. The OS can't open it either.

    Here is the direct link to install the Firefox extension. Please be sure to open it in Firefox and follow the onscreen instructions:

    https://agilebits.com/extensions/mac/firefox.html

    Does that help? Please let me know. :)

  • apvisionapvision Junior Member

    all was good Firefox 22, Mac OS 10.7.5, 1P 3.8.21 until I installed NoScripts. Javascript is enabled. Can I use extension for 1P with NoScripts. Is a NoScripts issue or 1P? I could always use Safari, but prefer Firefox.

  • apvisionapvision Junior Member

    yup -- that was it -- I merely changed default browser to Firefox -- tks.

  • khadkhad Social Choreographer

    Team Member

    It sounds like everything is working well now. Is that the case? I just want to make sure. Please let me know if you are still having trouble. :)

  • I cannot install 1P extension update(s) for Firefox. Safari and Chrome appear fine. This is the error returned after [Install Now] button is selected:
    "1Password could not be installed because Firefox cannot modify the needed file." I wasn't too worried because I have (also) encountered the disappearing extension toolbar which would load with a relaunch of Firefx. Now will not load the extension and I still cannot install the update to correct the problem either. Have turned off all apps in case of a conflict (I don't use many anyway). Considered it only slightly annoying before but now would like to resolve the issue.

    I have also tried by downloading the extension, open file using FFx with same result. Have checked FFx prefs and cannot see anything preventing the install. What does FFx want to modify to install the extension?

    sys info: OSX 10.7.5, Firefx 22.0, 1Passwd 3.8.21, ext version stuck at 3.9.9

    Thanks for any assistance you can offer.

  • khadkhad Social Choreographer

    Team Member

    Let's try completely removing and reinstalling the Firefox extension. Other browsers handle the removal of the SQLite file automatically when you remove the extension, but you will need to do this manually for Firefox:

    1. In Firefox, select Tools > Add-ons from the menu bar.
    2. Click the Remove button to remove the 1Password extension.
    3. Quit Firefox.
    4. In Finder, select Go > Go to Folder from the menu bar.
    5. Copy and paste the following path and press Return:

      ~/Library/Application Support/Firefox/Profiles

    6. Move the OnePassword.sqlite file you see there to the desktop.

    Then reinstall the 1Password extension in Firefox:

    https://agilebits.com/extensions/mac/index.html

    Once everything is working well, you can safely move the OnePassword.sqlite file on the desktop to the trash.

    If you're still having trouble, could you please send us a Diagnostics Report?

    Download the 1Password Troubleshooting utility and follow the instructions to generate the report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hi Khad, This was enormously helpful. I just couldn't get Firefox to show the key in the toolbar. I followed your steps here and it's fixed!

  • khadkhad Social Choreographer

    Team Member

    Great news! Thanks for letting me know that everything is working well. :)

    If we can be of further assistance, please let us know. We are always here to help!

This discussion has been closed.