Delete Primary Vault?

pgseyepgseye Junior Member

I did something strange when upgrading (I think I clicked on new 1Password user rather than existing). Anyway, I have now ended up with a 'Primary Vault' which is effectively empty and my usual vault which I importing by dragging the 1Password keychain stored in my Dropbox onto the open Dock app.

My issue is that every time I open 1Password, the vault defaults to the Primary (i.e. empty) one and I need to switch to my main vault. I can't seem to see a way to delete the Primary vault or at least change the status of multiple vaults (i.e. make my main vault the Primary one).

Any ideas?

Thanks,

Paul

Comments

  • From what I've seen while reading the forums, you can enable Dropbox sync for your Secondary Vault (the one that's not empty) and that will put a keychain file in your Dropbox. Then you can use that file to start a fresh keychain. You will have to delete the old stuff (make sure you put the one you created when enabling Dropbox in a safe place first).

    E

  • MikeTMikeT Agile Samurai

    Team Member
    edited June 2014

    Hi @pgseye,

    It's not strange, 1Password did what it is supposed to do. You told it that you were new to 1Password, which would then welcome you into a new vault.

    If you double-click on an existing data file from Dropbox or anywhere else, 1Password will prompt to create a separate vault that'll import that data file and sync with it. It is not supposed to import any data file into the primary vault but set up a new vault for each separate data file.

    Here's how to start over:

    1. Make a copy of your 1Password.agilekeychain file in your Dropbox folder to your desktop, don't move it, just copy it.
    2. Open 1Password, go to the 1Password Menu > Preferences > General and uncheck Keep 1Password Mini running. Now, close 1Password.
    3. Open a Finder window and select "Go to Folder" from the Go menu. Type this in the input field and then press Return:
      ~/Library/Containers
    4. Move all the agilebits folders you can find to the desktop. 2BUA8C4S2C.com.agilebits.onepassword-osx-helper, com.agilebits.*
    5. Now, back up a directory into the Library and go to the Preferences folder and move any agilebits plist file you can find to the desktop
    6. Due to how Mavericks aggressively cache its preferences, you'll need to reboot or restart the daemon responsible for the preferences. To do this, open Terminal, and enter this command: killall -SIGTERM cfprefsd
    7. Now, open 1Password, it'll look like it's brand new. Click "I've used 1Password before > Sync with Dropbox" and point it to your Dropbox folder.

    You should be all set here. We have an idea of how to skip almost all of those steps in the future but for now that should help.

  • SmudgeSmudge Junior Member

    @MikeT, one suggestion that I've seen used well with other apps is that if the user is holding down the option key when 1P is launched, it can ask if they wish to start over. If so, it would go thru the steps you have mentioned above so the user doesn't have to do it. Then it would present the user with a clean slate.

  • pgseyepgseye Junior Member

    Thanks guys - that works great.

  • sjksjk oversoul

    Team Member
    edited October 2013

    Glad you've got your desired Primary vault now, @pgseye!

    Thanks for the suggestion, @Smudge. We already have a similar one filed.

    Or perhaps at least a standalone 1P4 (MAS and website versions) 1Password Uninstaller application for 1P4 (MAS and Agile Online Store versions) like the one here for 1P3 (AOS-only version):

    Completely Uninstalling 1Password | 1Password 3 User Guide

    Whatever might help reduce the temptation for people to use problematic third-party app uninstaller utilities to "start over".

  • CraftGeekCraftGeek Junior Member
    edited October 2013

    Just a "me too".

    I converted my license from two singles to a family pack so I could install 1PW4 on our Mac server (fresh install). The install found an old keychain on iCloud that I didn't know existed and offered to use that. I didn't see an option not to, but I wasn't looking hard. This made the old keychain primary.

    I created a second vault and synced with Dropbox. I have since cleaned up the old keychain in iCloud but could not figure out how to remove the local copies. So, thanks Mike.

    Since there are several ways for users to find themselves in this predicament and the solution is NOT user friendly, I'll add my vote for an in-app solution, sooner rather than later.

  • Thanks @MikeT this worked.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @Smudges, we had that in the past with 1Password 3 and removed it later as it was causing many folks to get the start-over dialog out of nowhere.

    Apparently some of the app launchers were opening the app with the option key down. We have no idea why but it was causing confusion and potentially causing data loss, so we killed it. We need to make this option that requires human intervention and with an additional warning, so the option key is a no-go for us at the moment.

    One of the ideas is to do it in the Advanced Preferences instead or via the Help Menu > Tools. Neither will require unlocking 1Password app, so those are the better places and it is something we'd like to try in the near future.

  • I have the same issue after upgrading my wife's Mac. She was using Dropbox with 1Password 3, and I selected the ~/Dropbox/1Password.agilekeychain file during the upgrade. It wouldn't accept her master password after several tries, so I had to quit. When I opened 1Password again, the primary vault appeared (with the password I had been trying to use for the Dropbox vault), but was empty. I then added the Dropbox vault, but I would like to get rid of the Primary vault (or switch the Dropbox vault to be the primary vault).

    It looks like this user is having the same problem. No answer there, either.

  • I have (still) the same problem like pgseye. I tried the instruction given by MikeT but it did not work. I could start over with 1P4 but I could not choose between a new user and an old user.

    What can I do set my old vault as the primary vault? Thanks for your help.

  • eva_seva_s 1Password Alumni

    Hi dfehr,

    Can you be a little more specific about the issue you had with reinstalling 1P4? Also, where is your old vault currently stored?

  • I had a similar problem. I show to 1Password the file inside my Dropbox folder, he sees it, asks for the master password. I enter it, press "enter" and the only thing that happens is that padlock now appears open on the "submit" button. Solution by MikeT did not help. Had to remove everything but the .agilekeychain file. Besides files listed by MikeT that also included 1Password folder in ~/Library/Application Support/, some logs, etc. I've used CleanMyMac and default finder search with "system files" criteria turned on. Now that was a bad experience when switching to licensed version.
    I can also mention that I was using 1Password 3 some time ago (not from App Store), then I was using 4th version (also not from App Store) and now I have a 4th version from App Store. So maybe some app traces broke keychain unlocking.

  • I am having the exact same issue as #10. I go through the steps, open up 1p, select my keychain and it requests an unlock. I can enter the password, then I press enter to unlock, the lock pad switches icon (to unlocked) and then nothing happens. It just sits there. After a few seconds the icon switches back to unlock but at this point you become unable to unlock it again. The lock pad icon no longer switches. After a few futile attempts you close the application and reopen it and then you are presented with the new empty primary vault.

  • I am having the same issue as Kenneth Ulmer. I updated to 1Password 4 (I had the demo version of 3 installed from your website, then installed 4 from the Mac AppStore). This is very annoying - AgileBits, please fix ASAP!

    There are two solutions that I found:

    1. I double-clicked on my old 1Password.agilekeychain in my Dropbox folder. That launched 1Password 4. It then forced me to import this into a new keychain called 1Password. Fine. Annoying. I then exported this via File => Export => All Items => Enter vault password => 1 Password interchange format. Save then import into Primary Vault.
    2. You can try to sync the empty Primary Vault to your Dropbox folder. This will notice the old 1Password.agilekeychain file from your old version and ask if you want to merge with it. Say yes, and you're merged and good to go.

    Still, AgileBits, this is really annoying and really degrades an otherwise good experience with your app. Clearly you have not tested this sufficiently. Please fix this ASAP. I'm happy to give you a good AppStore review, if you fix this obvious bug ...

    Thanks!

  • MeganMegan

    Team Member

    Hi @iosdev,

    I would like to apologize for the delay in responding to you here but we have been a bit overwhelmed since the launch of 1Password 4 for Mac. We're all working hard and putting in extra hours to get back to our usual snappy responses and we really appreciate your patience.

    I'm so glad to hear that you found a solution, but I do apologize that it was a bit of a process for you! I've passed along your feedback to our developers - we'll do what we can to make the set-up process simpler and more intuitive in the future.

    For anyone else who is finding that 1Password isn't immediately finding an existing keychain, please see our support article:

    Helping 1Password find existing data in Dropbox

  • I am having the exact same problem as pgsye (question 1 in this thread). I upgraded this week from 1PW 3 to 4.2.2 from the website. What is frustrating me is that now I have 2 vaults, Primary Vault and 1Password 4 Vault. All my data is in the 1Password 4 Vault. The Primary Vault is empty, and to see the Vault with my data in it I have to switch to it, since 1PW opens to the Primary Vault by default.There seems to be no way to delete that Primary Vault, although there is the option to delete the 1Password 4 Vault (which of course I am afraid to do because that one has all my data showing). I have followed all of the suggestions in this thread to a T but 1PW still defaults to the Primary Folder (which wasn't there in 1PW 3). I want only one Vault! Is there a way to get all the data that is in my 1Password 4 Vault into the Primary Vault perhaps? Everything I have tried doesn't work. One thing I did notice on upgrading to the newer version is that I never got the message page I am a new user/I already have a 1PW account, etc. There were no boxes to check. I hope someone can help.

  • sjksjk oversoul

    Team Member

    Hi @JanetS5,

    I'm sorry that all of your 1Password data has ended up in a secondary "1Password 4" vault instead of being in the Primary vault.

    Do you have any 1Password data in Dropbox and is the "1Password 4" vault in 1Password 4 currently configured to sync with it? You can check the syncing status by opening 1Password’s Preferences > Sync window. It'll look similar to this if syncing is disabled:

    And similar to this with Dropbox syncing enabled:

    Once we've determined the syncing status of that vault we can better suggest how you can move its data into the Primary vault. Thanks!

  • My 1Password 4 prefs under the Sync tab show the second image, not the first. Forgot to say I am using the latest update to Mavericks, if that's relevant.

  • sjksjk oversoul

    Team Member
    edited April 2014

    Thanks, @JanetS5. It's helpful to know that your secondary "1Password 4" is currently configured to sync with 1Password data in Dropbox.

    To ensure that all of your data will be transferred to your Primary vault, please send us a Diagnostics Report from your Mac, along with a link to this topic and your forum username, to [email protected]. A brief comment here mentioning that you've sent the report would also be helpful. Once we've seen it we'll email you specific instructions for moving the data. Thank you!

    .

  • edited April 2014

    I've had the same problem on some installs, multiple Vaults and with no simple way to delete the primary vault or remove or merge all the vaults into the one.

    I ended up syncing my preferred value to a folder, exporting the data of any other vaults (to plain text), then deleting the 1Password Data directory (under Mac OS X: ~/Library/Application Support/1Password 4/Data), of cause while making sure 1Password mini wasn't running in the process.

    When opening up 1Password again, I was able to select my synced keychain as my main vault, then import the additional export vaults into the one.
    This allowed me to effectively merge all the vaults into one. Being able to delete or merge with the Primary vault would have been much more preferred, but obviously isn't a feature yet.

  • sjksjk oversoul

    Team Member

    Hi @desertcrystal,

    I'm glad you were able to merge multiple vaults into a new Primary vault and am sorry it was a cumbersome process. This improvement in 1Password 4.3 can be a helpful alternative to exporting/importing data:

    • Added the ability to move items (in addition to copy) from one vault to another

    I run File > Backup before copying/moving larger numbers of items between vaults or making other significant changes to the 1Password database to ensure having a current backup to restore in case of any mistakes or trouble.

  • I tried MikeT's instructions in post number 3 and it worked, except that after that every time I opened 1Password I got the Get Started screen popping up, and every time I closed it I got the popup asking if I want to enable 1Password Mini (even though I ticked the "Do not show this message again" checkbox).

    I tried deleting the app, trashing preferences and reinstalling, but that didn't solve the issue. I restored the original files deleted from the trash and restarted, but no joy. I eventually solved the issue by doing a spotlight search for "agilebits", deleting anything it found, restarting, emptying the trash and reinstalling the app again.

  • sjksjk oversoul

    Team Member

    Hi Scott,

    I hope 1Password is working well for you now, with all of your data where it belongs. I'm sorry it took such drastic measures to resolve the problem you were having.

    Please let us know if you run into any more snags and we'll be happy to help you untangle them. :)

  • Chaps - great support from the AgileBits guys, thank you. Sorted most of my issues out.

    Only one it didn't was the Primary and 1Password vaults on the iPhone and iPad - they had both vaults on them. To share the solution: delete the app and reinstall and select 'I've used 1Password before' then select the Dropbox sync option.

    All now back up and running.

  • sjksjk oversoul

    Team Member

    You are most welcome, @mylife98!

    I'm really glad that you've got this all sorted out now. And thanks for sharing the extra app reinstallation and 1Password data recovery from Dropbox steps you took to do it on your iPhone and iPad. :)

This discussion has been closed.