Revert back to 1Password 3 from Apple Store since 1Password 4 does not work with Dropbox

mrbarkermrbarker Junior Member

I am wondering what my options are for reverting back to 1Password 3. I have spent way to much time trying in vain to get syncing to work using Dropbox in my environment.

My wife and I have a Mac Book Pro an iPhone and an iPad. We each have a Dropbox account and share the 1Password.agilekeychain between our Dropbox accounts.

When I first installed 1Password 4, I lost around 70 items from my database. When I opened 1Password 4 on my machine the last entry was from March 2013. I disabled sync to Dropbox and re-enabled it and magically the items reappeared. I then noticed that no mater what I did my desktop would not sync with my mobile devices at all. At this point I disabled syncing on all my wife’s devices and did not upgrade her to 1Password 4. I read many posts regarding Dropbox syncing problems and felt that my problems could be related to the fact my 1Password.agilekeychain folder was located in the root of my Dropbox folder and not in a 1Password folder. So I removed the 1Password.agilekeychain folder and re-enabled sync with dropbox. This created the 1Password folder with the 1Password.agilekeychain folder within. I then was able it seemed to sync items between my mobile devices and the Desktop. This was promising so I proceded to get my wife's machine syncing again... This has not gone well, I stopped syncing to dropbox on her machine, removed the 1Password.agilekeychain and then had her conect to the shared 1Password folder. When the 1Password folder had completed syncing to her machine, I attempted to sync with Dropbox. 1Password says that it is syncing with the correct file Dropbox/1Password/1Password.agilekeychain, however there are now three agilekeychain files in Dropbox/1Password and I am no longer syncing items added/changed on any device.

I had created a backup in 1Password3 and would love to get off this mery-go-round and just have a working system again. What are my options?

Comments

  • I'm in a similar pickle with similar issues with my wife's and my own laptop. I was running 3.9 from MAS prior to 4.0 from MAS and I do not know of a way to get the 3.9 app back from App Store. I have opened a case to at least try to get the most recent 3.8 (or 3.9 if they're able to provide it). I am hoping to be able to restore from my most recent 3.9 backups. I suspect there may be some issues with reverting to 3.8 due to sandboxing, but I am not certain of this--I would guess that an attempt to wipe it all clean would be a good start though. Naturally I'm going out of town in about 90 minutes, so my time is short to resolve this! :-(

    --Larry

  • So here are the steps that I took to revert back to 3.8.21 (which we still had licenses for):

    1) Quit 1P4
    2) Quit 1P4 Mini
    3) launchctl list | grep agile
    (nothing found)
    4) ps -ef | grep pass
    (nothing found)
    5) rm -rf /Applications/1Password.app
    6) Reboot
    7) Unzip 3.8.21 and drag it to Applications
    8) Open all browsers and remove 1P4 extension
    9) Open 3.8.21
    10) Install browser extensions
    11) Verify backups
    12) Verify dropbox sync

    All in all a straightforward and clean process so far on both of our laptops, whew!

    I found a link to 3.8.21 in MikeT's post: http://discussions.agilebits.com/discussion/comment/86553/#Comment_86553

    --Larry

  • mrbarkermrbarker Junior Member

    Thanks Larry, I appreciate the detailed response and will look into making this change. Sadly I do not own a license for the 3.8 non Apple store version, so I will have to make a decision on how to proceed. I am still reeling from how bad this upgrade went.

  • Same problem here. Can not revert to 3.x since I bought it from App Store. Agile Bits needs to fix this asap

  • GrumGrum
    edited October 2013

    @Gooner:

    Can you not restore 3.x from your backups?
    I have the App Store version and am seriously considering trying this.

  • vonvon Junior Member

    This worked for me so just a suggestion,I got 1password 4 working on the iMac did a back up then deleted the dropbox keychain file then did a sync.
    Removed and reinstalled the software from iPad Ipod and MBP and every thing seems to be fine now.A long winded process but worth the trouble flor mekeychain

  • @Grum,

    No, I usually don't keep backups of my Applications folder. Maybe I should start doing that... :-)

  • roustemroustem AgileBits Founder

    Team Member

    The Dropbox issue is only happening in the Mac App Store version of 1Password 4.

    It might be easier to use the 1Password 4 from the AgileBits website. We will make sure that if you purchased the app from the Mac App Store then there is no need to buy another license to run the website version.

  • I need to revert to 1P3 asap because the 1P4 update caused loss of important data. Can you please help me?

  • RDHRDH Junior Member
    edited October 2013

    We will make sure that if you purchased the app from the Mac App Store then there is no need to buy another license to run the website version.>

    How?

    And does this solve ALL the issues with MAS version?

  • roustemroustem AgileBits Founder

    Team Member

    I posted an update on Dropbox sync issue in this thread:
    http://discussions.agilebits.com/discussion/comment/87235/#Comment_87235

  • roustemroustem AgileBits Founder

    Team Member

    @Niklas,

    Please let me know what's happened and we'll try to get it fixed.

  • mrbarkermrbarker Junior Member

    @roustem,

    Thanks for commenting about this issue and glad to read in your comment to the thread linked above that you have identified the problem with the MAS version and are investigating a fix to the issue. To be honest your product has always 'just worked' and I have in the past just taken it for granted, so that when things started to go south, it caught me by surprise. Having written rudimentary syncing software I should have known better and since the MAS version puts you at a slight disadvantage, kinda like running a sprint with one leg tied behind your back ;-) It is understandable that there could be fallout. Anyway my post here was more of an 'oh snap' mostly because I came into this situation by just upgrading without thinking. I have subsequently put my hands on a 'trusted' known good backup of all my data and can wipe all the clients and Dropbox data stores and then restore to make sure everything is working. Oh and when I looked, I actually already have a Family license to version 3, so I was able to downgrade to 3.8.21 using that license. Since you mentioned that the problem does not exist using the non MAS version, I will upgrade my license to 4 and stick with the non MAS version going forward. Our families configuration is enough on the fringes that I think for us it makes more sense. Thanks again for an awesome product and hope to have many more years of having it 'Just Work'.

    I do have anotherr question that I posted regarding using Dropbox to share the 1Password keychain. You can find it here: http://discussions.agilebits.com/discussion/16684/is-syncing-using-a-shared-dropbox-folder-for-two-or-more-1password-users-a-supported-config

  • roustemroustem AgileBits Founder

    Team Member

    Thank you, @mrbarker. I appreciate the support!

    I replied to your question about the keychain sharing. Please note that in 1Password 4 it is also possible to share and sync secondary vaults.

This discussion has been closed.