1Password 3's Safari extension not working on Mavericks

MikeTMikeT Agile Samurai

Team Member
edited October 2013 in 1Password 3 – 6 for Mac
This discussion was created from comments split from: Safari Extension Not Working in Mavericks.


  • Hi,

    I'm sorry for posting here instead to create new topic.

    I'm using 1Password 3 (3.8.21) on Mavericks with Safari extension (1P v. 3.9.19).
    Everything look fine, I can click to unlock, search, copy.. But shortcut or click to fill in username and password not working!

    Hope you can help,

  • MikeTMikeT Agile Samurai

    Team Member
    edited October 2013

    Hi @IamJay,

    Is there a red badge on the 1Password button in Safari? What about other browsers, does 1Password work there?

    Try reinstalling the extension in this guide and see if it'll work.

  • Hi MikeT,

    There is no red badge on the 1Password button in Safari, and I did the step as you suggest.
    Now, 1Password Extension back yo live again, Many Thanks for you help!

    Now I can use shortcut or click to fill in username and password on the opening page. But all 1P Bookmarks that I safe for 1 click instant fill and auto login not working.
    I did try to recreate some 1P Bookmarks but not working, the target page open and doesn't fill anything, I have to manual click the 1P button to login to that page.

    Many Thanks for your help mark, 1p Extension working again, not perfect as it used to be but that's ok for me now.

    Hope you can update the Extension (for 1Password 3) to fix the 1P Bookmark Bug, or any suggestion please let me know.

    Thank You and HavE a NiCe DaY!

  • Safari extension is not working in mavericks for me either.

  • Same problem here.

  • Hi @jcgiff and @kzolnowski,

    I'm sorry to hear that you're having trouble with the Safari extension in Mavericks. Did you see Khad's post about "Problem with database" in v3 extension in Safari on OS X Mavericks? If his instructions don't fit your situation, please let me know if you seeing the problem in any other browsers, or if reinstalling the extension helped. :)

  • I've uninstalled and reinstalled the safari extension.
    Filling the user id and password still does not work in Safari 7.

  • Hi @firstclassff,

    Thanks for trying reinstalling the extensions - that's always a good first step when trouble strikes. Next, could you please let me know if Khad's solution (from my earlier post) helped at all?

  • When I meant reinstalling the extension, I meant following Khad's solution of deleting files from ~/Library/Safari/Extensions and ~/Library/Safari/Databases. No luck here.

  • Hi @firstclassff,

    I apologize for misunderstanding - I just wanted to be sure all our bases were covered! Because the next step requires a bit more information. In order to track this down, Could you please send us a Diagnostics Report?

    Using your browser please download a small standalone tool from us that will run a networked copy of our diagnostics tool.


    After the download is complete, use Finder to locate it. It should be in your downloads folder. If the file ends in .zip then your browser has not already unzipped it. Please double click it to expand it.

    The expanded file will have a "Unix Executable File" named 1Password_diagnostics. Double-clicking this will cause a Terminal window to open and download some files it needs. (Note: If you use OS X Lion or Mountain Lion, you may need to right click the file, choose Open, and click Open on the dialog).

    Once it completes it should open a window in your browser with the results. Please click File->Save As to save this file to your computer. Please save it as "Page Source" or "HTML" if there are options for this.

    If you do not get a report created, please copy and paste the output from the Terminal window so we can take a look at the errors that were created. This will help us figure out where the problem is in creating the diagnostics report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hello @Megan,

    I've sent generated report to your support. I hope this will help you to fix this issue :)


  • Hi @kzolnowski,

    We'll work with you via email until everything is resolved so that we are not duplicating efforts or creating any confusion. Thanks for your patience :)

  • Thank you @Megan.

    I found a temporary solution. Extension seems to start working after resetting Safari (Safari -> Reset Safari...) [except browser history] and reset my computer.

  • Hi @kzolnowski,

    Thanks for passing that along!

  • I had this same problem that just crept up today for some reason, though I've been running Mavericks for weeks and had no problems previously. Anyway, for me at least, reinstalling the Safari extension (even after deleting the Library files as specified by Khad) did not solve the problem, but restarting my Mac did the trick. I did not have to reset Safari.

  • Hi @brabin,

    I'm so glad to hear that you were able to sort things out! Thanks so much for posting your steps here. :)

  • I was having a similar issue. After working since updating to Mavericks, today I found that the Safari extension was no longer working. Every time it appeared to successfully reinstall, when I tried to fill in a username/password with the shortcut it would not work. I had recently replaced Symantec with Sophos for my anti-virus program. On disabling the "Web Protection" features in Sophos and restarting Safari, things started working again. Looks like I'll return to Symantec unless there is a way to tell Sophos that their software is blocking legitimate software.

  • Hi @AlfredK,

    We have a handy little support article on Configuring Sophos to ensure that 1Password and Sophos play nicely together. :) I hope this helps, but please let me know if I can be of any further assistance.

  • Hello,
    I have a problem with 1Password Extension for Safari on my MacbookPro. I upgraded to Mavericks sometime ago, and the extension worked properly. Yesterday, a pop up message appeared (while using Mail) saying that I still had the an old version of the extension installed on safari and that I should upgrade to version 4. So I uninstalled v3 and downloaded from your site the latest version (which is still v3... ???). I did the same on Firefox. While the extensions works fine on Firefox, it no longer works on Safari. When I enter my password and click "enter" a connexion "count" begins. See attached image. I tried all the above solutions, but none works.
    I would be very grateful for your help.
    Many thanks !!

  • Very strange, I uninstalled the extension once more and downloaded it again (now v4 while few minutes ago it was v3).

    FYI, when I followed your suggested solution (see: http://discussions.agilebits.com/discussion/17249/problem-with-database-in-v3-extension-in-safari-on-os-x-mavericks#latest) I only deleted "safari-extension_com.agilebits.onepassword-safari-2bua8c4s2c_0" (as suggested) but now I also deleted "safari-extension_com.abine.dntpsafari-82m4selzcb_0" from "~/Library/Safari/Databases/ ".
    Anyway, all sorted out now :-)

  • Hi @jonathanNewman,

    I'm so glad to hear that you've managed to sort things out!

    Just to clarify, there are currently two versions of the 1Password extension available, and which one you use is dependent on which version of 1Password you have installed. If you are using 1Password 3, you'll want the version 3 extension, which is available for download here. If you have upgraded to 1Password 4, you need to be using the version 4 extension, which can be found here. :)

  • It is NOT sorted out at all, I'm afraid.

    It is great that eveyone in here is so technically skilled and can go into the libraries, OS X backend, and delete folders and files.
    HOWEVER, most of us are not capable. AND we cannot be expected to waste so much time and energy on it.

    A product like 1 password should function. Always. Period. With alle standard browsers and OS X whatever.
    You have made us totally dependent on your product. We paid a lot of money for it I now cannot work from my Safari browser (which is the one I need to use) exactly beacuse of the problem described above:

    I get the red dot (with the number '1') and the "Extension database bla bla." And I cannot find the folders to delete no matter what I have tried, following Khan's instructions closely.

    This will simply not do and I want my money back. Or I want someone to PROPERLY fix it.

    Safari Version 7.0.1 (9537.73.11) 1 PW: Version 3.8.21 (build 32009)

  • Hi @thingsdontwork,

    I'm so sorry to hear that you've been having difficulties here: I know that poking around in Library files is not always an easy (or fun) thing to do.

    To help you understand why this annoying process has become necessary, I'd like to talk a bit about the wonderful and exciting world of software development. :) Unfortunately, what you're seeing is the result of the breakneck pace of technology today. 1Password 3 was designed to work great with OS X 10.5. Apple has now released Mavericks, which is version 10.9. Between 10.5 and 10.9, Apple has made some big changes in their operating system, including some significant changes to the backend architecture of things. This means that the ecosystem that 1Password has to operate in is, in some ways, radically different. As an example, in Mavericks, Apple updated one of its programming languages from Ruby 1.8.7 to Ruby 2.0. 1Password's import scripts are written in Ruby 1.8.7, so now users need to essentially run a translation script to help the import feature operate correctly with the new language. The issue we're seeing with Safari is a similar example.

    1Password 3 will continue to work great in the ecosystem that it was designed for. As that system changes however, developers are faced with the choice: continually patch up aging code (using more and more outdated tools) to force existing features to function, or to take advantage of some of the new tools available in the new ecosystem to build a better, stronger, faster product with features designed for the new environment. We made the decision to build a new version of 1Password with some great new features, including a more stable, reliable browser extension.

    If you do not want to upgrade though, you are welcome to continue using 1Password 3 and I'd be happy to help you troubleshoot this issue to get your extension back up and running again.

    Finding those pesky Library files doesn't require too much advanced knowledge or technical skill. You can read about how to view the Library folder in Mavericks in this handy MacWorld article, or simply click the Go menu item in Finder and hold down the 'Option' key to reveal Library in the list.

    I hope this helps you track down those files, but if you have any further questions, we're here for you!

  • romanyromany Junior Member

    same issues here. it worked for months with mavericks, but just stopped today. i can click on the toolbar icon, the menu opens, but it doesn't fill in the forms, nor does the shortcut work. tried to delete the extension and database, reinstalled the extension, changed the sophos preferences... nothing helps...

  • Hi @romany,

    I'm so sorry to hear that you're having trouble with Safari right now. Just to confirm, you follow Khad's instructions here: "Problem with database" in v3 extension in Safari on OS X Mavericks, correct?

    If that didn't fix things, I'd like to take a closer look at your system. Could you please send us a Diagnostics Report?


    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

This discussion has been closed.