Windows 8.1 on Surface Pro

Installing the Windows version of 1Password on a Surface Pro running Windows 8.1 interferes with the tablet writing function. Pen strokes disappear, or are inserted automatically before the letter can be completed. Uninstalling 1Password fixes the problem.

This was not an issue before upgrading to Windows 8.1. 1Password and the tablet writing function both worked fine under Windows 8.

Will there be a new version of 1Password released for Windows 8.1? Including an extension for Firefox? Not being able to install 1Password creates a major inconvenience not being able to copy and past robust passwords from 1Password running on the same machine as where I need to enter the password, or being able to log on to sites directly from 1Password. I have to retype them manually from my phone.

Thanks.

«1

Comments

  • DBrownDBrown 1Password Alumni

    Hi!

    In what program are you having the problem with pen writing, and in what way does it fail to work as expected?

    I have a Surface Pro 2 running Windows 8.1, and I haven't seen any pen-related problems. In fact, the only problem I've encountered is that the virtual keyboard doesn't display Ctrl and \ at the same time, so I had to change my 1Password key combination to Ctrl+, (comma).

    1Password for Windows already includes an extension for Firefox, which you can enable on the Browsers tab of the preferences window in the main 1Password program (as with all the browser extensions).

    I hope that helps.

  • edited November 2013

    I'm experiencing exactly the same issue as Urban Rockstar. The first line of the handwriting input screen doesn't keep the strokes onscreen, instead inserts the first guess of the word. Everything thereafter disappears as quick as you can imprint it. The second line of the input screen works as per normal.

    Uninstalling 1Password (1.0.9.338) fixes the issue for me as well. Running 8.1 on Surface Pro 2. First time I had the problem I did a full refresh. It was only after I installed Dropbox, then 1Password that the problem comes up.

    Tested the handwriting in Office 2013, Notepad, Wordpad etc. Happens in all apps.

  • DBrownDBrown 1Password Alumni

    Thanks for mentioning the handwriting keyboard, @Pixel_Spartan! I now see the effect you describe (which seems more complicated than first-line-fails), and I'll bring it to the attention of Development. Sorry I hadn't seen it earlier, @urban_rockstar.

    To set realistic expectations, though, a fix is likely to be a while in coming, as we're very early in testing on tablets (currently limited to my Surface Pro 2, in fact).

  • I think there is a workaround until there is another update. If you install (and run) 1Password in Windows 7 compatibility mode it seems to work normally again. Should there be any quirks come up, I shall mention it here. Thanks for the response.

  • DBrownDBrown 1Password Alumni

    I don't recall seeing that as an option, @Pixel_Spartan. Do you happen to remember the specific steps?

    I'd love to test the procedure on my SP2 and publish it for others to use, too.

    Thanks so much for your help!

  • Go to the 1password app or shortcut on the desktop or taskbar > Right Click > Select ' Properties'

    This will pop up the properties dialog window. Third tab is called 'Compatibility'

    Tick checkbox 'Run this program in compatibility mode for' > Windows 7

    If you reset the surface pro for any reason ( power + volume up key) you'll need to redo the above steps. You might need to bring up the task manager (power + windows key)
    to end task any running instances of the app before it works

  • DBrownDBrown 1Password Alumni
    edited November 2013

    I'm not able to consistently reproduce the problem—sometimes the first character is dropped, sometimes the first word or two, sometimes the entire top line, ...and sometimes the problem doesn't happen at all: the handwriting area works perfectly. In my tests, the problem never occurs unless the main 1Password program is actually running—just having it installed doesn't cause the problem to happen on my SP2.

    At any rate, I tried the suggestion by @Pixel_Spartan, above (running 1Password in Windows 7 compatibility mode), and I haven't seen the problem since. Thanks, @Pixel_Spartan!

    If you encounter the problem and try the suggestion, please let us know how it works for you!

  • DBrownDBrown 1Password Alumni

    According to a customer who contacted us by e-mail, the problem appears when 1Password is installed, even if the browser extension (for Firefox, in his case) isn't installed, pointing to 1Password (rather than the extension) being the problem.

    I haven't been a developer in decades, but I have a hard time imagining how the mere presence of 1Password.exe on a system could be a problem, so I'm thinking it's more likely the 1Password Helper running in the background, but that's a TOTAL GUESS.

    I'm leaving this comment so that Development has access to this additional bit of information, in hopes that it'll help guide the investigation.

  • I noticed the problem pops up here and there even if I haven't run 1Password (after a restart). The solution is always to End Task the running 1Password in the background (the Helper?) and the handwriting returns back to normal.

  • DBrownDBrown 1Password Alumni

    Thanks, @Pixel_Spartan! That's the way it was looking to me, too.

  • So this is what's causing it! I've been searching online everywhere to try and find out what's causing my handwriting to go haywire on my Surface Pro 2 and I never thought it was 1Password! I've always had to restart the Input Panel service to get it to work normally.

    Now, I have tried applying Windows 7 compatibility to all of the 1Password .exe files in its Program Files folder and then restarting, but that hasn't solved it. I'll try reinstalling 1Password with Windows 7 compatibility switched on later and report back if that solves it.

    But thank you @urban_rockstar for bringing my search to an end!

  • OK, time for an update. I reinstalled 1Password with the install file set to Windows 7 compatibility but it doesn't fix the problem. Using Task Manager I've identified 'Agile1pAgent.exe' as the culprit. If this is running, I get the problems – if not then handwriting works fine. I've tried setting the compatibility on this file to both Windows 7 and Windows XP (SP3) but no luck.

    Can anyone else help, please?

  • DBrownDBrown 1Password Alumni

    Thanks for that information, Tom!

    We're trying to figure out what about the Agent might be causing the problem.

  • Thanks for all these posts. Glad to know I'm not crazy or it was not just me. I put Microsoft through the wringer trying to figure this out.

    I'm quite clear 1Password is the problem. I install it and writing doesn't work. I uninstall it and writing works fine.

    To respond to the question about what about the writing doesn't work: this is not limited to any software; it is all software including input boxes for browsers and the like. It is a function of Windows 8.1 on a tablet. As those with Surface Pros know, to use tablet writing, a box pops up that one writes in with the pen, or finger. The device takes a fraction of a second to decipher the strokes and then converts the handwriting into typed letters and words, still in the pop up box. The user can make corrections if necessary. If the user is satisfied, then and only then the user clicks "input" and the text is inputted into the document, browser or software. Its ability to decipher really bad handwriting especially mine is amazing. Overall it is a wonderful functionality and my favorite part of the Surface Pro.

    The malfunction when 1Password is installed is the strokes for a letter either disappear, or are inputted out of the pop up box into the document almost instantly when the pen or finger is lifted from a stroke, even before the letter or word is finished. This premature input almost always is wrong as it does not have the complete letter or word. It makes the writing function unusable.

    As for the fixes, I don't think I have the time, patience or skill to try the Windows compatibility mode, and sounds like it may not always work, but good to know that may be an option. Also good to know about Agile1pAgent.exe from Tom Stone. But again, I don't want to have to be going to Task Manager to make my device and software work.

    The problem from 1Password running in the background makes sense. But I don't think I want to turn that off; part of the functionality I like about 1Password is it popping up to capture password entries it does not have, and to be running as an extension on the browser so I can easily import from it to log in to a page.

    1Password is otherwise a wonderful product. I've been using it on my other devices, iphone and PCs, for about two years, and have grown a little dependent on it. With this resource I've been able to easily make my password practice much more secure.

    So I'm disappointed that it sounds like this may not be looked at for awhile. That means I have to look at long, robust passwords on my phone, including non-letter characters, and then manually try to type them on the Surface Pro. A work around, but laborious and not what I paid $99 to AgileBits for. I had heard that this product favors the Mac environment, and this experience supports that belief.

    I see there is a new release of 1Password, but there is no mention of this issue in the release notes, so I won't be installing it on my Surface Pro. I'll be waiting eagerly for a release that fixes this bug. Thx.

  • DBrownDBrown 1Password Alumni
    edited December 2013

    Thanks for your post, @urban_rockstar!

    I agree that the handwriting recognition is very impressive. It's a feature I always wished my iPad included.

    The Surface Pro 2—and indeed the touch-screen environment in general—is still terra incognita to us on the Windows team. I've advocated for Development getting hold of one, as I did, which I hope will speed the process of figuring out where the conflict is occurring. That's not a commitment to fix it in any particular release, because that's not my decision to make; but I want to make sure you know we're not ignoring the problem—just applying limited resources where we can.

    I hope that offers at least a glimmer of hope for a better answer in the future.

    Thanks so much for understanding!

  • Keep in mind writing was working fine on the touch screen with 1Password under Windows 8. The problem arose only under 8.1, if that helps.

  • svondutchsvondutch

    Team Member

    @urban_rockstar are you running 1Password 1.0.9.x or the 1Password v4 beta?

  • 1.0.9.339 on my other devices. Nothing presently on the Surface Pro. I doubt it was beta. I don't do beta. The version I downloaded and since deleted was whatever was the current version downloaded off the AgileBits site.

  • Terry TignerTerry Tigner Junior Member

    This was my exact problem!!! Arggghh! This wasted hours!! Finally I found this post and booted 1Password off the island.

    Now my SP2 works like a charm.

    Please Agilebits, fix this and let us know when it is rock solid.

  • DBrownDBrown 1Password Alumni
    edited February 2014

    I'm sorry for the wasted time, Terry. :(

    We are in very early stages of testing on non-iOS tablets, and that limited testing is being done with 1Password 4 for Windows (currently in beta development) on a Surface Pro 2. I'd look for any advances to be made in that version, and only after completion of initial development.

  • jchiarjchiar Member

    I have a Samsung convertible tablet PC running Windows 8.1. I installed 1Password 1x . Long time Mac user, iPhone, ipad user.

    Is there a Metro version of the App or just the desktop version?

  • svondutchsvondutch

    Team Member

    Is there a Metro version of the App or just the desktop version?

    Desktop version only.

  • Terry TignerTerry Tigner Junior Member

    Follow up note to DBrown and the Agilebits team:

    Thanks, DBrown for your comment regarding that 1Password is not able to work on my Surface Pro 2. I do look forward to when a version will be ready for this platform.

    You mentioned testing taking is place for "non-iOS tablets." For what it's worth, I am also using an Asus VivoTab 8 which runs Windows 8.1. It is one of very few early models built on a BayTrail CPU AND including a full Wacom digitizer layer. So, compared to the Surface Pro 2, while the processor is different and it is a 32bit version of the OS rather than the SP2's 64bit Win8.1 - it IS the case that the Asus VivoTab8 is running 1Password without the Input Panel conflict that exists with the Surface Pro 2. Your team probably already knows this, but I thought I'd mention it.

    One last question: How would I know, or what should I look for to be informed when a version of 1Password will be available and fully support the Surface Pro 2??

    Thank you.

  • DBrownDBrown 1Password Alumni
    edited March 2014

    Thanks for that info, Terry! At this time, the Surface Pro 2 is the only non-iOS tablet on which 1Password for Windows (the version 4 beta, to be precise) has been tested, so all the information like your that we can gather is very helpful.

    I'm sure there'll be announcements here in the forum and probably in the AgileBits blog, but the surest way to see what's in any release is to scan the release notes that are offered each time there's an update. (The full history of release notes is also available from the Help menu in 1Password.) Note that I would expect tablet compatibility eventually to be a feature of 1Password 4 for Windows.

    Thanks again for taking time to share this information with us!

  • Thanks to the 1Password Windows team for looking into this! I have been suffering the same problem and am glad to hear that the team is working on it.

  • Came on the forum to look for help with my Chrome extension, and stumbled across this thread... Brilliant! This explains why the handwriting on my Surface Pro no longer works. Thanks Urban_rockstar for highlighting this, now I'll look forward to the fix.

  • DBrownDBrown 1Password Alumni

    Be sure you're watching the 1Password 4 beta builds for any improvement.

    You can sign up for the beta program here: https://agilebits.com/beta_signups/winnewsletter.html

  • I just downloaded the latest beta (458) and immediately saw the same problem. I'll post it in the Beta forum, too. Thanks for tracking this down! I really miss 1Password on my Surface!

  • DBrownDBrown 1Password Alumni

    We apologize for the inconvenience, @robcourtney‌.

  • Hi,
    I am having a similar problem on my Surface Pro ever since I downloaded windows 8.1 about a week ago.
    When i try to hand write onto PDF's on reader, the handwriting starts out normal, but after a bit of use it doesn't link the letters as well but instead they come out as straight lines as opposed to curved. There is also a lot of lag when this happens. Although if i open up another app to write on such as notes, then it writes as per normal. This was not a problem before i updated my tablet.
    Also i am having problems with the mousepad on my type keyboard, sometimes it doesn't seem to recognise that i am touching it, however when i disconnect and reconnect my keyboard it works.
    I am not sure what 1password is or if i have it, when I search my computer for it nothing comes up.
    Thank you.

This discussion has been closed.