Windows 8.1 on Surface Pro

2»

Comments

  • DBrownDBrown 1Password Alumni
    edited March 2014

    Check the Task Manager for 1Password.exe and Agile1p*.exe; if they're there, you have (or at some time had) 1Password installed.

  • You might try uninstalling any custom programs or apps until writing works normally again. Then reinstall one at a time, testing writing after each one. You might find the culprit. That's how I discovered 1Password's incompatibility. If you don't know what 1Password is you probably don't have it. It's an expensive password vault you have to buy.

  • After some fiddling with 1Password in my Surface Pro 2, installing, removing, running in compatibility mode, etc., I've found a way to keep both 1Password and handwriting recognition working, at least for me.

    Under compatibility tab for the Agent, just check the option for "Disable display scaling on high DPI settings". If you dont know how to change it, just follow these steps:

    • Open Explorer and navigate to C:\Program Files (x86)\1Password
    • Right click on "Agile1pAgent" and click Properties
    • Click the Compatibility tab, and there, check "Disable display scaling on high DPI settings".
    • Reboot (or just open Taks Manager, kill all 1Password processes, and then doublelick Agile1pAgent)

    Working with 1Password 1.0.9.340 and Windows 8.1 up to date.

    I hope this helps Agilebits to find where the bug is (in case they haven't found it yet).

  • DBrownDBrown 1Password Alumni

    Marino, I've just confirmed that those steps DO WORK for 1Password 4 for Windows. (I don't have 1Password 1 installed on a Surface Pro 2, as all our testing on the SP2 is being done with beta builds of the new version.)

    Thanks so much for sharing this procedure!

    Have you perceived any disadvantage to leaving Agile1pAgent.exe configured this way permanently?

  • No problems so far. I have used it only for two days after applied the setting to the agent and in those two days I have used 1Password as usual.

  • DBrownDBrown 1Password Alumni
    edited June 2014

    Excellent. Thanks for the follow-up, Marino!

  • Terry TignerTerry Tigner Junior Member

    Compatibility update: I just installed version 4 on my Surface Pro 3. So far everything seems to be working. Pen input panel is behaving normally. Chrome extension also seems to be working. In fact I used the extension to log into this forum and am inputting this comment with the input panel. It's just been the first few minutes but so far so good.

    Not sure whether the Version 4 team tested specifically for this issue or if the different digitizer (SP2 vs. SP3) might be a factor, but if this was tested it would be nice if the release comments called this out.

    Thanks

  • Terry TignerTerry Tigner Junior Member

    Update: Well, Version 4 finally started having conflicts with the input panel on my SP3. The behavior noted here started happening consistently. I had to use the "disable display scaling" solution. But at least that is working for now.

  • DBrownDBrown 1Password Alumni
    edited June 2014

    I've confirmed that the latest beta build of 1Password 4 for Windows does not conflict with the handwriting "keyboard" on my Surface Pro 2 test device.

    Terry, can you tell me more about the "disable display scaling" option you mention?

  • Terry TignerTerry Tigner Junior Member

    Yes, it was a work around posted by Marino Carlos on 1 May 2014:
    https://discussions.agilebits.com/discussion/18371/windows-8-1-on-surface-pro/p2

  • DBrownDBrown 1Password Alumni
    edited June 2014

    Of course! :\"> Thanks for the reminder, Terry.

    (comment 34, above)

This discussion has been closed.