Sync broken between three devices

I have two macs and an iPhone. All are running the current version of the software. All are using Dropbox. I can see that both macs are using the same dropbox file. All three say that they are synced, but all three have different versions of the more recent changes. They are most definitely NOT synced. This used to work seamlessly. Is there any way to fix this?

Comments

  • By the way, I have updated on all three devices today as a test. In dropbox, the package and contents update time is October 10th. I think you aren't syncing at all.

  • Yep, same issue here. In fact, if I make changes on one Mac the date it Dropbox shows 30th November on one Mac and 10th November on the other, despite the fatc that they should be the same and should be showing today's date. Confused? I sure am.

  • thightowerthightower T-Dog Agile's Mascot Community Moderator

    @alexmidd

    Please note the .agilekeychain date may not change but the files inside will change as you add more. My keychain data when viewed thru Finder is 12/7/13 while the wife's version is dated 12/1/13 but we each have the same content and the data size is the same etc.

    The folder aka the wrapper for the keychain files date is not always updated as you would expect.

    The keychain is basically a folder with many many smaller files inside.

  • Thanks thightower, but I did check the contents of the package as I said in my message. This is still failing for me, I'm going to attempt a complete reset of syncing on my devices (as described http://mygeekdaddy.net/2013/10/19/how-to-fix-1password-dropbox-syncing/) and will see if that fixes it. If it doesn't, I will post again.

  • thightowerthightower T-Dog Agile's Mascot Community Moderator

    @KevinGoldsmith

    Give it a try, is all I can say, I looked it over and it appears to be well written. (From a user standpoint I'm not staff). Following the forums as much as I so I have started to see some weird issues lately w/ syncing.

    Please do post back.

  • MeganMegan

    AgileBits Team Member

    Hi @KevinGoldsmith and @alexmidd,

    If you're still having difficulty syncing, please take a look at this post: 1Password Losing Sync Permissions after System Restart [MAS]. If you've purchased your copy of 1Password 4 from the Mac App Store, you may be encountering this bug.

    The good news is that our developers have managed to squash this bug, and the fix version is currently awaiting approval in the Mac App Store. It will be released just as soon as it is approved!

    Thanks so much for your patience here. If we can be of any further assistance, we're here for you :)

  • I've installed the newest version on both my macs and I'm still seeing this issue.

  • assuming the newest version is Version 4.1.2 (412009)

  • MeganMegan

    AgileBits Team Member

    Hi @KevinGoldsmith,

    You're right, the latest version for purchasers from the Mac App Store is 4.1.2. Have you tried re-setting sync since upgrading? I imagine that this might be the kickstart that is needed.

    • On your iOS devices, open 1Password 4 for iOS, tap Settings > Sync, and toggle Dropbox to OFF.

    • On the Mac, open 1Password 4 for Mac, and click the 1Password menu, then Preferences. Click Sync, and click Change syncing.

    • Check the box to remove the data from Dropbox and confirm that you want to disable sync.

    • Reboot the Mac and iOS devices.

    • On the Mac, go back to the Sync preferences, and enable Dropbox. This will regenerate a 1Password folder in Dropbox, and that will contain a new 1Password.agilekeychain file.

    • Allow Dropbox to fully sync.

    • Go back into the iOS app and re-enable Dropbox sync. It should work this time.

    If you are still seeing this problem after a reset, please let me know, as we'll want to investigate as soon as possible!

  • There was a bit of a hiccup (the first time both my phone and iPad tried to sync they failed because the application was being rate limited by dropbox. When I opened on my second computer, I had to disable and re-enable dropbox sync to get it to pick up the latest info. Everything is in sync now, I'll post again if they get out of sync again.

    thanks for your help!

  • sjksjk oversoul

    AgileBits Team Member

    You're welcome, @KevinGoldsmith, on behalf of everyone here who's helped you. :)

    It's great news you've got Dropbox syncing back on track with 1Password. Here's some information about the rate limiting you encountered during initial syncing on your iOS devices:

    The error message about "rate limiting" is coming directly from Dropbox. This can happen during the initial sync when a lot of data needs to be downloaded all at once. The error should be temporary and should automatically resolve itself after a few hours. There are a few things to keep in mind however:

    1. You must not disable Dropbox syncing and re-enable it. People often do this thinking that it will solve the issue but every time you disable and re-enable syncing 1Password is forced to re-download all the files and this will cause the rate limiting to happen again. It basically resets everything and we're forced to start over.

    2. If you have a lot of attachments stored in 1Password it could take a long time for this rate limiting error to go away. The reason is 1Password for iOS will download all your attachments automatically during syncing. This can be a great feature as it allows you to view all your attachments while offline, but it comes at the cost of making the initial sync much slower. As soon as you have more than a few megabytes of attachments stored in 1Password Dropbox will start rate limiting you as 1Password attempts to download everything at once. Eventually all the attachments will download but it will take time.

    Most often this issue happens because of attachments. The good news is 1Password will only download your attachments after all your items finish downloading so you can access all your data (except attachments) even though the Dropbox syncing hasn't fully completed.

    I've been through this multiple times. Patience is a virtue, just waiting it out. It's faster and smoother after this initial syncing settles down.

    Please do let us know if syncing starts misbehaving again or if you have any other issues. Thanks!

This discussion has been closed.