Cannot add custom password fields in version 4.1.1 build 411001

Hi,

I'm running the AppStore version of 1Password 4, version 4.1.1 build 411001. I am running OS X 10.9.1.

The release notes for 4.1.1 at https://app-updates.agilebits.com/product_history/OPM4 say:

  • Added the ability to create custom password fields for your items.

I am unable to add custom password fields. There is no option to do this.

I have created multiple new items, logins, bank accounts etc. I can fill in custom fields but they still show in plain text. There is no way to turn them into password fields or even to create new custom password fields for that matter.

Please give me the exact steps to add custom password fields. As far as I can tell, it looks like this feature wasn't implemented as described or am I just missing something. In fact, I don't see how to control the type of any custom field. I've tried left and right clicks, double clicks, middle clicks, menu items and none of them allow me to add custom password fields.

Please help ASAP! Thanks and Happy New Years!

Comments

  • JasperJasper

    Team Member
    edited December 2013

    Hey @SizzlerWA,

    There should be an option change the field from Text to Password:

    Are you seeing that option?

    Also, if you're using 1Password 4.1.1, that's the AgileBits website version not the Mac App Store version. :)

    Hope that helps!

  • I have this same issue - Version 4.1 (410009) - which is the MAS version.

    A bit of poking around - it looks like I get the option for custom fields on almost all categories, except identities, secure notes and (the killer) Logins. The option to confirm the field just doesn't appear, only the click target to let you move fields up and down. This affects both new items and existing ones. I couldn't find any reference to this in any later posts here - sorry if I missed them.

  • sjksjk oversoul

    Team Member

    Hi, Chris.

    In 4.1 and 4.1.1, I'm able to select a Password or Text type for custom fields (that aren't being actively edited) in Login and Identity items, e.g.:

    Custom fields (and therefore types) aren't supported at all in Secure Note items.

    Are you not seeing the custom type selection triangles in the right column of items in edit mode?

  • I'm not but having looked at what you've posted and some of the items I'm not seeing the triangles on, I think I've worked out what I've done. Almost all of my items are Login items anyway - and I think when I first started using 1password I got into a habit of just using the fields that automatically appear under the first website address for custom fields (changing the label) - these aren't showing the triangles but I guess that's because they are only really intended to hold URLs and not be customisable?

    If I move the data I want to change into a new field in a custom section, it works fine. Not sure how I ended up doing this - have used 1password on Mac (and my iOS devices) for a while (used v3 on the mac) so probably something I did a long time ago for no good reason!

  • sjksjk oversoul

    Team Member

    Hi, Chris.

    I'm glad you've figured this out. My bad for not mentioning that custom fields in the top section of Login (and Password) items don't support custom types. It looks it'll work in any sections with default label/new field pairs, e.g. Credit Card items have four of them:

    Plus some of the other default fields like you see there.

    It's not always apparent which and how item details are editable; we'll look improve that. :)

This discussion has been closed.