Failed to run import script

I have installed my copy of 1password 3.8.21 on my Macbook running Mavericks but when I import the exported pif file, I get Failed to run import script, very frustrating, I don't want to have to renter everything again, is there a fix?

Comments

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @agd,

    I'm so sorry that import is being difficult for you! Because Mavericks has involved some pretty significant changes to the back end of the operating system, we'll need to run a Terminal command to get import behaving properly.

    Open a Terminal window and paste the following:

    PATH=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin /Applications/1Password3821.app/Contents/MacOS/1Password

    (Where 1Password3821.app is the name of the 1Password 3.8.21 app.)

    Now import should work correctly. Please keep in mind that this command will only work for the current session. If you restart your computer, you will need to run the script again.

    Please let me know how this works for you!

  • The terminal script didn't work for me. This is what I got:
    TREFTS$ PATH=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin /Applications/1Password3821.app/Contents/MacOS/1Password
    -bash: /Applications/1Password3821.app/Contents/MacOS/1Password: No such file or directory

    I tried several things to get it to work. Restart computer then do script - no luck. run script with 1password open - no luck, run it with 1password closed - no luck.
    Any help would be great. I have 1Password 3.8.21 on my MBP running 10.9.1

  • JasperJasper

    Team Member
    edited January 2014

    Hi @trefts,

    Be sure that you change 1Password3821.app to the name of the 1Password app in your Applications folder.

    For example, if it's named 1Password, run this command:

    PATH=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin /Applications/1Password.app/Contents/MacOS/1Password

    Or if it's named 1Password 3, run this command:

    PATH=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin /Applications/1Password 3.app/Contents/MacOS/1Password

    Does making that change work for you?

  • JasperP,

    The above did not work for me either. I have a late 2012 Mini running 10.9.2 and 1 Password 3.8.21. Importing from a pif of a previous database; any thoughts?

  • JasperP,

    Also, previous database was from 1 Password 3.8.20 and a Late 2009 Mini running 10.6.8...

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @MAC123A,

    I'm sorry to hear you're having trouble with import here. I'd like to take a bit of a closer look at your system there to see if we can track down where things are going wonky. Using your browser please download a small standalone tool from us that will run a networked copy of our diagnostics tool.

    http://i.agilebits.com/kyle/tools/1Password_diagnostics.zip

    After the download is complete, use Finder to locate it. It should be in your downloads folder. If the file ends in .zip then your browser has not already unzipped it. Please double click it to expand it.

    The expanded file will have a "Unix Executable File" named 1Password_diagnostics. Double-clicking this will cause a Terminal window to open and download some files it needs. (Note: If you use OS X Lion or Mountain Lion, you may need to right click the file, choose Open, and click Open on the dialog).

    Once it completes it should open a window in your browser with the results. Please click File->Save As to save this file to your computer. Please save it as "Page Source" or "HTML" if there are options for this.

    If you do not get a report created, please copy and paste the output from the Terminal window so we can take a look at the errors that were created. This will help us figure out where the problem is in creating the diagnostics report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Megan: to you just now, thanks....

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @MAC123A‌,

    Thanks for sending the Report along! We'll follow up directly via email to ensure that things don't get muddled up between here and there. :)

  • Sounds good Megan, please let me know asap...

  • MeganMegan 1Password Alumni 1Password Alumni
    edited March 2014

    Hi @MAC123A,

    I see that one of our tech gurus has responded to your email - if you haven't already checked your email please do so, you're in good hands. :)

    .

  • Megan, no word yet...

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @MAC123A,

    This is strange, I can see that a reply was sent to the email address you used to send in the Diagnostic Report on Tuesday, March 18. Have you checked in your Junk folder just in case?

    If you are still not seeing a response, please send me a private message with an alternate email address so I can re-send the email.

  • Megan,

    Sorry, spam got it. I'll correspond with the tech via e-mail. Thanks for the assistance.

  • JasperJasper

    Team Member

    On behalf of Megan, you're welcome! And I'm glad you've received Chris' email now. :)

This discussion has been closed.