Always autologs out

I went into settings and set up a 60 minute delay before locking and set lock on exit to off. I also set a quick unlock code. I still have to enter my full password any time I return to the application, even after just opening up a web browser. Since I have a secure password and typing on a tablet is less than convenient, this is a pain in the neck flaw.

Comments

  • saadsaad

    Team Member

    Hey Jessi! I'm sorry for the confusion. The 'Autolock interval' setting is working as expected, and it allows you to set a time period where 1Password should lock itself it there's no activity within 1Password. This only applies if you have 1Password open because, by default, when you switch away from 1Password to another application, 1Password will lock itself.

    If you don't like this behaviour, there are two option in Settings -> Security that will help.

    • Quick Unlock Code: The Quick Unlock Code allows you to create a short numerical passcode (ideally 4 digits) to unlock your vault. With this feature enabled, every time you return back to 1Password from the background, you will only be required to enter your quick unlock code to access your data. So now when you switch between applications and return back to 1Password, you just need to enter your numeric passcode instead of your master password.

    • Lock on Exit: This will keep your vault unlocked when you switch between applications on your device. There’s no need to enter a quick unlock code or a master password when you return

    I hope that helps! Let me know if you have any other questions.

  • Thanks for those tips @saad‌

    I've noticed something slightly odd:

    When switching back and forth between open apps, the quick unlock settings work as intended. However, if I switch to a different app, then go back to 1P by pressing the 1P icon in my "app tray" of installed apps, or the icon I have pinned to my phone's "desktop", it always asks for the master password regardless of my chosen settings.

    Hopefully this makes sense - I don't know the proper terminology for different parts of the Android UI sorry!

    (I'm running the latest version of the beta)

  • saadsaad

    Team Member

    You're welcome!

    I wasn't able to reproduce this bug on my Nexus devices, but I am going to keep a closer eye on this behaviour. Thank you for letting us know you're experiencing this issue too. I passed on these details to the development team.

This discussion has been closed.