B47 - Sync only works one-way. New entries created in iOS are not synced

superchinksuperchink Junior Member

Entries added on the Mac do sync correctly to iOS (using Dropbox, currently), but additions on iOS are not synced at all.

Is this current expected behavior?

Comments

  • Also seeing this with B47 and dropbox sync - I've just added a new Wifi router on iOS but it fails to sync back to dropbox or into 1password for Windows (via dropbox)

  • hch3hch3
    edited March 2014

    Also items created in b47 do not sync with the official iOS AppStore version of 1pass either.

    Also if I create a note in the AppStore 1password it will sync to b47, however when I open that note and try to change it every time I hit save it reverts back to its original state.

    iPhone 5, iOS 7.0.6

  • Saving changes in Secure Notes on B47/iOS 7.1 does not work for me neither.

  • I deleted the previous beta and then installed b47, and sync worked fine. So, there is bug with the upgrade that needs resolving.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Can you open the main 1Password app, go to Settings > Sync, and tap on Sync Now. Wait until it is done syncing and then check the Mac app, does it show the data now?

  • @MikeT Made a change on the Mac App, Version 4.3.BETA-7, and this would only replicate, via Dropbox on iOS b47, if I disabled sync and then re-enabled. All subsequent changes were then fine, no matter which App I used.

    The problem appears to be when you upgrade to a new beta version on iOS - the Dropbox sync function stops working.

  • Tried tapping the Sync now and doesn't appear to do anything - the Last Sync remains empty.

    I've had to email a newly added entry to myself, delete the beta and open the email link in the AppStore version of 1password to get it added and syncs across Dropbox.

  • superchinksuperchink Junior Member

    Can you open the main 1Password app, go to Settings > Sync, and tap on Sync Now. Wait until it is done syncing and then check the Mac app, does it show the data now?

    @MikeT‌ strangest thing… I could have sworn I did that a few times when I first installed this update. I did it again, after you suggested it, and those entries from a few days ago that were not syncing back are now showing up in my vault on my Mac. Maybe I never kept the app open long enough to actually finish the sync? Either way, it was a bit frustrating.

    Thanks for helping resolve this for me. Is this because of an upgrade from a prior beta? I'm assuming this won't happen for new users of this version onward. Is that accurate?

  • cortigcortig Senior Member

    In my case, the Sync Now doesn't do anything (again: I had the same issue a few builds ago and now it's back).

  • Same issue here as cortig. In order to get new entries from the Mac over to iOS, I've had to disable then re-enable sync.

  • I can confirm after deleting b47 and reinstalling and setting up Dropbox again it is syncing okay.
    Certainly appears an issue when upgrading from previous beta

  • MrRooniMrRooni

    Team Member

    Thanks for the confirmation everyone, it sounds like this was just a kink in the upgrade from beta <47 to beta 47.

  • rosenkriegerrosenkrieger Junior Member

    I am still unable to sync. I already tried removing the Dropbox Sync and adding it again. Nothing is synced to the Dropbox. Also tapping Sync now does nothing for me. This happens with B48 for me on my iPhone 5 and my iPad Mini Retina.

  • MrRooniMrRooni

    Team Member

    @rosenkrieger‌ I responded to you on another thread.

This discussion has been closed.