Where oh where did my datafile go?

I run 1PW 3.8 on my mac and the android version, synced with dropbox. I realized today that I was missing some logins on my phone, so tried to update the sync and kept getting network errors. Strange, so I had a look at my computer -- everything works fine with the Firefox plugin and I have no issues saving logins -- and when I open the 1PW app it prompts me for my datafile. Uh oh.

I thoguht the file was on my dropbox, but there's nothing there. The phone reported that the file was found, and THEN gave a network error.

If I cd into the dropbox folder and run 'ls -a', it does indeed show that I have a ws.agile.1Password.settings file. So I cp that file over to my local machine and the 1Password app still can't read it.

Cool, so I thougt maybe I just need to update 1Password. So I come to this site and see that there's a version 4 now, so I get my credit card out and figure I'll try the demo first to make sure it can find my old data. Uh oh, v.4 can't read that file from my dropbox either.

So, if Firefox is still saving my passwords locally, where are they going and how can I find my datafile so I can update to v4?

I seem to remember having an issue like this before and I had to pull a backup out of dropbox somehow, but I cannot remember how I did that/where I found the info.



  • e987yuise987yuis
    edited April 2014


    Ran the diagnostic script, it said the datafile was in a deleted(!) dropbox folder. I restored the folder and the 1Password App can find it, but now tells me that encryption keys file does not exist in my dropbox. I found them in yet another old dleted folder. Everything seems to be sorted.

    Don't put your 1password stuff in a folder called 'old'.

    I am still trying to get my android app to sync correctly

  • MeganMegan

    Team Member

    Hi @e987yuis‌

    I'm glad to hear you were able to get things sorted out. In order to get your Android app working though, we might need to take a peek at that Diagnostic Report. Please generate a fresh one so that any changes you have made are properly reflected in the Report.


    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hi, I sent the report in a few days ago. Can someone please confirm that it was received? cheers

  • MeganMegan

    Team Member

    Hi @e987yuis‌

    Thanks for letting me know that you've sent the Report in! Unfortunately, I'm unable to find an email in our system from the email address attached to your forum account. Did you perhaps use a different email address? If so, please send me a private message with the address you used so that I can track it down. :)

  • I'm also having the same problem. keep getting the message "the encryption keys file does not exist in my dropbox. Never had a problem with the macs but I now have an android phone. I don't have much knowledge on computers. Can you help?

  • MeganMegan

    Team Member

    Hi @fiP9nIk3J‌

    In order to get this sorted out, I'll need to know a little bit more about your 1Password ecosystem:

    • What are the version numbers of 1Password and your operating system for all computers and devices running 1Password?
    • Are you seeing this error message on your Mac or your Android device?

    The more detail you can provide, the more quickly we'll be able to get you sorted out! :)

This discussion has been closed.