1Password 3 installation/licensing on an older Mac [resolved in email]

sjksjk oversoul

Team Member
This discussion was created from comments split from: 1Password 4 backwards compatible with 3.x?.

Comments

  • The above comments seem to assume you've already installed 1password 3 and want to use it along with 1password 4. I need the opposite; I am set up with 1password 4 and want to use 3 on my old mac. When I try to get started with 3, I get the following message:

    "1Password 3 is a very significant update and we need to upgrade your database for all its new features to work. It will remain compatible to 1Password 2." The single option is "Upgrade". How do I install 3 and get it to work with 4, and also, will I need a separate license in addition to my Mac family license I bought for 4?

  • MeganMegan 1Password Alumni

    Hi Tony,

    I apologize for the trouble here. It sounds like you may have an old datafile from 1Password 2 on your old Mac? The upgrade message you are seeing is referring to an upgrade of your database, not an upgrade from v3 to v4. I'll need a bit more information here to ensure I'm giving you the right instructions to get all set up.

    What are you using to sync your data between 1Password 4 for Mac and 1Password 3 for Mac?

    You will need a separate license for 1Password 3, but I was able to locate your license information in our back office records using the email address attached to your forum account and I've added a 1Password 3 license to your account. You should see an email with the details shortly.

    Once I know how you plan to keep 1Password 3 and 1Password 4 in sync (your best options are Dropbox or Folder Sync over a local network), I'd be happy to give you directions on how to get set up. :)

  • I started with 1Password 4, using dropbox for sync. I now have it running on two computers and an iPad. The 1Password 3 problem came up when I tried starting 3 on my downlevel Mac (10.6) It looks like 3 doesn't recognize the vault created by 4.

  • sjksjk oversoul

    Team Member

    Hi Tony,

    How far along have you gotten in the 1Password 3 setup on your older Mac? Do you have Dropbox configured there and has your 1Password data been synced there for 1Password 3 to use?

  • Dropbox is configured and the 1password vault shows up where expected, so yes, it is sync'd. When I started p3, it immediately went to the window I described in my first note, so I have not had a chance to point it to dropbox. I did a spotlight search just in case and no files with "agile" appear that I didn't put there in the past day. I just tried P3 again with the same results. I did not hit "update" because I'm afraid it will damage the vault I've already spent time filling up. Am I being misled by the welcome screen?

  • MeganMegan 1Password Alumni

    Hi Tony,

    It still sounds to me like there might be an old datafile on your Mac that 1Password 3 for Mac is noticing and asking you to upgrade. Let's take a closer look at your system by running a Diagnostic Report. Using your browser please download a small standalone tool from us that will run a networked copy of our diagnostics tool.

    http://i.agilebits.com/kyle/tools/1Password_diagnostics.zip

    After the download is complete, use Finder to locate it. It should be in your downloads folder. If the file ends in .zip then your browser has not already unzipped it. Please double click it to expand it.

    The expanded file will have a "Unix Executable File" named 1Password_diagnostics. Double-clicking this will cause a Terminal window to open and download some files it needs. (Note: If you use OS X Lion or Mountain Lion, you may need to right click the file, choose Open, and click Open on the dialog).

    Once it completes it should open a window in your browser with the results. Please click File->Save As to save this file to your computer. Please save it as "Page Source" or "HTML" if there are options for this.

    If you do not get a report created, please copy and paste the output from the Terminal window so we can take a look at the errors that were created. This will help us figure out where the problem is in creating the diagnostics report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    A short note here once you've sent the Report in will help us to keep an eye out for it. :)

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Diagnostics have been mailed as a Dropbox link. (The "cpanero" in the file name is my wife; it is her computer.) Thanks, I'm looking forward to what you find out.

  • MeganMegan 1Password Alumni

    Hi Tony,

    We've received your Diagnostic Report - thanks for sending it in! Someone from the support team will get back to you as soon as possible with some details.

    .

  • The problem was solved by the support team. In my initial post, I reported that 1P3 was expecting to upgrade me from 1P2 and I was more than a bit nervous about clicking "upgrade." I also noted that the 1P4 license might not work. I received at no cost a license for 1P3 and a diagnostic to run. It turned out that the "upgrade from 1P2" message was wrong and that the correct procedure was to ignore it. I won't go into the subsequent user-error that led to more hand holding other than to say a couple persistent people worked me through it. If anyone asks, yes I recommend 1Password.

  • MeganMegan 1Password Alumni

    Hi Tony,

    Thanks so much for posting here to let us know that your issue has been resolved! Your kind words here are much appreciated. We're here for you (both in forums and via email) if you run into any further snags. :)

    (Since this issue is resolved, I'll close this thread.)

This discussion has been closed.