Cannot fill due to code signature verification [Solution: Configure Sophos]

mrsmacmrsmac
edited May 2014 in Mac

iMac running 10.8.5

1Password 4
Version 4.4.1.BETA-3 (441003)
Agile Beta

Google Chrome
Version 35.0.1916.114

Firefox
29.0.1

This afternoon I went to log in to a site and got the following message:

Cannot Fill item in web browser
Web browser is connected but its code signature could not be verified. Filling and other features are disable until this configuration issue is resolved.

I followed the VIEW TROUBLESHOOT GUIDE link and read:

There is a known issue with Chrome where validation will not pass if it is in the middle of an update. If you are seeing this message in Chrome, the first thing you should try is to simply quit and restart Chrome as this often resolves the issue.

Sure enough, Chrome was updating. So I switched over to Firefox and got the same error message. I waited for Chrome to finish updating, and then I restarted iMac. I launched Chrome and got the same error. Launched Firefox and again received the same error. I've not tried Safari as I never use it.

The other thing I noticed is that using the key in the browser window, I am able to at least see my log ins and do the copy/paste routine. If I use the 1Password key up in the finder menu bar, I see the same menu that shows up when I'm only in the finder.

The only change to my iMac is that today I deleted Adobe Reader and it’s associated files from my library.

I cannot log in to any site with 1Password, and it's annoying, and the key thing is frustrating.

Any suggestions?

«1

Comments

  • Same issue started for me this morning...

    OS X 10.9.3, 1Password 4.4 (440002), Chrome 35.0.1916.114

  • I have same problem - tried it on Chrome and Firefox - same issue. 1Password mini does not happen.
    OSX 10.9.3, 1Password 4.4 (440002) Chrome 34.0.1847.137

  • I have the same issue - OSX 10.9.3, Chrome Version 35.0.1916.114 and 1Password Version 4.4 (440001). Hope it gets fixed soon!!!!

  • Me too, OSX 10.9.2, Chrome 35.0.1916.114, 1Password Version 4.4
    Just started this morning, nothing significant that I know of changed on computer since yesterday, just an itunes update.

  • The same issues started affecting all browsers—Chrome, Firefox and Safari. As per the Agilebits suggestion, disabling 'Verify browser code signature' in 1Password/Preferences/Advanced works partially. You will be able to fill login and password by selecting site in the 1Password browser extension but not using the shortcut.

  • Same problem all browsers. Came here for answer. Guess you are working it. Can still copy from mini and paste into password line but I get the same Chromium message in Safari and Chrome.

  • It came good for me by itself after sometime. Hope it is fixed for all of you too

  • Still broken for me.

  • JasperJasper

    Team Member
    edited May 2014

    Hi everyone,

    This issue is commonly caused by running Sophos antivirus software. If you use Sophos on your Mac, please double-check to make sure it's properly configured to allow local connections so 1Password filling will work:

    http://learn.agilebits.com/1Password4/Mac/en/KB/sophos.html

    Also restart 1Password mini in addition to restarting your browser(s).

    If that doesn't help, please email us a Diagnostics Report from your Mac, along with a link to this discussion, to: [email protected]

  • Thanks JasperP. That has fixed it for me.

  • Thanks Jason - but can you, or anyone, tell me how/where to configure Sophos? I looked in preferences, but didn't see it there.

  • The link JasperP posted includes some screenshots: http://learn.agilebits.com/1Password4/Mac/en/KB/sophos.html

    Open Sophos and from the 'Sophos Antivirus' menu select Preferences. Then add '127.0.0.1' under the 'Web Protection' tab.

  • Thanks, laazy - that worked. Sorry I didn't read all the fine print in the first place.

  • Looks like that worked for me as well, thanks.

  • MeganMegan

    Team Member

    Hi @laazyj‌ and @focasle‌ and @juliancoates,

    On behalf of @JasperP, thanks so much for letting us know that those steps got you up and running again! Please let us know if you have any further questions or concerns!

  • SpacemanSpaceman Member

    I'm having this issue with Firefox 24.5.0 ESR but not Safari 6.1.4. I am not running Sophos but I am running Symantec Endpoint Protection.

  • I had a free basic version of Sophos AV that didn't have the above mentioned settings for me to change, so I didn't think it would be the source of the problem, I thought it would maybe be the version with firewall built in. But, I uninstalled, downloaded the latest sophos installer then ran an update followed by a reboot and the problem is solved. Thank you.

  • MeganMegan

    Team Member

    Hi @Spaceman,

    I'm sorry to hear that you're having trouble here. Our article: 1Password fails to fill data should help you out here. Essentially, 1Password needs to be able to communicate with the Mini (and the browser extension) via 127.0.0.1/localhost. If this is blocked by your protection software, 1Password will not be able to fill.

    I hope this helps you get all sorted out, but we're here if you have any further questions!

    (and @PurpleBoots, happy that you found a solution!) :)

  • SpacemanSpaceman Member

    Megan,

    Thanks for the response. While I can not say the my protection software (Symantec Endpoint Protection) is not the cause, I would be surprised. If it were, I would expect the problem to exist for both browsers (Safari and Firefox) but it only affects Firefox. Also, I am running the same protection software at home (although it appears to be an older version) and I have no issues with either browser there.

    I am going to try and update the home version of the Symantec Endpoint Protection to the same version to check it out. I will let you know.

  • http://discussions.agilebits.com/discussion/comment/126480/#Comment_126480

    This worked for me as well—many thanks. I am curious as to why this issue suddenly cropped up. Was it an update to 1P? Or an update to Sophos? Or something in the ether? :D

  • @mrsmac‌, see this thread (and in particular post #14 by JasperP) in the beta forum.

    Stephen

  • This problem just cropped up this morning, and updating the Sophos "Allowed Websites" setting worked for me. Nonetheless strange that I haven't need to make the change until today, even though I've been using both 1P and Sophos for many many months. Recent updates included Mac (10.9.3).

  • sjksjk oversoul

    Team Member
    edited May 2014

    Hi Daniel,

    I'm glad that fixing the Sophos configuration resolved your issue, too. Quite a few cases have been reported of it being unexpectedly reset, e.g. after an OS update/upgrade, so it's not too unusual for it to happen. :)

  • Hi.

    After updating Safari to 7.0.4 the 1Password extension won´t fill in my logins or credit card details. I get the same message as what's shown here: http://learn2.agilebits.com/1Password4/Mac/en/KB/browser_validation_failed.html
    Is there an update for 1Password to fix this, or do I have to disable the "Verify browser code signature"?

  • bigreddogbigreddog Junior Member

    ditto... all apps (safari/1pwd), os is up to date.

  • sjksjk oversoul

    Team Member

    Hi @lebomp,

    I've merged your post with a related discussion. Please refer to @JasperP's suggestion in post #10 for help with resolving this issue.

    Hi @bigreddog,

    Have you seen @JasperP's suggestion in post #10?

  • bigreddogbigreddog Junior Member

    Updating the IP loopback as described in the Sophos fix did indeed work for me. Confusing as neither Sophos or 1Pwd apps were updated. But... a solution is a solution, and the help is appreciated. Thx!

  • sjksjk oversoul

    Team Member

    The OS X 10.9.3 update is one thing that might be causing this issue, @bigreddog. I'm glad the possible solution was an actual solution for you, too. :)

  • Starting today (5-27-2014) anytime I try to fill in a password on any website, I get a popup error box that says "Cannot Fill Item in Web Browser". 1Password has never done this prior to today. I'm getting this on both Safari and Chrome on my Mac (Mavericks). I'm not getting it in Windows 7. I'm attaching the error box popup.

  • sjksjk oversoul

    Team Member

    Hi @andyvg99,

    Like some other posts here, yours has also been merged into this related discussion. :)

    Please see if @JasperP's suggestion in post #10 helps resolve your issue, too. Thanks!

This discussion has been closed.