1Password Public Beta 4.6.BETA-1 + iPhone 5s iOS 8 Touch ID not switching on



  • Thanks for the suggestion, not working here.

  • Didn't work for me, either. I will try rebooting after turning it off then turning it back on and see if that changes things. Will report back if it works.

  • MrRooniMrRooni

    Team Member

    Thanks gents.

  • Jeff ShinerJeff Shiner AgileBits Admin

    Team Member

    While I was not able to reproduce the issue on my 5S, I was able to reproduce the same problem on my iPad Air. Turning on the Quick Unlock would simply turn it back off. I have tried resetting the passcode and restarting the device, but that was not successful.

    It originally had iOS 8 beta 1 installed and that had been updated to beta 2 through the device Software Update.

    I tried performing a full restore to iOS 8 beta 2 and am now able to properly set the Quick Unlock code. I have filed a Radar for this issue.

  • Same issue in iOS8 Beta 3. Just FYI.

  • MrRooniMrRooni

    Team Member

    Thanks for the report @volcom45‌. We have yet to hear back on our radar from Apple, so so far the only workaround is a full device restore.

  • I took the full restore plunge and can confirm that TouchID is fixed and is now working. Very nice!

  • jsmechamjsmecham
    edited July 2014

    I can also confirm that a full restore (including a settings restore from backup) enables the Touch ID functionality.

  • MrRooniMrRooni

    Team Member

    Good stuff guys, thanks!

  • I had the same problem, being unable to turn on TouchID in 1Password settings. I tried turning TouchID off and back on again in iPhone settings, but this didn't help. However, I finally got it working by doing the following (running iOS 8 Beta 3 and 1Password 4.6.BETA-2):

    1. Open the app switcher and quit 1Password.
    2. Go to iPhone settings and turn off TouchID (both for unlocking the phone and for iTunes and App Store).
    3. Disable my passcode alltogheter.
    4. Re-enable my passcode.
    5. Turn TouchID back on.
    6. Turn TouchID on in 1Password.

    I'm not sure that exactly all these steps are necessary, but this is what I did and it worked. Yey! :)

  • Thanks tawe. It worked.

  • myckmackmyckmack
    edited July 2014

    With the step 1, 3, 4 and 6, I have Quick Unlock running in my iPad.

    Running iOS 8 Beta 3 and 1Password 4.6.BETA-2 in both iPhone 5S and iPad Air.

  • Looks like we have a fix, thanks Tawe!

  • Thx so much, Tawe! I can confirm this worked! So awesome getting to use this feature now!!

  • Can also confirm that Tawe's suggestion works! Thank you!!!

  • MikeTMikeT Agile Samurai

    Team Member

    Awesome, guys.

    @tawe‌, huge thanks for tracking that down. I'll ask Shiner to update the radar on this.

  • BabyGotMacBabyGotMac Junior Member

    Thank you Tawe.

  • MikeTMikeT Agile Samurai

    Team Member

    A lot of folks have confirmed tawe's suggestion works. So hopefully, Apple'll figure this out and have it fixed in the later betas.

This discussion has been closed.