Touch ID wouldn't start working until I disabled, reenabled

David_ChartierDavid_Chartier 1Password Alumni

TL;DR: Touch ID stopped prompting me in 1P b2 on iOS b3, even after a device restart. After updating to b3, it still wouldn't prompt me, but now it works. I'm reporting this since I wasn't sure if its broken-ness carrying over from b2 to b3 is an issue.

Touch ID is enabled and set to request my fingerprint after exiting 1P or leaving 1P idle for 2 minutes. In b2, Touch ID stopped working entirely, I had to reenter my MP every time I exited the app, even if I opened it one second later.

Then I received the b3 prompt and upgraded. Touch ID still misbehaved, my MP was requested immediately, wouldn't see a Touch ID prompt. Once I disabled and reenabled Touch ID with the same settings, it is now working.

Comments

  • MrRooniMrRooni

    Team Member

    Thanks David! I'll be sure this one gets into our internal bug tracking system. If you have any other feedback don't hesitate to let us know. It's great people like you that help us to make 1Password the awesome product it is. Moreover, you in particular are a great source of our success and we're lucky to have you.

  • camsoftcamsoft Junior Member

    I had the same issue

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @camsoft,

    Did you reset TouchID on your iPhone? It is often the cause and the only workaround is to reset TouchID completely and re-add your fingerprints. It's an issue in iOS 8 at the moment.

  • HunterHillegasHunterHillegas Junior Member
    edited July 2014

    Hi,

    I'm new to the test... On my 5s, when I go to enable TouchID in 1P, the slider automatically goes back to Off. It won't ever stick to the 'on' position despite rebooting the device, etc...

    Is that the same issue as the above? And if so, how do I 'reset' TouchID? Just turn it off and back on or is there a formal process for that?

    Cheers.

    Edit: I'm now seeing this other thread. Apologies if I've asked an already answered question... reading now... https://discussions.agilebits.com/discussion/27016/touch-id-wouldn-t-start-working-until-i-disabled-reenabled#latest

    Yup. The directions in that thread worked. Cool!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @HunterHillegas‌,

    I assume you mean this thread: https://discussions.agilebits.com/discussion/26409/the-big-thread-on-touchid-issues-with-1password-4-6-betas since you linked to the same thread as this one. I'm glad it works for you.

    Here's the instruction in case anybody else needs it:

    1. Open the app switcher and quit 1Password.
    2. Go to iPhone settings and turn off TouchID (both for unlocking the phone and for iTunes and App Store).
    3. Disable my passcode altogether.
    4. Re-enable my passcode.
    5. Turn TouchID back on.
    6. Turn TouchID on in 1Password.
  • camsoftcamsoft Junior Member

    I did not reset TouchID I just had to toggle the Touch ID switch in 1Password Settings off and on again.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @camsoft,

    Yea, if you see it happen again, it is usually the issue with the fingerprint data on the devices, so resetting TouchID is the only workaround at the moment.

    Thanks for updating us.

This discussion has been closed.