Can't migrate data from v3 to v4 on iOS

edited July 2014 in iOS
  1. I own version 3 and have been using it successfully for a year or so on my iPhone (iOS 7.1.1) I just bought version 4 and am not able to migrate data from version three to version four. When I open v3 or v4, I am given the option to migrate data from 3 to 4 but when I choose this option, nothing happens. I have tried restarting my iPhone, but this does not help.

  2. Also, b/c I already owned v3 I figured I'd be given a discount on purchasing v4 but this did not occur.


  • MeganMegan

    Team Member

    Hi @beckn,

    Thanks for taking the time to write in! I'm sorry to hear that you're having trouble getting your data migrated into 1Password 4. Could you please confirm for me which version of 1Password 3 you currently have installed? You can find this in More > Settings > About.

  • Thanks Megan. It is version 3.7

  • MeganMegan

    Team Member

    Hi @beckn,

    Thanks so much for confirming that for me! It looks like you are missing the last update to 1Password 3 for iOS, which is when the import scripts were polished up, so that's where your trouble is coming in. Since 1Password 3 will no longer automatically update, we'll backup your existing datafile and reinstall 1Password 3 for iOS, which will give you version 3.7.2, and make the import process a lot smoother!

    • On the old 1Password 3 for iOS, do a backup of the data to your computer. This will create a .1ptbackup file, which can only be restored to 1Password 3 for iOS.

    • Go to App Store > Purchased (on iPhone go to App Store > Updates > Purchased) and search for 1Password there. Make sure it appears in your purchase history. If it does not, stop here and reply to me.

    • If 1Password 3 does show in your purchase history, close the App Store, then delete 1Password 3 for iOS from the device. Now Reopen the App Store and go back to the purchase history.
    • The old icon should be visible with a cloud icon next to it. Tap the cloud icon to re-download.
    • Open 1Password 3 for iOS, and set up the same passcode and Master Password as you had before.
    • If you get prompted to import, tap that you will do it later, but do not tap that you never want to see the prompt again.
    • Restore the .1ptbackup file according to the restore instructions in the previous link.
    • Close both 1Password 3 for iOS and 1Password 4 for iOS from the multitasking view.
    • Launch 1Password 3 for iOS, and tap that you want to begin the import when you are prompted.

    This should get you all sorted out, but please let me know if you have any questions about the process - we're here to help!

  • thanks Megan. this worked.

  • JasperJasper

    Team Member
    edited July 2014

    I'm glad to hear that worked! On behalf of Megan, you're welcome. Please let us know if you have any other questions! :)

This discussion has been closed.