Dropbox sync no longer working to iPhone

I have 74 items on my OSX app, syncing via Dropbox. This used to sync fine to my iPhone but seems to have stopped working at some point. Now my phone shows 68 items and new things I add on the desktop don't sync over. I disabled and reenabled Dropbox sync on both desktop and on my iPhone and still no luck. I even tried to delete the 1password data from my Dropbox and start over and still doesnt work. What can I do?


  • MeganMegan

    Team Member

    Hi John,

    I'm sorry to hear that you're having trouble keeping things synced up lately. I've got a few basic things that we want to check regarding Dropbox first, before we get into the serious troubleshooting:

    • Please ensure that Dropbox is installed and running on your computer
    • Check that you are logged in with the same account on all computers and devices
    • Confirm that Dropbox sync is selected in 1Password > Preferences > Sync on your Mac
    • Confirm that Dropbox is selected in Settings > Sync on your iOS device

    If all of those items check out, let's run a test and see where things are getting tripped up:

    • Create a test entry on your Mac ("Test, Mac") and add some data
    • Create a test entry on each of your iOS devices ("Test, iPhone/iPad") and add some data
    • Does "Test for Mac" show up on either of your iOS devices?
    • Does "Test for iPhone" and/or "Test for iPad" show up on your Mac?
    • Log in to the Dropbox website and click on the 1Password.html file inside your 1Password.agilekeychain folder
    • Enter your Master Password
    • Do either or any of your test entries show up in your database here?

    Please let me know the results of this little experiment - once we have a better idea of where things are going sideways, we should be able to get this straightened out simply for you :)

  • Megan I tried the instructions above but it asks for a vault password for dropbox. I have no idea what that is?

  • MeganMegan

    Team Member

    Hi @dmurray,

    I'd like to know a bit more about your situation so that I can advise you a little bit better here. Could you provide me with a bit more detail?

    If you're being asked for a password it sounds to me like sync isn't quite set up yet. To set up sync on your iOS device, you will first be asked to log into the Dropbox website (if you do not have the Dropbox app installed on your device.) After that is done, you can select the file in Dropbox that you wish to use. The instructions for setting up Dropbox sync on your iOS device are here if you'd like a bit more detail.

    If you're already logged in to Dropbox, 1Password might be asking you for the password of the vault that you are attempting to sync to. I'd love to see a screenshot of the message you're seeing so I can get a better idea of where you're at. There are instructions on how to take a screenshot here: http://take-a-screenshot.org/. You can save the image to a service like Dropbox and include a link in your reply.

  • Hi Megan, I have an ipad2 and forgot the master password so I uninstalled the app and reinstalled it. It asked if I have an account and I said yes it asked where I wanted to link to and I said to dropbox. When it opened dropbox it asked if 1password could have access to dropbox, i said yes, it then asks me to choose the 1 password agielbits vault- prepopulated , so I say yes, and it asks for the password.

  • My 1Password is all of a sudden not syncing.. Very frustrating as I went through this in May and finally resolved it.. I have iMac version 3.822 and
    iOS version I can't find anywhere.. Trying to find some important passwords and now it's a mess.. not showing up on iMac..

  • Hi.
    For a couple of days, I experience the same problem described by John.
    On 1P iOS, dropbox sync perfs ask me to choose a vault between 1Password.agilekeychain and 1Password - copie.agilekeychain.
    When I select the first one, 1P announces a Vault Mismatch. When asking information, 1P compares my current vaults:

    My Vault (on iOS): 412 items, last updated 12.05.2014
    Dropbox Vault: 252 items, last updated 29.7.2014

    How to force 1P on iOS to use the dropbox Vault without merging the two vaults?

    Syncing between my 3 mac is ok.

    Thanks for your help

  • MeganMegan

    Team Member

    Hi @dmurray‌

    Thanks for explaining things to me!

    Unfortunately, if you have forgotten your Master Password, you will not be able to set up 1Password as an existing user - the Master Password for the vault currently stored in Dropbox will be required before you can access the data.

    For your privacy and security, your master password is known only by you. We cannot reset it for you and you cannot change it without entering the old one. There is also no "back door" to access your data without the master password. If there were, that would be a security hole that criminals could exploit to steal your information.

    If you think you know what the password is, but it is not being accepted, please see the tips in this guide:


    Please try each tip, for we have found them to be the most common causes of this problem. If you cannot remember the password, you will need to restore from a backup or start over. Both of these steps are documented in the guide.

    If you've really never stored anything in your 1Password data file then starting over is really easy -- but you'll want to make sure and provide a good "password hint" so you don't forget the master password again.

  • MeganMegan

    Team Member

    Hi @Lotus777‌

    In order to get this sorted out, I'll need to know a little bit more about your 1Password ecosystem:

    • What are the version numbers of 1Password and your operating system for all computers and devices currently running 1Password?
    • To find out which version of 1Password for iOS you have, let me know which icon you see on your home screen from the following image: A, B, C or D?

    The more detail you can provide, the more quickly we'll be able to get you sorted out! :)

  • MeganMegan

    Team Member

    Hi @phof‌

    I'm sorry to hear that you've been having trouble keeping things synced up lately!

    How to force 1P on iOS to use the dropbox Vault without merging the two vaults?

    If you are certain that the vault in Dropbox contains all your complete database, we can delete the existing data on your iPhone and set things up fresh. To start fresh, please try:

    • Tap & hold on the 1Password icon on the home screen. It will begin to move slightly, and an x will appear on the corner.
    • Tap the x on 1Password, and confirm the deletion.
    • Press the Home button to stop the other apps on your screen from moving.
    • Delete the Data on iCloud (if it exists): http://learn.agilebits.com/1Password4/iOS/Tutorials/ios-reset-data.html
    • Restart your iOS device
    • Now, visit the App Store on your device, and tap the Purchased section (on iPhone, Purchased is nested within Updates).
    • Find 1Password in your purchase history and tap the cloud icon to re-download, free of charge.

    • When you open 1Password 4 for the first time, select "I've Used 1Password Before" and sync via Dropbox

    This should get things all sorted out for you, but if you have any further questions, we're here to help!

  • Hi all, I am having same issue. I have 3 Macs, an iPhone 5, and an iPad 3. Dropbox is syncing just fine with the 3 Macs, but it stopped syncing with the iOS devices. The iPhone and iPad are on iOS 7.1.2, Dropbox 3.2.2, and 1Password4 4.5.3. I've tried doing the suggestions on the various posts about this with no luck. I know it's gotta be something I am doing or not doing. If someone could reply, I would greatly appreciate it!

     Kind regards,
  • MeganMegan

    Team Member

    Hi @scottafry,

    I'm sorry to hear you're having trouble keeping things synced up lately. Let's try resetting sync:

    • On your iOS devices, open 1Password 4 for iOS, tap Settings > Sync > Sync Service and choose 'Disable Sync’.

    • On the Macs, open 1Password 4 for Mac, and click the 1Password menu, then Preferences. Click Sync, and click Change syncing.

    • Check the box to remove the data from Dropbox and confirm that you want to disable sync.

    • Restart the Macs and iOS devices.

    • Check your Dropbox folder and delete any other 1Password folders or files that the remove data checkbox did not take care of.

    • On the first Mac, go back to the Sync preferences, and click Dropbox. Click Choose vault, then navigate to your Dropbox folder and select Open. This will regenerate a 1Password folder in Dropbox, and that will contain a new 1Password.agilekeychain file.

    • Allow Dropbox to fully sync.

    • On the other Macs, go back to the Sync preferences, and click Dropbox. Click Choose vault, then navigate to your Dropbox folder and select the 1Password.agilekeychain file we just created. 1Password will prompt you for the Master Password of the vault.

    • Go back into the iOS app and re-enable Dropbox sync. That should get everything on the same page for sure.

    Please let me know if things are still acting up and we'll investigate further.

  • scottafryscottafry
    edited August 2014

    Hi Megan,

    Step 1 is where I run into issues. I tap Setting > Sync, but there is no Sync Service choice. I see "Start Syncing". If I tap that, it takes me to "Choose a sync method". If I tap on "Sync with Dropbox" that shows me my Dropbox account. If I tap on the 'info' icon, an i in a circle, I can choose "Stop Using Account". Is this close or am I still way off track here?



  • scottafryscottafry
    edited August 2014

    Wow… what did I do to get that funky post?

    Nevermind. all the odd fonts and colors now appear to be gone. I'm having an odd day to be sure.

  • MeganMegan

    Team Member

    Hi @scottafry‌

    I've edited the funky out of your post. This forum allows Markdown formatting, so the indents might have made things interesting there. (I'm only familiar with the most basic Markdown formatting details.)

    In any case, you're really close to getting things set up here. I do apologize for the confusion here. In order to finish setting up sync and select the keychain in Dropbox, you'll need to tap on your account name, not on the info button. (You're not the only one who's gotten tripped up here and we're looking at making this more clear in the future!)

    From the following screen, you should be able to select your existing keychain in Dropbox, then you'll be off to the races! Please let me know if this gets things straightened out for you. :)

  • Nope. Still not working, and now when I try to click on my name for the keychain, I am receiving a "Vault Mismatch" error, and it recommends to not merge the vaults.

  • MeganMegan

    Team Member

    Hi @scottafry,

    We're getting closer! You're seeing the vault mismatch error because the data in your iOS device is not quite identical to the data in the Dropbox keychain, and we want to be sure that you don't merge two different vaults together accidentally. Please tap on the 'More info' option to see just how different the vaults are. Generally, 1Password is pretty good at merging, so we can select 'Merge vaults' and 1Password will combine the data on your iOS device with the data in Dropbox.

    If you are seeing a serious discrepancy between the data in your iOS device and the data in Dropbox, please let me know where you most recent data lives: are there new entries on your iOS devices that need to be preserved? If the data in Dropbox is the most recent copy of your data, we can erase the data on your iOS device and use just the data in Dropbox. :)

  • Hi Megan,

     I would  have to say the data in dropbox is the one that I want to keep. How do I erase the data off the iOS devices?
     Kind regards,
  • MeganMegan

    Team Member

    Hi Scott ( @scottafry‌ ),

    To remove the data on your iOS device, go to Settings > Advanced > 'Erase Data and Settings'. Quit 1Password. When you open it again, it will ask if you're a new user or if you've used 1Password before. Select I've used 1Password before, sync using Dropbox, and select your keychain.

  • Hi Megan,

    That did it!!!! Thank you soooo very much!

    Kind regards,


  • MeganMegan

    Team Member

    Hi Scott,

    I'm soooo glad to hear we finally got things sorted out! I hope everything works smoothly for you from now on, but if you hit any other snags, we're here to help. :)

    Happy Friday!

This discussion has been closed.