Lockout is behaving differently recently - it locks very quickly

For the last week or so, this has been driving me batty. I typically have a relatively long lockout time set in the app, and for the last year I've been able to open up 1Password on my phone throughout the day without having to provide the master password. Recently, I have been exiting the app (not force-quitting, but just using other apps on the phone like normal) and it seems like 5 minutes later if I re-open 1Password, it requires the master password. Has something changed? I'd like to keep that setting on the less-secure side of things, as I have my iPhone set to always require a passcode (or TouchID) to unlock the phone itself.

Comments

  • Remember that iOS will shut down applications in the background if it needs memory for an active application. When that happens, you will indeed need to reenter your master password, regardless of the timing set it 1Password. Perhaps your use has changed and you are now doing something that ends up closing 1Password sooner that you've been used to?

  • Hi @paulbrown,

    Have you allowed 1Password to store the Master Password in the iOS keychain? 1Password 4.5 for iOS features a newly designed PIN code which will provide users with a more consistent experience.

    In earlier versions of 1Password 4 for iOS, the lock settings were dependent on 1Password remaining open in the background. When the iOS would quit the app to reclaim memory resources, users would be prompted for their Master Password upon re-opening, regardless what their auto-lock settings were.

    By providing the option to store your Master Password in the iOS keychain, we are able to respect users' PIN code settings, even if the iOS closes 1Password in the background.

    To ensure that users are aware of this new behavior, the PIN code is not automatically enabled for users who have migrated from an earlier version and will need to be manually enabled.

    Please note that we recommend only using this feature only if you have enabled a device passcode on iOS.

    As a security feature, if you mistype the PIN code once it will clear the iOS keychain and require the Master Password to be typed to access your database.

    If you do not wish to store your Master Password in the iOS keychain, you can disable 'use the iOS keychain' in Settings > Advanced. This will allow you to access 1Password using the PIN code until the iOS closes the app in the background, after which point your Master Password will again be required.

  • Thanks for the info. The memory thing seems to have been the problem. And I will have to look into this keychain thing, that seems really helpful,

  • JasperJasper

    Team Member

    On behalf of Megan, you're welcome. Please let us know if you have any other questions! :)

This discussion has been closed.