Imported a bunch of logins but location field doesn't update

revlisoftrevlisoft
edited October 2014 in 1Password 4 for Windows

I imported a bunch of logins but I noticed that the location property doesn't get updated (nor do the icons) even though the URL is populated. It seems like I have to click on every entry before 1Password will take the URL and put it into the location property and update the icon?

I came from keepass where I migrated over 300+ entries.

Comments

  • DBrownDBrown 1Password Alumni

    To be sure I understand correctly:

    1. You import KeePass data (presumably in delimited-text format).

    2. The Logins are created, and the username and password fields contain the correct values, but the URL fields are empty.

    3. You click on a Login, and its URL field contains the correct value.

    Is that correct?

    If so:

    • How and where do you see the empty URL fields in step 2?

    • How and where do you click on a Login to see its populated URL field in step 3?

    Thanks!

  • The URL contains the correct value but the "location" is empty. Once I click on the entry and close the entry only then does the "location" entry gets populated and the icons are downloaded.

    In step 2 the location fields are empty. Once I click on the entry I see the URL a is already populated correctly.

    I close the entry and now the location shows up and so does the icon.

  • DBrownDBrown 1Password Alumni

    The URL is the location.

    Also, I'm not sure what an "entry" is.

    Can you post screen shots that show what it is you're describing?

  • revlisoftrevlisoft
    edited November 2014

    In this image you see there's a bunch of missing "Location" in the Location column. Let's focus on bleacherreport.com for now.

    After opening on that entry there is a proper URL in there which was imported from a CSV file

    Without modifying anything except to close the entry the Location shows up and so does the icon.

    Hope that helps explain it. I have over 300+ entries like this.

  • DBrownDBrown 1Password Alumni
    edited November 2014

    Thanks, @revlisoft‌—the images really help!

    While the Location column is partially populated, please try selecting a different category and then selecting Logins again.

    Does that force a "refresh" of the list?

  • That didn't help either. I even tried to update icons and only the ones with location filled in already update.

  • Hi @revlisoft‌,

    Can you please try selecting 'File > Download Icons…' and check if it improves things?

    Cheers

  • DBrownDBrown 1Password Alumni
    edited November 2014

    That'll be interesting to know, @revlisoft‌, and may help us figure out what's going on.

    Also, if that doesn't solve the problem with the URLs missing from the list area, please try File > Repair 1Password Vault.

    Thanks for your help!

  • Tried the file > download but it didn't do much. It sees that I have 401 logins but doesn't download anything. I tried the repair and retried the download icons but still no luck.

  • DBrownDBrown 1Password Alumni
    edited November 2014

    Can you confirm that you exported the KeePass data in delimited-text format and imported that into 1Password 4 for Windows?

    (We may need to ask for a "sanitized" version of the import file, in order to try and reproduce the problem.)

  • Yes. I used the other popular tool created by one of your users using the keepass 2.x format to generate the file. No errors during export and none was shown by 1password during the import.

  • DBrownDBrown 1Password Alumni

    I've asked the creator of that tool whether he might have any ideas about what's going wrong.

    I hope he'll join the conversation, here.

  • MrCMrC Community Moderator
    edited November 2014

    Hi folks. I'm sorry I never noticed this thread.

    I found that CSV importing on 1Password for Windows was problematic. I've seen problems like this when importing many records via CSV. This is one reason I removed the CSV export format from the converters, All of the converters now use the 1PIF format. If @revlisoft‌ is still working on this, the new converter should provide satisfactory results. I'm happy to help work through any issues.

    https://discussions.agilebits.com/discussion/30286/mrcs-convert-to-1password-utility/p1

  • I believe the format exported was 1pif IIRC since that's the default. I downloaded the latest version from 10/30. The only option I specified in the tool was the source format which is keepass 2.x

  • MrCMrC Community Moderator
    edited November 2014

    Hi @Revlisoft. It sounds like you were using convert_to_1p4 1.00 rather than the older keepass2_to_1p4.

    After I wrote my reply very late last night, I had this nagging feeling that I'd also see a similar problem with 1P4 / Windows and 1PIF not showing some values immediately after large imports. And I believe these resolved themselves after entirely quitting 1PW and restarting it. I can't swear to this, but I'm fairly positive it occurred. There's nothing wrong with the converted 1PIF - it contains all the data; its just that after the initial large import, 1P4 lags behind somehow (I have no idea how the data is stored / used internally), or does not correctly update some fields. It could also be that a large delete followed by an import helps trigger the issue. I really have no insight on this end.

  • Thanks. Like I said the value is definitely there and must be since when I try to click on an entry to view it and close it only does 1P recognize it.

  • MrCMrC Community Moderator

    Looks like there are a couple of posts where users have noticed field updates, and I've seen this too with 1P4 for Windows. Perhaps this issue will gain some more traction.

This discussion has been closed.