FirefoxDeveloperEdition is currently unsupported [Known issue, working on a fix]

dangoordangoor Junior Member
edited November 2014 in Mac

It appears that the new FirefoxDeveloperEdition released today is the replacement for Firefox Aurora. I'm using 1Password 4 on Mavericks (can't upgrade yet because the corp. IT folks aren't ready for that) and it complains about the code signature on the new browser. It appears that FirefoxDeveloperEdition is signed by Mozilla, but 1Password may be doing a check beyond that...

Any possibility of adding support for this browser to 1Password 4?

«13

Comments

  • I've been experiencing the same problem. Disabling the check for a code signature doesn't appear to help the problem either.

  • Hi @dangoor‌ and @sammarks15‌ Can you check one preference setting for me please and see if it makes any difference if you disable it (assuming it is currently enabled). The preference setting in question is 1Password : Preferences... : Advanced tab and the option Verify browser code signature.

    That might help allow you to run the extension (fingers crossed).

  • @littlebobbytables‌ - Disabling that preference doesn't appear to have an effect (even after restarting 1Password Mini).

  • BenBen AWS Team

    Team Member

    Darn. Thanks for trying. We aren't quite sure how support for this development build will go, or what if any versions of 1Password will support it, but our developers are actively looking at the issue now. Unfortunately I don't have anything else to suggest for the immediate future, other than to switch to the stable version of Firefox. I realize that may not be practical.

  • @bwoodruff‌ - No problem. I'll just copy/paste passwords for now. I can't imagine it being that bad with Firefox saving passwords. Thanks for the quick response!

  • edited November 2014

    Same issue here. I get the alert even with the "Verify browser code signature" option disabled. I've rebooted and the problem persists.

    Firefox Developer Edition 35.0a2
    Mac OS X 10.10

  • Confirming that disabling verification of browser signatures, and restarting Firefox and 1password, has no effect. Please support Firefox Developer Edition :)

  • BenBen AWS Team

    Team Member

    Thanks for the continued feedback. :)

  • Mine started working for some reason. I reinstalled the Firefox add-on, unchecked "check code signature", and restarted FirefoxDeveloperEdition. Now my CMD-\ shortcut is working and I can fill in forms.

  • Still getting the same issue after removing the addon and reinstalling. I also was able to reproduce the issue on a clean Firefox profile. There is an open bug on the Mozilla side as well for this. https://bugzilla.mozilla.org/show_bug.cgi?id=1096429

  • I originally copied my Firefox profile into my FirefoxDev profile, so maybe that's why mine is working. I have no idea.

  • BenBen AWS Team

    Team Member

    @csharpminor‌ Are you using the beta 1P extension?

  • edited November 2014

    No:
    1Password 4 Version 4.4.3 (443000)

    Extension Version 4.2.4

  • I'm suffering this, too: extension 4.5.1b1; 1Password Version 5.0.2 (502006) Mac App Store

  • Interestingly: working firefox has a v1 code signature. FirefoxDeveloperEdition has a v2 code signature.

    :; spctl --assess -v /Applications/Firefox.app/
    /Applications/Firefox.app/: rejected
    source=obsolete resource envelope
    :; spctl --assess -v /Applications/FirefoxDeveloperEdition.app/
    /Applications/FirefoxDeveloperEdition.app/: accepted
    source=Developer ID
    
  • aredridelaredridel
    edited November 2014

    @csharpminor: Which version of MacOS? 10.9.4, 10.9.5 or 10.10.x?

  • janrothenjanrothen
    edited November 2014

    I'm having the same problem (Extension 4.2.4, 1Password Version 5.0.2 (502007) Agile Web Store. OS X Yosemite 10.10 (14A389)

    Please support FirefoxDeveloperEdition.

  • Also have this problem. Unchecking "check code signature" does not help.
    Extension 4.2.4, 1Password 5 Version 5.0.2 (502007) Agile Web Store, OS X 10.10 (14A389).
    Please support FirefoxDeveloperEdition.

  • I get the same with Firefox Developer Edition (which was released yesterday). It worked with Aurora, but the Aurora channel has now become DeveloperEdition, so there's no switching back. Do you have an ETA on a fix?

  • BenBen AWS Team

    Team Member

    Hi folks,

    Our developers are aware of this issue and are working on a fix.

    ref: OPX-673

  • I would also like to report that I have encountered this issue as well.

    OS X 10.10 (14A389), 1Password 5 Version 5.0.2 (502007) Agile Web Store, Extension 4.2.4.

  • MeganMegan 1Password Alumni

    Hi @bholley and @Panopticon‌,

    @bholley‌ - I've merged your report with an existing thread so that we can keep this discussion all in one place.

    We apologize for the inconvenience here. As Ben has mentioned above, our developers are aware of this issue, and we're currently looking for a solution.

  • ghuerta09ghuerta09
    edited November 2014

    Bugzilla has been updated with investigations from the Mozilla side.

  • Why wouldn't disabling the check have any effect. That's what I find confusing.

  • Same here. Yosemite 10.10.1 (14B23) - Firefox DeveloperEdition 35.0a2 - 1password 4.2.5b1.
    Thanks for your support.
    Please update the icon on firefox with the lock and more dark.
    :)

  • LosInvalidosLosInvalidos Junior Member

    +1

  • Hello!

    I've been trying to get 1password to work with the new Developer Edition of Firefox (which doesn't seem to be codesigned). Every time I try to autocomplete something using 1Password I get a warning saying that I have to disable code signature checking in the app preferences. I did that and I keep getting the same warning. Any ideas?

  • Hello!

    I just updated to Firefox Aurora 35.0a2 (Release 2014-12-11), which is a brand new version of the Aurora channel, now called Firefox Developer Edition.

    In short: I've gotten the latest 1Password from the Mac App Store, and the latest browser extension for Firefox, but I'm getting the browser code validation error.

    The error is annoying even if the code signature validation in 1Password is disabled.

    Something's going wrong.

    How can I solve this? The best would be re-enabling code signature validation, because browsers without it are untrusted.

    Thank you in advance.

    Tyrexionibus

  • RazorAZRazorAZ Junior Member

    I second this.
    This new browser won't work with 1password even disabling code signature checking. I still get the same error about it's code signature could not be verified.

«13
This discussion has been closed.