Tried to sync iPad, lost most of my logins now

I was having problems getting my new iPad to sync with my dropbox 1password vault. (The operation couldn't be completed (dropbox.com error 404). I think I messed it up by creating a new vault on the iPad, then trying to sync it with Dropbox. I could never get the iPad to sync. Then, I synced my iPhone, which had never had a problem. Then my iPhone said it could no longer sync. But each time I tried, some files would say they were being updated on my Windows Laptop in my Dropbox folder.

Now, when I launched 1Password in Windows, I only have 4 logins saved! I have lost 88 of them! I hope they can be recovered from the data on my PC's or dropbox folders. Any chance? And how do I get my iOS clients to work with my vaults, or do I just create one just for them and sync them on iCloud?

Comments

  • Actually, I don't see the username and password for any of the 4 logins that showed after the sync issues. I think I lost them all. I hope I can get them back somehow. If so, please let me know. It's not the end of the world if I have to start over, but I just need to know so I can get started.
    And if the iOS and Windows vaults aren't particularly compatible across multiple iOS devices, let me know that up front so I can consider just creating them on their own and sync them separately on iCloud instead of dropbox.

  • Hi @Chris Hagwood

    The agilekeychain is compatible with all of our platforms, indeed Dropbox (with the agilkeychain) is what we recommend if you need any cross platform syncing.

    The first thing to do is disable syncing on all your devices.

    The next thing to do is restore a backup made on your Windows machine. The default preferences are to backup every day and to keep 50 backups so you should be safe there. So in 1Password go to Backup > Restore 1Password Vault from Backup... You'll be taken to the backup folder and you can select which backup you would like to restore. It should be quite clear from the item count in the filename which you're looking for.

    What I suspect is happening with your iOS devices is when syncing the primary vault it is always called 1password.agilekeychain. I'm guessing something got overwritten and wiped out the old sync data. If you had other machines pointing to that location they picked up changes and did what they were meant to - sync.

    So with 1Password for Windows back on track (hopefully), what I'd like to know is what version of 1Password are you running on each iOS device and are there any items in either one you need to keep? If there aren't we'll wipe the iOS devices, set up a brand new agilekeychain based on your Windows copy of 1Password and then point the iOS devices to that. That should get you back on track.

This discussion has been closed.