Safari Extension Disappears From Toolbar After Closing Browser, 1Password 5, Yosemite, Safari 8

I have added the safari extension a number of times. I have downloaded the 1password installer and double clicked. The extension installs and is enabled in Safari Preferences. The icon is visible on the Safari toolbar. When I close Safari and then re-open, the icon is no longer in the toolbar and there is no extension shown in Safari Preferences. This is happening with Evernote as well.
Early 2011 Macbook Pro 15"
New install of Yosemite that has been updated to 10.10.1
Safari 8.0 (10600.1.25.1)
1Password 5.0.2 (502007)
1Password is visible on the menu bar.
Can you help me get the extension to remain on the Safari Toolbar?
Thanks

Comments

  • JasperJasper

    Team Member
    edited December 2014

    Hi @jholl,

    Could you please give this a try:

    • Launch Keychain Access. (Enter the first few letters of its name into a Spotlight search and select it in the results.)

    • Make sure "All Items" is selected in the Category sidebar on the left.

    • Use the search box in the toolbar of the Keychain Access window to search for an item named Safari Extensions List.

      • If found, right click on it and delete.
    • Quit Keychain Access and Safari, then relaunch Safari.

    • Try installing the 1Password extension again: https://agilebits.com/store

    Please let me know if that helps. :)

  • Hi,
    Thanks for quick response.
    I deleted the extension list and downloaded the 1password extension installer from the menubar dropdown. Installed and saw icon in safari toolbar. Quit and restarted Safari again - gone

  • JasperJasper

    Team Member
    edited December 2014

    Hi @jholl,

    Sorry to hear that didn't fix it. I have a few other things for you to check.

    First, check the permissions for Safari's Extensions folder:

    • Open a Finder Window.
    • Use the Go > Go to Folder... menu item.
    • In the text field that appears, copy/paste this in (including the ~) : ~/Library/Safari
    • Click Go.
    • Finder will navigate to that folder (it's normally hidden, that's why we use that trick to get to it).
    • Find and select the Extensions folder inside of ~/Library/Safari.
    • Use the File > Get Info menu item.
    • A panel will show up with a bunch of information about the folder. The last item it should have is called Sharing & Permissions. Make sure it's expanded.
    • Make sure that the row that corresponds to your user has Read & Write permissions. If it doesn't, you may need to unlock the panel via the lock icon in the lower right to make the changes.

      • Here is an example:

    • If you made a change to the permissions, restart Safari and see if that fixed it.

    If that wasn't it, check to make sure that Safari has permission to save its extension list in your keychain:

    • Launch Keychain Access. (Enter the first few letters of its name into a Spotlight search and select it in the results.)
    • Make sure "All Items" is selected in the Category sidebar on the left.
    • Use the search box in the toolbar of the Keychain Access window to search for an item named Safari Extensions List.
    • Double click that item. A window will be displayed with additional information. Select the Access Control tab.
    • In the Access Control tab, check if Safari shows up in the list of applications that are always allowed access.

      • If it isn't there, add it via the "+" button (you'll have to locate the Safari app in a Finder dialog that appears).
      • If it is there, remove it using the "-" button, then re-add it using the "+" button (you'll have to locate the Safari app in a Finder dialog that appears).
      • Example:

    • Restart Safari, re-install the extension, and see if that fixed it.

  • Confirmed that I have read/write privileges. Admin has read/write too.
    No luck
    Cannot try the 2nd suggestion because I already deleted Safari Extension List per earlier instructions.

  • RadRad 1Password Alumni

    Hi @jholl‌,

    Sorry to hear that Safari keeps on misbehaving. By the looks of it it seems that you extension installations are not persistent across Safari launches. Let's try the reboot voodoo it might be helpful in your situation.

    1. Reboot your Mac.
    2. Re-install the 1Password Browser Extension
    3. Launch Safari and enable it if necessary.
    4. Quit and relaunch Safari. The extension should still be there.

    If this doesn't work can you please send us a Diagnostics Report from your Mac, along with a link to this topic and your forum username, to [email protected].  A brief comment here mentioning that you've sent the report would also be helpful.

    Once we see the report we'll be able to better assist you.

    Thanks in advance!

    Rad

  • Hi there,

    this was also happening to me. However it wasn't just the 1password extension. It was any extension. Just came across a recently added support suggestion on their site. If you've been having problems since upgrading to Yosemite and all extensions disappear across restarts of Safari, then you need to follow the final recommendation on page 2 of this support document (blocked in green). The section from Linc Davis about removing the Safari Extension List from the keychain is what resolve the issue for myself and others.

  • sjksjk oversoul

    Team Member

    Hi @Elsior,

    Glad to hear you've fixed your problem with disappearing Safari extensions! @JasperP also suggested removing Safari Extensions List from Keychain Access, although @jholl reports still having trouble retaining the 1Password extension (at least) after doing that and some other things. Hopefully what @Rad suggested works for him. :)

This discussion has been closed.