"Looking for Helper" message every time Chrome is started

gwatgwat
edited December 2014 in 1Password 4 for Windows

Hi all.

Since upgrading to 1Password 4 I get this annoying helper page every time I start chrome. It's sooo irritating and it has to stop.

Help or a psychiatrist needed please!!!!!!

(...and any advice such as, "Stop clearing your browser data" is not acceptable)

Comments

  • @gwat Help > Restart 1Password Helper

  • @svondutch‌ Thanks but it's a bit cryptic - What where you trying to say?

  • I suspect that he means click that menu option and see if the problem goes away.

  • @RichardPayne‌ Thanks Richard. I did look at the help options but there's none so blind as they say.

    Anyway that didn't resolve it. After clearing the browsing data up it comes again next time I load Chrome.

  • Did anyone say to clear the browsing data?

  • @RichardPayne‌ No but in my original posting I indicated (although arguably not very well) a suspicion that this issue happens when I clear the browsing data (which I do automatically on shutdown)

  • Try not including the "Cookies and other site and plug-in data" option in your automatic clear and see if the problem goes away.

  • gwatgwat
    edited December 2014

    Yes this does cure the issue but not clearing cookies is not an option.

    To have an extension do something because you have taken security or privacy protection steps is not really acceptable. A user should have a choice whether to enable a help option or not. Having one forced on you is irritating particularly when it wipes out your chosen start page.

    Comments welcome and a fix would be even more welcome.

  • It's not cookies that are the problem but, I suspect, the "and plugin data" bit. The helper page is displayed when the plugin is first installed to validate the installation. I am guessing that it stores a little bit of data to indicate to itself that the sanity check has already been run.

    By clearing app data every time you close the browser, you're going to force it to load that page each time you startup. It's just unfortunate that Chrome has lumped cookies in with plugin data. They're really not the same thing.

  • The only solution I can think of is to use Incognito. It doesn't seem to clear plugin data down (primarily because it doesn't normally load plugins) but it does not permanently store cookies, history or any other browsing data.

  • Ah well I temporarily stopped the clearing of cookies and it didn't do it. Clearing them brought the issue back but from what you say that may explain it.

    Either way it's a pain and if nothing can be done about it I would suggest they get rid of the Welcome page as it adds very little to the experience really or failing that have it open in a new tab maybe, although that would still be a pain but that's better than wiping out a chosen start page.

  • gwatgwat
    edited December 2014

    Richard, I appreciate very much your interest in this and your comments but using Incognito to work around the problem is unacceptable and impractical. They need to consider these points and see what they can come up with.

    Just because it may not be an issue to many users I still think it should be resolved and thanks to your help I think we have narrowed it down for them.

    I would like to hear more comment from @agilebits‌ on their thinking of it.

  • Either way it's a pain and if nothing can be done about it I would suggest they get rid of the Welcome page as it adds very little to the experience really or failing that have it open in a new tab maybe,

    It depends on how well you know the system. The welcome page is useful and it instructs you on how to use 1Password. Granted, in your case, it does nothing useful but then clearing down browsing data.
    I can only assume that you're using an extension to manage this since Chrome doesn't, to the best of my knowledge, allow clearing of browsing data when closing.

    using Incognito to work around the problem is unacceptable and impractical.

    It seems to me that Incognito mode is exactly what you're trying to accomplish by clearing down every time the browser is closed.

  • gwatgwat
    edited December 2014

    It's clear this is not an issue to you and, as I said earlier, it's most likely not an issue for many but for me and possibly others it is an issue.

    I do not, by the way, clear the browsing data every time I close Chrome. It only occurs automatically on shutdown i.e. once or twice a day, as part of an automatic housekeeping routine.

    Thanks again for your interest. I look forward to, although I doubt I will get, a response from @agilebits or maybe @svondutch‌.

    I'm not suggesting it's a bug, just a poorly conceived feature.

    As the extension has it's own settings why not add the ability to enable or disable the helper page. That way everyone is happy and it comes under the user's control - The way life should be !!

  • It's clear this is not an issue to you and, as I said earlier, it's most likely not an issue for many but for me and possibly others it is an issue.

    You seem to be under the mistaken impression that I'm dismissing your concerns because they don't affect me. I'm not. I'm just not sure what the should do instead, short of removing a useful feature for novice users.

    i.e. once or twice a day, as part of an automatic housekeeping routine.

    I.e. not a standard part of Chrome and therefore not something you should expect developer to take account of; therefore it's not a ill conceived feature.

    As the extension has it's own settings why not add the ability to enable or disable the helper page. That way everyone is happy and it comes under the user's control - The way life should be !!

    That would be a fine idea, except for the fact that you're clearing the settings a couple of times a day. To make it work they'd have to make the default to not show it unless there is a setting saying to. The problem there is that, for novice users, if it gets switched off then it's off permanently.

  • Hi @gwat,

    Sorry for the frustration here.
    Can you please tell us a bit more about your setup?

    The welcome screen for the 1Password Helper comes up when the Chrome extension tries to connect with it and can't do so immediately.
    It will try to launch the 1Password Helper and upon connecting successfully, display the page.

    It might be that the 1Password Helper (Agile1pAgent.exe) is not launching automatically, or that something is interfering with the communication.

    This guide article might give you some useful information:
    https://guides.agilebits.com/1password-windows-kb/4/en/topic/about-the-helper

  • Hi @AlexHoffmann‌

    Your helpful reply prompted me to do a bit more digging...

    I have discovered the issue relates to the removal of the Chrome's Local Storage file:

    'chrome-extension_aomjjhallfgjeglblehebfpbcfeobpgk_0.localstorage'

    This seems to hold a welcomeScreenShown flag or token?.

    If this file is removed (as it is during my cleanup and close down procedures) the issue arises when the system next restarts and Chrome is loaded for the first time when the 'Looking for the 1Password helper' quickly followed by the 'Welcome to the 1Password Extension!' - This is done on the start-up page.

    The welcome screen for the 1Password Helper comes up when the Chrome extension tries to connect with it and can't do so immediately.

    I'm not sure this is the behavior I'm seeing. The Agile1pAgent is running fine but it seems the missing welcomeScreenShown flag prompts the problem?

  • AlexHoffmannAlexHoffmann

    Team Member
    edited December 2014

    @gwat‌ Nice detective work :)
    I'm not sure I can give you a plain yes/no to your findings, but they seem at least plausible.

    I'd like one of our developers to take a look at this.

    Still, might I ask which anti-malware software you are using?
    We've encountered cases where the browser extension would make an initial attempt at connecting to the 1Password Helper only to be blocked by the anti-malware program. After checking the connection request, however, it would allow the browser extension to connect (resulting in the display of the welcome screens) and everything would work fine after that.

  • gwatgwat
    edited December 2014

    Hi @AlexHoffmann‌ - shucks, now you've got me warming to you guys :p ...

    I use McAfee Total Protection but I doubt this is the cause as:

    Delete the local storage file, shutdown, restart and load Chrome it shows the Welcome page.

    Do not delete the local storage file, shutdown, restart and load Chrome and all is well, i.e. no Welcome page.

    In both cases AV's, firewalls etc etc are identical.

    Actually you don't have to shutdown, restart etc - quicker to:

    1. Open Chrome with local storage file intact - All's well
    2. Close Chrome and delete the local storage file
    3. Open Chrome - Welcome screen :o !!!
  • DBrownDBrown 1Password Alumni

    So, the answer seems to be not to delete the local storage file.

    Am I missing anything?

  • Do you seriously think I would bother reporting this if it didn't matter!

    That's the most stupidest reply I can think of.

  • Obviously only the developers can provide the code change fix you're looking for, but in the mean time maybe you can approach this from another angle.

    How does this clear down routine you have work and how configurable is it? Can you modify it to ignore the local storage file for the 1Password extension while still clearing down the others and all your cookies?

  • gwatgwat
    edited December 2014

    Hi @RichardPayne‌

    Yes I was thinking the same. My problem is that to use this laptop at my employment I must abide by their security rules.

    In the meantime I am in contact with the security software vendors to ask whether clearing everything in the Local Storage folder is necessary particularly with regard to extension state files. I note that clearing the Chrome browsing data clears all but those files. The vendors have taken this question on board and are considering the issue.

    But, I still think there is an issue with 1Password 4 as relying on the welcomeScreenShown flag to verify the contactability of the helper can't be right.

    Furthermore, the extension has access to settings that are not affected by the deletion issue. Surely the flag could (and maybe should) be set/unset there.

    I am looking forward to @AlexHoffmann‌ 's discussion with the Agilebits developers.

    PS. @DBrown‌. I apologise for the strength of my previous response (para 2) to your comment but I felt you had not read the thread completely, a fact that happens too often in these forums.

  • DBrownDBrown 1Password Alumni

    I'm sorry you think my reply was the "most stupidest." I certainly didn't even imply that it "didn't matter."

    As I hope you'll understand, I was merely pointing out the way to avoid seeing the message while using 1Password today.

This discussion has been closed.