No permission for other user, 1password5 for mac

Hi,
My imac configuration:
Mac OS 10.10.1 (Yosemite)
1Password for Mac version 5.0.2
2 users are on this imac, each with its own "vault" located in dropbox locations

While I am able to start 1password5 and open my own vault (everything works fine...), the other user, after logging in on the other imac account, is unable to open 1password5 app. A message appears:
"You don't have permission to open 1password 5.app.
Ask your computer- or network administrator for assistance"

My licensies allows me to use 1 password on mac and windows. I have a 1Password Mac + Windows Bundle license for 2 machines. This imac is 1 machine with 2 user accounts on it.

Previously I created 2 copies of the 1password5.app under each users programs folder. Each copy pairing with a different vault. That worked finde but each time, when the app was started a message would appear stating that only 1 copy of the app was allowed to be located there. After this message was closed, the app could be started and opened the correct vault for that user.
Now in order to solve this "small problem", I now am trying to use only 1 copy of the app for both users, but now I am left with the problem stated above.

How can I solve this issue?

Kind regards and thanks for your help,
Ben van Wetten

Comments

  • Well..... solved it myself in the following manner....

    The application 1password5.app needs to be installed (or better explained: copied from the original installation file...) to the applications folder of each specified user.
    Normally (without further intervention from the mac user) the application will be installed in the folder: Mac -> Applications
    From that position only 1 application can be run, owned by 1 user and opening 1 vault. Although once opened by the respective user, vault switching can be done. But only the user having installed this application can do this.
    Even creating a copy and renaming the copy at this location does not help in getting 2 different modes of operation for 2 different users.
    Even more so, changing the permissions on the application to allow 2 different users to read and write to this application does not solve it.

    Well then... what does...?

    The application should be installed (or better said: copied from the original installation file) to the applications folder of each individual user. The location will therefore be: Mac -> Users -> [username] -> Applications
    When inititaed form this position by the respective user, the program will not indicate that it cannot be opened, nor will it indicate a problem with duplicate 1password-mini files.

    Hopefully other users will benefit from my explanation. And, of course, it may be useful for the developers to change the preferential installation location for the app so in future this does not re-occur.

    Thanks, Ben van Wetten

  • Well, there must be something wrong then with your installation. I have 1password (Mac App Store) installed on one single Mac in the Mac->Applications folder. There are 3 users on this single Mac. Each user can log into his own account and without any problem start 1password and open it's own vault. There is absolutely no need to install 1password for each user separately in their own Applications folder located in their home folder.

  • @Burnardo‌ Vlad0907 is correct, more than one user should be able to run 1Password from the Applications folder, you shouldn't need to have individual copies.

    In your case it might be worth moving 1Password back to the Applications folder and then running Verify Disk Permissions in Disk Utility. That application can be found in your /Applications/Utilities/ folder. If it finds any errors you'll want to run Repair Disk Permissions.

    See if that helps.

This discussion has been closed.