Dropbox Sync: "Automatic sync disabled"

jwarthmanjwarthman Junior Member
edited January 2011 in iOS
Switching from WiFi sync to Dropbox Sync
Summary: 1Password Pro on iPhone4 won't sync with Dropbox. It tells me "Automatic sync disabled".

I'm using 1Password Version 3.5.4 BETA-5 (build 30831) on the iMac and 1Password Pro Version 3.5.5 on the iPhone4.

I've been using WiFi Sync for quite a long time to keep my iMac and iPhone4 in sync.

Tonight I decided to try syncing via Dropbox. On the iMac I've had 1Password configured to keep its agilekeychain on Dropbox for quite some time.

So I followed the instructions for setting up "Automatic Syncing Using Dropbox" that are here: http://help.agile.ws/1Password3/cloud_syncing_with_dropbox.html

Although I think I've followed the instructions properly, when I go to the Sync screen in the iPhone4 and tap "Dropbox", immediately under the Account field is the statement "Automatic sync disabled".

If I tap "Sync Now", It takes me to the Unlock screen, where I have "Master Password on iPhone" set to "Remember". On that screen, when I tap "Sync Now" it quickly returns to the previous "Dropbox Sync" screen.

Any thoughts about what I'm doing wrong here? What things, exactly, can cause automatic syncing to be disabled on the iPhone?

Thanks,

Jim

**Flash Update: I force-quit DropBox Pro on the iPhone4, then re-launched it and - with no other changes - when I display the Dropbox Sync window it began to sync - automatically!

It took a bit of time, but successfully completed its sync!

For the development team: I suspect this might be related to having changed both my 1Password Pro Master Password and my Dropbox password just now. Perhaps "something" in the App wasn't updated, but that was fixed when I force-quit and restarted 1Password Pro.

Comments

  • khadkhad Social Choreographer

    Team Member
    It sounds like everything is working well for you, Jim. That is good news if I am reading it correctly. :-)

    For others with Dropbox sync problems, you can always reset Dropbox syncing from within 1Password on your iOS device (Settings > Sync > Dropbox > Account > Reset). This does not affect your data but merely resets syncing.

    Please let me know if you need further assistance.
  • jwarthmanjwarthman Junior Member
    khad wrote:

    It sounds like everything is working well for you, Jim. That is good news if I am reading it correctly. :-)


    Yes, all is well - thank you!

    The developers might be interested to hear of this anomaly, however. I suspect there is a software defect that could be fixed on a future release.

    Enjoy!

    Jim
  • khadkhad Social Choreographer

    Team Member
    Thanks for the update, Jim.

    If you change your Dropbox or 1Password for Mac or Windows master password — the former rather than the latter in your case as changing the 1Password for iOS master password will not affect Dropbox syncing — you will need to update the password(s) stored in 1Password for iOS for Dropbox syncing. The easiest way to do this is to simply reset Dropbox syncing as described above.

    Cheers!
  • Thought you'd like to hear that I had the same experience as the previous poster. I changed the Master Password, which I do on a monthly basis. That has always been "less than simple" because of needing to reset the sync, but I had written down the procedure and followed it. However this time I got the "automatic sync has been disabled" message. Tried the sync reset again, no change. Finally did what was suggested above and "forced quit" the app on my iPhone. When it came back up, all was well and the sync was underway.

    I THINK this is new behaviour in the most recent version. Previously I just had to do the sync reset.

    (Even when it's working, you should think about making it easier to change the Master Password on the IOS version as this is something people should be encouraged to do. Perhaps have the reset happen automatically?)

    Thanks for a great pair of apps, I totally rely on 1Password!

    Stephen
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Stephen! And thank you for the very kind words. :-)

    I'll see if we can't nail something down in this regard, but I will be honest that it is probably not a high priority because changing your master password often is actually not advised if you have a strong, unique one. If you have a good master password, don't share it with anyone, and don't reuse it it will last a lifetime. Jeff explains the technical details of this a bit more in depth in another forum thread.

    Thanks again for the feedback!
This discussion has been closed.