Password field covered by keyboard in Safari extension

jszottenjszotten
edited December 2014 in iOS Beta

TestFlight beta: 502012
Phone: iPhone 5S

When triggering the extensiont on Safari and I'm prompted for password (possible separate bug - not prompted for fingerprint), the keyboard covered the input field.

Screenshot: http://share.capsulecrm.com/image/1F122B2y3U1V

Comments

  • I have encountered the same bug on the iPhone 6, but I have not been able to find out what is causing it exactly though since it only happens occasionally.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @jszotten, this is an area we've tried to resolve a few times in this 5.2 version series. Can you reproduce this consistently or does it happen intermittently like what @eh801 reported here?

    What about in the main app, did it prompt for Touch ID even if it didn't in the Safari extension?

  • @MikeT‌ It happens in 502013 as well.

    The main app just prompts for Touch ID so that's ok. Just the extension I'm having issues with. Seems to happen every time. It's not intermittent. Any logs or diagnostics I can send? What else can I try or test for you?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jszotten,

    It's actually difficult at the moment to collect the logs from the extension itself.

    Can you tell me the security settings you've configured in the 1Password app, so I can try to reproduce it on my iPhone 5S. It'd be easier to take a screenshot of the Security settings view.

    Also, can you tell me which iOS version you're running on the iPhone 5S, so I can match it up as much as possible.

    Thanks!

  • @MikeT‌ I'm running iOS 8.1.2

    Screenshot: http://share.capsulecrm.com/image/0I0F1E1e4717

    I have an original iPad mini as well running the same OS and it doesn't happen there. It doesn't have TouchID however I'm prompted for my PIN instead of password which is what I'd expect. Could it be related to the screen size/res for some odd reason?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jszotten,

    Can you turn off Touch ID in 1Password, lock the app, and then kill Mobile Safari in the background. Open Safari again, does 1Password show up properly with the keyboard?

  • Sorry no, that didn't make a difference. I tried restarting the phone as well - didn't help either. Anything else I can try?

  • RadRad 1Password Alumni

    Hi @jszotten‌,

    Do you have both the TestFlight and the HockeyApp versions of 1Password installed on your iPhone?

    By the looks of it you are invoking the HockeyApp versions of 1Password beta extension and not the TestFlight one.

    Notice that only the HockeyApp public beta displays "1Password Beta", the TestFlight beta displays "1Password".

    Can you please confirm that the Master Password field is visible in the TestFlight beta?

    Cheers!

  • Wow - I feel like such an idiot. You're absolutely right. I really apologise about the wild goose chase. Consider this resolved. Again I'm so sorry

  • MeganMegan 1Password Alumni

    Hi @jszotten,

    No need to apologize, I'm glad we figured this out, and we appreciate you taking the time to report this and helping us to track things down. :)

  • It appears the bug is not limited to the beta. An iPhone 5 running the App Store version had the same problem where the password field was covered by the keyboard. If you were already aware of this then I suppose the bug has been squashed in the latest TestFlight beta. :)

  • On again another iPhone, a 5s with the App Store version there seems to be another UI bug; see photo.
    When the current beta gets public I will check whether the UI bugs are resolved.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @eh801,

    It was fixed in later TestFlight betas, I can't reproduce this. Please do let us know when you test 1Password 5.2 at the App Store, which is already in review at Apple. Hopefully, not too long of a wait.

This discussion has been closed.